aboutsummaryrefslogtreecommitdiff
path: root/devel/newtonsoft-json
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2015-03-12 18:40:35 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2015-03-12 18:40:35 +0000
commite296897f6502323ff4848693a46976ec1ada829e (patch)
tree47cdff8424f31caebdcf8f2d00d42c7aa72490e0 /devel/newtonsoft-json
parent9f55879596de9dd4360685ed285f827f00fceef7 (diff)
Notes
Diffstat (limited to 'devel/newtonsoft-json')
-rw-r--r--devel/newtonsoft-json/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/devel/newtonsoft-json/Makefile b/devel/newtonsoft-json/Makefile
index c500bb186681..272009ec27f1 100644
--- a/devel/newtonsoft-json/Makefile
+++ b/devel/newtonsoft-json/Makefile
@@ -25,15 +25,15 @@ PLIST_FILES= lib/mono/Newtonsoft.Json/Newtonsoft.Json.dll \
libdata/pkgconfig/Newtonsoft.Json.pc
do-build:
- (cd ${WRKSRC}/Src/Newtonsoft.Json && xbuild Newtonsoft.Json.csproj \
+ (cd ${WRKSRC}/Src/Newtonsoft.Json && ${SETENV} ${MAKE_ENV} xbuild Newtonsoft.Json.csproj \
/property:SignAssembly=true \
/property:AssemblyOriginatorKeyFile=Dynamic.snk \
/property:Configuration=Release \
/property:DefineConstants='SIGNED NET45 TRACE')
(cd ${WRKSRC}/Src/Newtonsoft.Json/bin/Release/Net45 && \
- monodis Newtonsoft.Json.dll --output=Newtonsoft.Json.il)
+ ${SETENV} ${MAKE_ENV} monodis Newtonsoft.Json.dll --output=Newtonsoft.Json.il)
(cd ${WRKSRC}/Src/Newtonsoft.Json/bin/Release/Net45 && \
- ilasm /dll /key:../../../Dynamic.snk Newtonsoft.Json.il)
+ ${SETENV} ${MAKE_ENV} ilasm /dll /key:../../../Dynamic.snk Newtonsoft.Json.il)
do-install:
(cd ${WRKSRC}/Src/Newtonsoft.Json/bin/Release/Net45 && \