aboutsummaryrefslogtreecommitdiff
path: root/devel/notify-sharp/Makefile
diff options
context:
space:
mode:
authorRomain Tartière <romain@FreeBSD.org>2011-06-12 18:59:59 +0000
committerRomain Tartière <romain@FreeBSD.org>2011-06-12 18:59:59 +0000
commitbc4b2ebe15c1e9bbc40adb784562f853c988138e (patch)
tree07e624140c74af3bbf595bf3c0a61b773a28d4a6 /devel/notify-sharp/Makefile
parent2fbd3ff653d887ffafef7ac5aac1df682e515bc4 (diff)
downloadports-bc4b2ebe15c1e9bbc40adb784562f853c988138e.tar.gz
ports-bc4b2ebe15c1e9bbc40adb784562f853c988138e.zip
Notes
Diffstat (limited to 'devel/notify-sharp/Makefile')
-rw-r--r--devel/notify-sharp/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/devel/notify-sharp/Makefile b/devel/notify-sharp/Makefile
new file mode 100644
index 000000000000..f05d779d0e5e
--- /dev/null
+++ b/devel/notify-sharp/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: notify-sharp
+# Date created: 2008-08-05
+# Whom: Romain Tartiere <romain@blogreen.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= notify-sharp
+PORTVERSION= 0.4.0
+CATEGORIES= devel
+MASTER_SITES= http://romain.blogreen.org/distfiles/
+
+MAINTAINER= mono@FreeBSD.org
+COMMENT= C\# client library for notification-daemon
+
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/ndesk-dbus-glib-1.0.pc:${PORTSDIR}/devel/ndesk-dbus-glib
+RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/ndesk-dbus-glib-1.0.pc:${PORTSDIR}/devel/ndesk-dbus-glib \
+ ${LOCALBASE}/share/dbus-1/services/org.freedesktop.Notifications.service:${PORTSDIR}/deskutils/notification-daemon
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= gnomehack gtksharp20
+
+.include <bsd.port.mk>