aboutsummaryrefslogtreecommitdiff
path: root/devel/npth
diff options
context:
space:
mode:
authorMichael Scheidell <scheidell@FreeBSD.org>2012-08-14 12:04:40 +0000
committerMichael Scheidell <scheidell@FreeBSD.org>2012-08-14 12:04:40 +0000
commit37b155e4e874e1ac2f4254cc015fdd5399459d93 (patch)
tree092637138c71c97b7f29e8b868b9e3ff0cf403bb /devel/npth
parent3e902415715c6da10da51cd876f6f152f1853b01 (diff)
downloadports-37b155e4e874e1ac2f4254cc015fdd5399459d93.tar.gz
ports-37b155e4e874e1ac2f4254cc015fdd5399459d93.zip
Notes
Diffstat (limited to 'devel/npth')
-rw-r--r--devel/npth/Makefile29
-rw-r--r--devel/npth/distinfo2
-rw-r--r--devel/npth/pkg-descr11
-rw-r--r--devel/npth/pkg-plist7
4 files changed, 49 insertions, 0 deletions
diff --git a/devel/npth/Makefile b/devel/npth/Makefile
new file mode 100644
index 000000000000..b74f8aac4bfd
--- /dev/null
+++ b/devel/npth/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: npth
+# Date Created: 2012-08-12
+# Whom: Jason E. Hale <bsdkaffee@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= npth
+PORTVERSION= 0.91
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_GNUPG}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= bsdkaffee@gmail.com
+COMMENT= New GNU Portable Threads
+
+LICENSE= LGPL3 GPLv2
+LICENSE_COMB= dual
+
+USE_BZIP2= yes
+USE_AUTOTOOLS= libtool
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= ac_cv_search_pthread_create=""
+CFLAGS+= ${PTHREAD_CFLAGS}
+LDFLAGS+= ${PTHREAD_LIBS}
+MAKE_JOBS_SAFE= yes
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/devel/npth/distinfo b/devel/npth/distinfo
new file mode 100644
index 000000000000..310283010e29
--- /dev/null
+++ b/devel/npth/distinfo
@@ -0,0 +1,2 @@
+SHA256 (npth-0.91.tar.bz2) = caef86ced4a331e162897818a5b924860c8d6003e52da5bdf76da00e8e0dfae1
+SIZE (npth-0.91.tar.bz2) = 299702
diff --git a/devel/npth/pkg-descr b/devel/npth/pkg-descr
new file mode 100644
index 000000000000..65500c63682f
--- /dev/null
+++ b/devel/npth/pkg-descr
@@ -0,0 +1,11 @@
+nPth - The New GNU Portable Threads Library
+
+This is a library to provide the GNU Pth API and thus a non-preemptive threads
+implementation.
+
+In contrast to GNU Pth is is based on the system's standard threads
+implementation. This allows the use of libraries which are not compatible to
+GNU Pth. Experience with a Windows Pth emulation showed that this is a solid
+way to provide a co-routine based framework.
+
+WWW: http://www.gnupg.org
diff --git a/devel/npth/pkg-plist b/devel/npth/pkg-plist
new file mode 100644
index 000000000000..f6ff4373e4c8
--- /dev/null
+++ b/devel/npth/pkg-plist
@@ -0,0 +1,7 @@
+bin/npth-config
+include/npth.h
+lib/libnpth.a
+lib/libnpth.la
+lib/libnpth.so
+lib/libnpth.so.0
+share/aclocal/npth.m4