aboutsummaryrefslogtreecommitdiff
path: root/devel/nx/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2005-04-13 07:38:04 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2005-04-13 07:38:04 +0000
commit3f61220f6c93d9bb5914e35812e78b79594f2441 (patch)
treede0af4ae0530774241f812e0b80984a74779268b /devel/nx/Makefile
parentddce896694bfc5a028c2181a588860bec4884e82 (diff)
Notes
Diffstat (limited to 'devel/nx/Makefile')
-rw-r--r--devel/nx/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/devel/nx/Makefile b/devel/nx/Makefile
new file mode 100644
index 000000000000..f221e3ed1def
--- /dev/null
+++ b/devel/nx/Makefile
@@ -0,0 +1,41 @@
+# ex:ts=8
+# Ports collection makefile for: NetworkX
+# Date created: Apr 13, 2005
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= nx
+PORTVERSION= 0.2
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= networkx
+DISTNAME= ${PORTNAME:U}-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A Python package for the networks (graph)
+
+BUILD_DEPENDS= ${PYNUMERIC} \
+ ${PYTHON_SITELIBDIR}/pygsl/__init__.py:${PORTSDIR}/math/py-gsl \
+ ipython:${PORTSDIR}/devel/ipython \
+ ${PYTHON_SITELIBDIR}/matplotlib/__init__.py:${PORTSDIR}/math/py-matplotlib \
+ ${PYTHON_SITELIBDIR}/pydot.py:${PORTSDIR}/graphics/py-pydot \
+ dot:${PORTSDIR}/graphics/graphviz
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PYTHON= 2.3+
+USE_PYDISTUTILS= yes
+DATADIR= ${PREFIX}/share/${PORTNAME:U}
+
+.include <bsd.port.pre.mk>
+
+post-install:
+.for d in ${DATADIR} ${PYTHON_SITELIBDIR}/NX
+ @${FIND} ${d} ! -type d | \
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${d} -type d | ${SORT} -r | \
+ ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
+.endfor
+
+.include <bsd.port.post.mk>