aboutsummaryrefslogtreecommitdiff
path: root/devel/oaf/Makefile
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2000-06-01 20:16:24 +0000
committerAde Lovett <ade@FreeBSD.org>2000-06-01 20:16:24 +0000
commitdf757445b02967d8a266058a6e2344044420d523 (patch)
tree7110f97b889d4dc60b962e1ade0017b87d6816eb /devel/oaf/Makefile
parentff874b3b39d968bc469ba9d7762df8e043756dc1 (diff)
downloadports-df757445b02967d8a266058a6e2344044420d523.tar.gz
ports-df757445b02967d8a266058a6e2344044420d523.zip
Notes
Diffstat (limited to 'devel/oaf/Makefile')
-rw-r--r--devel/oaf/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/devel/oaf/Makefile b/devel/oaf/Makefile
new file mode 100644
index 000000000000..5cf39398d680
--- /dev/null
+++ b/devel/oaf/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: oaf
+# Date created: 1st June 2000
+# Whom: Ade Lovett <ade@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= oaf
+PORTVERSION= 0.3.0
+CATEGORIES= devel gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= unstable/sources/oaf
+
+MAINTAINER= ade@FreeBSD.org
+
+LIB_DEPENDS= glib12.3:${PORTSDIR}/devel/glib12 \
+ ORBit.2:${PORTSDIR}/devel/ORBit \
+ popt.0:${PORTSDIR}/devel/popt
+
+GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
+ --datadir=${PREFIX}/share/gnome \
+ --enable-static --enable-shared
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ GLIB_CONFIG="${GLIB_CONFIG}" \
+ LIBS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>