aboutsummaryrefslogtreecommitdiff
path: root/devel/oaf
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-09-11 07:41:34 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-09-11 07:41:34 +0000
commit0a6d9ef5dfb993682e0f0a309d63ed2708e86611 (patch)
tree2fec503d4fd227f74a884c5fb229c85915778928 /devel/oaf
parent412fb3b18e5244593f3f5dcacdd6659e38e227fb (diff)
downloadports-0a6d9ef5dfb993682e0f0a309d63ed2708e86611.tar.gz
ports-0a6d9ef5dfb993682e0f0a309d63ed2708e86611.zip
Notes
Diffstat (limited to 'devel/oaf')
-rw-r--r--devel/oaf/Makefile9
-rw-r--r--devel/oaf/distinfo2
-rw-r--r--devel/oaf/files/patch-liboaf::oaf-fork-server.c (renamed from devel/oaf/files/patch-liboaf::oaf-registration.c)6
-rw-r--r--devel/oaf/files/patch-ltmain.sh18
-rw-r--r--devel/oaf/pkg-plist4
5 files changed, 30 insertions, 9 deletions
diff --git a/devel/oaf/Makefile b/devel/oaf/Makefile
index 753de7f3dba8..262806411867 100644
--- a/devel/oaf/Makefile
+++ b/devel/oaf/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= oaf
-PORTVERSION= 0.6.5
-PORTREVISION= 1
+PORTVERSION= 0.6.6
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= unstable/sources/oaf
+MASTER_SITE_SUBDIR= stable/sources/oaf
MAINTAINER= gnome@FreeBSD.org
@@ -19,7 +18,7 @@ LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GLIB= yes
-USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
USE_GNOMELIBS= yes
CONFIGURE_ARGS= --enable-static --enable-shared \
@@ -30,7 +29,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
diff --git a/devel/oaf/distinfo b/devel/oaf/distinfo
index eaafaed028d4..374a64edc561 100644
--- a/devel/oaf/distinfo
+++ b/devel/oaf/distinfo
@@ -1 +1 @@
-MD5 (oaf-0.6.5.tar.gz) = 23bfa9046d8d745d7cd17ad75fb08aed
+MD5 (oaf-0.6.6.tar.gz) = ae0150ee506d8b9a9f7b7edd7e1b87f4
diff --git a/devel/oaf/files/patch-liboaf::oaf-registration.c b/devel/oaf/files/patch-liboaf::oaf-fork-server.c
index 4282b650725b..cd70c728e75a 100644
--- a/devel/oaf/files/patch-liboaf::oaf-registration.c
+++ b/devel/oaf/files/patch-liboaf::oaf-fork-server.c
@@ -1,9 +1,9 @@
$FreeBSD$
---- liboaf/oaf-registration.c 2001/09/04 11:05:52 1.1
-+++ liboaf/oaf-registration.c 2001/09/04 11:06:15
-@@ -395,6 +395,7 @@
+--- liboaf/oaf-fork-server.c 2001/09/06 07:05:36 1.1
++++ liboaf/oaf-fork-server.c 2001/09/06 07:06:12
+@@ -267,6 +267,7 @@
if (od_iorstr)
oaf_setenv ("OAF_OD_IOR", od_iorstr);
diff --git a/devel/oaf/files/patch-ltmain.sh b/devel/oaf/files/patch-ltmain.sh
new file mode 100644
index 000000000000..33bc7983f107
--- /dev/null
+++ b/devel/oaf/files/patch-ltmain.sh
@@ -0,0 +1,18 @@
+
+$FreeBSD$
+
+--- ltmain.sh 2001/08/27 09:51:26 1.1
++++ ltmain.sh 2001/08/27 09:51:42
+@@ -4175,10 +4175,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/devel/oaf/pkg-plist b/devel/oaf/pkg-plist
index 2050f8663a7b..1775b16b5d27 100644
--- a/devel/oaf/pkg-plist
+++ b/devel/oaf/pkg-plist
@@ -1,5 +1,6 @@
bin/oaf-client
bin/oaf-config
+bin/oaf-empty-server
bin/oaf-run-query
bin/oaf-slay
bin/oaf-sysconf
@@ -39,6 +40,7 @@ share/locale/hu/LC_MESSAGES/oaf.mo
share/locale/it/LC_MESSAGES/oaf.mo
share/locale/ja/LC_MESSAGES/oaf.mo
share/locale/ko/LC_MESSAGES/oaf.mo
+share/locale/nn/LC_MESSAGES/oaf.mo
share/locale/no/LC_MESSAGES/oaf.mo
share/locale/pl/LC_MESSAGES/oaf.mo
share/locale/pt_BR/LC_MESSAGES/oaf.mo
@@ -47,8 +49,10 @@ share/locale/ru/LC_MESSAGES/oaf.mo
share/locale/sk/LC_MESSAGES/oaf.mo
share/locale/sl/LC_MESSAGES/oaf.mo
share/locale/sv/LC_MESSAGES/oaf.mo
+share/locale/ta/LC_MESSAGES/oaf.mo
share/locale/tr/LC_MESSAGES/oaf.mo
share/locale/uk/LC_MESSAGES/oaf.mo
+share/locale/zh_TW.Big5/LC_MESSAGES/oaf.mo
@dirrm share/gnome/oaf/html/liboaf
@dirrm share/gnome/oaf/html
@unexec rmdir %D/share/gnome/oaf 2>/dev/null || true