aboutsummaryrefslogtreecommitdiff
path: root/devel/oaf
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2002-04-18 14:01:11 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2002-04-18 14:01:11 +0000
commit098dfd1acc0916a679a9cbe3239f6eb437675bb5 (patch)
tree423dd98b4ebd7b0416ea99f26a25b3f368a6c8b3 /devel/oaf
parent496eac255b881bdf00cae1699709d4d1df9a618a (diff)
downloadports-098dfd1acc0916a679a9cbe3239f6eb437675bb5.tar.gz
ports-098dfd1acc0916a679a9cbe3239f6eb437675bb5.zip
Notes
Diffstat (limited to 'devel/oaf')
-rw-r--r--devel/oaf/Makefile10
-rw-r--r--devel/oaf/distinfo2
-rw-r--r--devel/oaf/files/patch-oafd::qsort_ex.c14
3 files changed, 7 insertions, 19 deletions
diff --git a/devel/oaf/Makefile b/devel/oaf/Makefile
index 78246f67cedc..3905b08914b8 100644
--- a/devel/oaf/Makefile
+++ b/devel/oaf/Makefile
@@ -6,16 +6,17 @@
#
PORTNAME= oaf
-PORTVERSION= 0.6.8
-PORTREVISION= 1
+PORTVERSION= 0.6.10
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= stable/sources/oaf
+DIST_SUBDIR= gnome
MAINTAINER= gnome@FreeBSD.org
LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
+USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GLIB= yes
@@ -23,11 +24,12 @@ GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
USE_GNOMELIBS= yes
CONFIGURE_ARGS= --enable-static --enable-shared \
- --disable-more-warnings
+ --disable-more-warnings --disable-gtk-doc
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib -lintl"
+CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
-MAN1= oafd.1
+MAN1= oafd.1
pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
diff --git a/devel/oaf/distinfo b/devel/oaf/distinfo
index ef95364078cb..8f27179015ce 100644
--- a/devel/oaf/distinfo
+++ b/devel/oaf/distinfo
@@ -1 +1 @@
-MD5 (oaf-0.6.8.tar.gz) = d1a7cd8cd87b78fe049c225d4f0a7f1e
+MD5 (gnome/oaf-0.6.10.tar.bz2) = ed9aa2ceb70bba34034b3134b22d2729
diff --git a/devel/oaf/files/patch-oafd::qsort_ex.c b/devel/oaf/files/patch-oafd::qsort_ex.c
deleted file mode 100644
index 4a4141a7c436..000000000000
--- a/devel/oaf/files/patch-oafd::qsort_ex.c
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- oafd/qsort_ex.c 2001/11/07 11:18:59 1.1
-+++ oafd/qsort_ex.c 2001/11/07 11:19:28
-@@ -26,7 +26,7 @@
- #include <string.h>
- #include "qsort_ex.h"
-
--#if HAVE_ALLOCA
-+#if HAVE_ALLOCA_H
- #include <alloca.h>
- #endif
-