aboutsummaryrefslogtreecommitdiff
path: root/devel/ocaml-camomile/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-03-19 02:33:23 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-03-19 02:33:23 +0000
commita4d2565ccba5efa58ca32d7f2b463f5dc4a044c2 (patch)
tree547545a8f5644cfc1812851f3b767e0dd77c4ddc /devel/ocaml-camomile/Makefile
parentfd71a26ec53022f723fb6043ac8360d839c97d5c (diff)
downloadports-a4d2565ccba5efa58ca32d7f2b463f5dc4a044c2.tar.gz
ports-a4d2565ccba5efa58ca32d7f2b463f5dc4a044c2.zip
Notes
Diffstat (limited to 'devel/ocaml-camomile/Makefile')
-rw-r--r--devel/ocaml-camomile/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/devel/ocaml-camomile/Makefile b/devel/ocaml-camomile/Makefile
new file mode 100644
index 000000000000..3ccab9713553
--- /dev/null
+++ b/devel/ocaml-camomile/Makefile
@@ -0,0 +1,38 @@
+# ex:ts=8
+# Ports collection makefile for: camomile
+# Date created: Mar 17, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= camomile
+PORTVERSION= 0.4.2
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= ocaml-
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A comprehensive Unicode library for objective caml language
+
+BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml \
+ ocamlfind:${PORTSDIR}/devel/ocaml-findlib
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+PKGDEINSTALL= ${PKGINSTALL}
+
+post-install:
+ @${FIND} ${PREFIX}/lib/ocaml/site-lib/${PORTNAME} -type f | \
+ ${SED} "s,^${PREFIX}/,," >> ${TMPPLIST}
+ @${ECHO_CMD} "@dirrm lib/ocaml/site-lib/${PORTNAME}" >> ${TMPPLIST}
+ @${ECHO_CMD} "@unexec ocamlfind remove ${PORTNAME} 2>/dev/null || true" >> ${TMPPLIST}
+ @${FIND} ${DATADIR} -type f | \
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${DATADIR} -type d | ${SORT} -r | \
+ ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
+
+.include <bsd.port.mk>