aboutsummaryrefslogtreecommitdiff
path: root/devel/ocaml-camomile
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-08-04 15:19:12 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-08-04 15:19:12 +0000
commit38a294bdcec119bb429297a24cef5e937757c55a (patch)
treecf5171e21b242ecb18939482c37f147b2e2f28cf /devel/ocaml-camomile
parent23d520e4ddf2f1557b392a7393c7e190755c87bc (diff)
downloadports-38a294bdcec119bb429297a24cef5e937757c55a.tar.gz
ports-38a294bdcec119bb429297a24cef5e937757c55a.zip
Notes
Diffstat (limited to 'devel/ocaml-camomile')
-rw-r--r--devel/ocaml-camomile/Makefile32
-rw-r--r--devel/ocaml-camomile/distinfo6
-rw-r--r--devel/ocaml-camomile/files/patch-Makefile.in15
-rw-r--r--devel/ocaml-camomile/pkg-install9
4 files changed, 20 insertions, 42 deletions
diff --git a/devel/ocaml-camomile/Makefile b/devel/ocaml-camomile/Makefile
index bb0e93de94e7..952872226baa 100644
--- a/devel/ocaml-camomile/Makefile
+++ b/devel/ocaml-camomile/Makefile
@@ -7,40 +7,36 @@
#
PORTNAME= camomile
-PORTVERSION= 0.6.5
+PORTVERSION= 0.6.6
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
PKGNAMEPREFIX= ocaml-
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ssedov@mbsd.msk.ru
COMMENT= A comprehensive Unicode library for objective caml language
-BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml \
- ocamlfind:${PORTSDIR}/devel/ocaml-findlib
-RUN_DEPENDS= ${BUILD_DEPENDS}
-
USE_BZIP2= yes
-GNU_CONFIGURE= yes
USE_GMAKE= yes
+USE_OCAML= yes
+USE_OCAML_FINDLIB=yes
+USE_OCAML_LDCONFIG=yes
+GNU_CONFIGURE= yes
-PKGDEINSTALL= ${PKGINSTALL}
+DOCSDIR= ${PREFIX}/share/doc/ocaml/${PORTNAME}
+EXAMPLESDIR= ${PREFIX}/share/examples/ocaml/${PORTNAME}
.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/lang/ocaml/bsd.ocaml.mk"
.if ${OSVERSION} < 500000
BROKEN= Need working <wctype.h>
.endif
-post-install:
- ${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
- @${FIND} ${PREFIX}/lib/ocaml/site-lib/${PORTNAME} -type f | \
- ${SED} "s,^${PREFIX}/,," >> ${TMPPLIST}
- @${ECHO_CMD} "@dirrm lib/ocaml/site-lib/${PORTNAME}" >> ${TMPPLIST}
- @${ECHO_CMD} "@unexec ocamlfind remove ${PORTNAME} 2>/dev/null || true" >> ${TMPPLIST}
- @${FIND} ${DATADIR} -type f | \
- ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
- @${FIND} ${DATADIR} -type d | ${SORT} -r | \
- ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
+post-extract:
+ @${CP} ${WRKSRC}/META ${WRKSRC}/META.in
+ @${REINPLACE_CMD} -E -e \
+ "s,([[:space:]]*)cp[[:space:]]*-f,\1\$${BSD_INSTALL_DATA}," \
+ ${WRKSRC}/Makefile.in
.include <bsd.port.post.mk>
diff --git a/devel/ocaml-camomile/distinfo b/devel/ocaml-camomile/distinfo
index 1d504ea0be10..368abe6b64e4 100644
--- a/devel/ocaml-camomile/distinfo
+++ b/devel/ocaml-camomile/distinfo
@@ -1,3 +1,3 @@
-MD5 (camomile-0.6.5.tar.bz2) = fef19a044389255929943a502b29218d
-SHA256 (camomile-0.6.5.tar.bz2) = ee599ec97b21aa7c4a8624b417f4932d6d5ed9f238a9ecf1c7b14ff754f4886b
-SIZE (camomile-0.6.5.tar.bz2) = 2135932
+MD5 (camomile-0.6.6.tar.bz2) = 3b4f19bc172189c17254e74abaa9644c
+SHA256 (camomile-0.6.6.tar.bz2) = 1de5d220dedc5684117aee4d7372e82358f01134bef131c8aeb1d25240d1c23f
+SIZE (camomile-0.6.6.tar.bz2) = 2124681
diff --git a/devel/ocaml-camomile/files/patch-Makefile.in b/devel/ocaml-camomile/files/patch-Makefile.in
index 2343e8bf935e..f108a36512e7 100644
--- a/devel/ocaml-camomile/files/patch-Makefile.in
+++ b/devel/ocaml-camomile/files/patch-Makefile.in
@@ -1,19 +1,10 @@
---- ./Makefile.in.orig Mon Mar 13 13:17:35 2006
-+++ ./Makefile.in Thu Jul 27 14:49:46 2006
-@@ -367,7 +367,7 @@
- install-without-ocamlfind:
- mkdir -p $(OCAMLLIB)
- cp -f $(INT) $(OCAMLLIB)
-- if [ $(OCAMLBEST) == opt ]; then cp -f public/*.cmx $(OCAMLLIB); fi
-+ if [ "$(OCAMLBEST)" = "opt" ]; then cp -f public/*.cmx $(OCAMLLIB); fi
- if [ -f camomile.cmi ]; then cp -f camomile.cmi $(OCAMLLIB); fi
- if [ -f camomile.cma ]; then cp -f camomile.cma $(OCAMLLIB); fi
- if [ -f camomile.cmxa ]; then cp -f camomile.cmxa $(OCAMLLIB); fi
+--- Makefile.in.orig Tue Aug 1 16:47:03 2006
++++ Makefile.in Tue Aug 1 16:47:47 2006
@@ -378,7 +378,7 @@
install-with-ocamlfind:
files= &&\
-- if [ $(OCAMLBEST) == opt ]; then files=public/*.cmx; fi && \
+- if [ $(OCAMLBEST) = opt ]; then files=public/*.cmx; fi && \
+ if [ "$(OCAMLBEST)" = "opt" ]; then files=public/*.cmx; fi && \
if [ -f camomile.cma ]; then files="camomile.* $$files"; fi&& \
if [ -f libcamomile.a ]; then files="libcamomile.a $$files"; fi && \
diff --git a/devel/ocaml-camomile/pkg-install b/devel/ocaml-camomile/pkg-install
deleted file mode 100644
index 6ff19f476711..000000000000
--- a/devel/ocaml-camomile/pkg-install
+++ /dev/null
@@ -1,9 +0,0 @@
-#!/bin/sh
-
-if [ "$2" = "POST-INSTALL" ]; then
- echo "${PKG_PREFIX}/lib/ocaml/site-lib/camomile" >> ${PKG_PREFIX}/lib/ocaml/ld.conf
-elif [ "$2" = "DEINSTALL" ]; then
- mv ${PKG_PREFIX}/lib/ocaml/ld.conf ${PKG_PREFIX}/lib/ocaml/ld.conf.tmp
- grep -v camomile ${PKG_PREFIX}/lib/ocaml/ld.conf.tmp > ${PKG_PREFIX}/lib/ocaml/ld.conf
- rm -f ${PKG_PREFIX}/lib/ocaml/ld.conf.tmp
-fi