aboutsummaryrefslogtreecommitdiff
path: root/devel/ocaml-camomile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2006-07-27 13:29:40 +0000
committerThierry Thomas <thierry@FreeBSD.org>2006-07-27 13:29:40 +0000
commit83233cbe71da7718652059a82817953520e227e3 (patch)
tree2000ac8605e20af1ba4297df24754dd8677d20a5 /devel/ocaml-camomile
parent31ebb4ed643a827caea54bc9ba4e5a841d797cbd (diff)
downloadports-83233cbe71da7718652059a82817953520e227e3.tar.gz
ports-83233cbe71da7718652059a82817953520e227e3.zip
Notes
Diffstat (limited to 'devel/ocaml-camomile')
-rw-r--r--devel/ocaml-camomile/Makefile8
-rw-r--r--devel/ocaml-camomile/distinfo6
-rw-r--r--devel/ocaml-camomile/files/patch-META11
-rw-r--r--devel/ocaml-camomile/files/patch-Makefile.in20
4 files changed, 27 insertions, 18 deletions
diff --git a/devel/ocaml-camomile/Makefile b/devel/ocaml-camomile/Makefile
index 85f780318d8c..bb0e93de94e7 100644
--- a/devel/ocaml-camomile/Makefile
+++ b/devel/ocaml-camomile/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= camomile
-PORTVERSION= 0.5.3
+PORTVERSION= 0.6.5
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -18,8 +18,7 @@ COMMENT= A comprehensive Unicode library for objective caml language
BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml \
ocamlfind:${PORTSDIR}/devel/ocaml-findlib
-
-BROKEN= Does not build
+RUN_DEPENDS= ${BUILD_DEPENDS}
USE_BZIP2= yes
GNU_CONFIGURE= yes
@@ -30,10 +29,11 @@ PKGDEINSTALL= ${PKGINSTALL}
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
-BROKEN= "Need working <wctype.h>"
+BROKEN= Need working <wctype.h>
.endif
post-install:
+ ${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${FIND} ${PREFIX}/lib/ocaml/site-lib/${PORTNAME} -type f | \
${SED} "s,^${PREFIX}/,," >> ${TMPPLIST}
@${ECHO_CMD} "@dirrm lib/ocaml/site-lib/${PORTNAME}" >> ${TMPPLIST}
diff --git a/devel/ocaml-camomile/distinfo b/devel/ocaml-camomile/distinfo
index 92ddaeb214f5..1d504ea0be10 100644
--- a/devel/ocaml-camomile/distinfo
+++ b/devel/ocaml-camomile/distinfo
@@ -1,3 +1,3 @@
-MD5 (camomile-0.5.3.tar.bz2) = 550ae2de1f6660312f9f4549061a95cb
-SHA256 (camomile-0.5.3.tar.bz2) = d7f6aa1514ee4f2ee8c2d0e46b7bc65b149de5e5ab2e5115383df7379f32befe
-SIZE (camomile-0.5.3.tar.bz2) = 2138256
+MD5 (camomile-0.6.5.tar.bz2) = fef19a044389255929943a502b29218d
+SHA256 (camomile-0.6.5.tar.bz2) = ee599ec97b21aa7c4a8624b417f4932d6d5ed9f238a9ecf1c7b14ff754f4886b
+SIZE (camomile-0.6.5.tar.bz2) = 2135932
diff --git a/devel/ocaml-camomile/files/patch-META b/devel/ocaml-camomile/files/patch-META
deleted file mode 100644
index e130824c26b8..000000000000
--- a/devel/ocaml-camomile/files/patch-META
+++ /dev/null
@@ -1,11 +0,0 @@
---- META Wed Jul 14 17:00:05 2004
-+++ META.1 Tue Aug 10 22:27:49 2004
-@@ -8,7 +8,7 @@
-
- package "unpack"
- (name="unpack"
-- varison="0.5.3"
-+ version="0.5.3"
- description="Unicode library for ocaml (not packed)"
- requires="bigarray"
- archive(byte)="camomileunpack.cma"
diff --git a/devel/ocaml-camomile/files/patch-Makefile.in b/devel/ocaml-camomile/files/patch-Makefile.in
new file mode 100644
index 000000000000..2343e8bf935e
--- /dev/null
+++ b/devel/ocaml-camomile/files/patch-Makefile.in
@@ -0,0 +1,20 @@
+--- ./Makefile.in.orig Mon Mar 13 13:17:35 2006
++++ ./Makefile.in Thu Jul 27 14:49:46 2006
+@@ -367,7 +367,7 @@
+ install-without-ocamlfind:
+ mkdir -p $(OCAMLLIB)
+ cp -f $(INT) $(OCAMLLIB)
+- if [ $(OCAMLBEST) == opt ]; then cp -f public/*.cmx $(OCAMLLIB); fi
++ if [ "$(OCAMLBEST)" = "opt" ]; then cp -f public/*.cmx $(OCAMLLIB); fi
+ if [ -f camomile.cmi ]; then cp -f camomile.cmi $(OCAMLLIB); fi
+ if [ -f camomile.cma ]; then cp -f camomile.cma $(OCAMLLIB); fi
+ if [ -f camomile.cmxa ]; then cp -f camomile.cmxa $(OCAMLLIB); fi
+@@ -378,7 +378,7 @@
+
+ install-with-ocamlfind:
+ files= &&\
+- if [ $(OCAMLBEST) == opt ]; then files=public/*.cmx; fi && \
++ if [ "$(OCAMLBEST)" = "opt" ]; then files=public/*.cmx; fi && \
+ if [ -f camomile.cma ]; then files="camomile.* $$files"; fi&& \
+ if [ -f libcamomile.a ]; then files="libcamomile.a $$files"; fi && \
+ if [ -f dllcamomile.so ]; then files="dllcamomile.so $$files"; fi && \