aboutsummaryrefslogtreecommitdiff
path: root/devel/ocaml-extlib
diff options
context:
space:
mode:
authorMarcelo Araujo <araujo@FreeBSD.org>2012-12-20 05:45:56 +0000
committerMarcelo Araujo <araujo@FreeBSD.org>2012-12-20 05:45:56 +0000
commite617f7923b2e09ff050d045ba7c72d8bb700bb2f (patch)
tree7692e01681ba7338e63d3cc7b8d13fcac958a281 /devel/ocaml-extlib
parentcbc12636c36acd60a0d86371a49f76bb7b84fed7 (diff)
downloadports-e617f7923b2e09ff050d045ba7c72d8bb700bb2f.tar.gz
ports-e617f7923b2e09ff050d045ba7c72d8bb700bb2f.zip
Notes
Diffstat (limited to 'devel/ocaml-extlib')
-rw-r--r--devel/ocaml-extlib/Makefile43
-rw-r--r--devel/ocaml-extlib/distinfo4
-rw-r--r--devel/ocaml-extlib/pkg-plist45
3 files changed, 23 insertions, 69 deletions
diff --git a/devel/ocaml-extlib/Makefile b/devel/ocaml-extlib/Makefile
index a7c9653206b1..f828577a64cf 100644
--- a/devel/ocaml-extlib/Makefile
+++ b/devel/ocaml-extlib/Makefile
@@ -1,41 +1,40 @@
-# Ports collection makefile for: extlib
-# Date created: Nov 2, 2004
-# Whom: mukai
-#
+# Created by: mukai
# $FreeBSD$
-#
PORTNAME= extlib
-PORTVERSION= 1.5.2
+PORTVERSION= 1.5.3
CATEGORIES= devel
-MASTER_SITES= http://ocaml-extlib.googlecode.com/files/
-MASTER_SITE_SUBDIR= ocaml-lib
+MASTER_SITES= GOOGLE_CODE
+PROJECTHOST= ${PKGNAMEPREFIX}${PORTNAME}
PKGNAMEPREFIX= ocaml-
MAINTAINER= ports@FreeBSD.org
COMMENT= A complete - yet small - standard library for OCaml
-BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml \
- ocamlfind:${PORTSDIR}/devel/ocaml-findlib
+LICENSE= LGPL21
-USE_GMAKE= yes
-USE_DOS2UNIX= yes
-ALL_TARGET= all opt
+OPTIONS_DEFINE= DOCS
-.if !defined(NOPORTDOCS)
-ALL_TARGET+= doc
-.endif
+USE_OCAML= yes
+USE_OCAML_FINDLIB=yes
+USE_OCAMLFIND_PLIST=yes
+
+ALL_TARGET= all opt
+DOCSDIR= ${OCAML_DOCSDIR}/${PORTNAME}
PORTDOCS= *
-DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
-post-patch:
- @${REINPLACE_CMD} -e '/css/d' ${WRKSRC}/Makefile
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
+ALL_TARGET+= doc
+PLIST_DIRSTRY= ${OCAML_DOCSDIR:S,^${PREFIX}/,,}
+.endif
post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ (cd ${WRKSRC}/doc && ${INSTALL_DATA} * ${DOCSDIR})
.endif
.include <bsd.port.mk>
diff --git a/devel/ocaml-extlib/distinfo b/devel/ocaml-extlib/distinfo
index 150e512fcd11..8bbed7f835a3 100644
--- a/devel/ocaml-extlib/distinfo
+++ b/devel/ocaml-extlib/distinfo
@@ -1,2 +1,2 @@
-SHA256 (extlib-1.5.2.tar.gz) = ca6d69adeba4242ce41c02a23746ba1e464c0bbec66e2d16b02c3c6e85dc10aa
-SIZE (extlib-1.5.2.tar.gz) = 70197
+SHA256 (extlib-1.5.3.tar.gz) = c095eef4202a8614ff1474d4c08c50c32d6ca82d1015387785cf03d5913ec021
+SIZE (extlib-1.5.3.tar.gz) = 70897
diff --git a/devel/ocaml-extlib/pkg-plist b/devel/ocaml-extlib/pkg-plist
deleted file mode 100644
index facbb563b126..000000000000
--- a/devel/ocaml-extlib/pkg-plist
+++ /dev/null
@@ -1,45 +0,0 @@
-lib/ocaml/site-lib/extlib/IO.cmi
-lib/ocaml/site-lib/extlib/IO.mli
-lib/ocaml/site-lib/extlib/base64.cmi
-lib/ocaml/site-lib/extlib/base64.mli
-lib/ocaml/site-lib/extlib/bitSet.cmi
-lib/ocaml/site-lib/extlib/bitSet.mli
-lib/ocaml/site-lib/extlib/dllist.cmi
-lib/ocaml/site-lib/extlib/dllist.mli
-lib/ocaml/site-lib/extlib/dynArray.cmi
-lib/ocaml/site-lib/extlib/dynArray.mli
-lib/ocaml/site-lib/extlib/enum.cmi
-lib/ocaml/site-lib/extlib/enum.mli
-lib/ocaml/site-lib/extlib/extArray.cmi
-lib/ocaml/site-lib/extlib/extArray.mli
-lib/ocaml/site-lib/extlib/extHashtbl.cmi
-lib/ocaml/site-lib/extlib/extHashtbl.mli
-lib/ocaml/site-lib/extlib/extLib.cmi
-lib/ocaml/site-lib/extlib/extList.cmi
-lib/ocaml/site-lib/extlib/extList.mli
-lib/ocaml/site-lib/extlib/extString.cmi
-lib/ocaml/site-lib/extlib/extString.mli
-lib/ocaml/site-lib/extlib/global.cmi
-lib/ocaml/site-lib/extlib/global.mli
-lib/ocaml/site-lib/extlib/optParse.cmi
-lib/ocaml/site-lib/extlib/optParse.mli
-lib/ocaml/site-lib/extlib/option.cmi
-lib/ocaml/site-lib/extlib/option.mli
-lib/ocaml/site-lib/extlib/pMap.cmi
-lib/ocaml/site-lib/extlib/pMap.mli
-lib/ocaml/site-lib/extlib/refList.cmi
-lib/ocaml/site-lib/extlib/refList.mli
-lib/ocaml/site-lib/extlib/std.cmi
-lib/ocaml/site-lib/extlib/std.mli
-lib/ocaml/site-lib/extlib/uChar.cmi
-lib/ocaml/site-lib/extlib/uChar.mli
-lib/ocaml/site-lib/extlib/uTF8.cmi
-lib/ocaml/site-lib/extlib/uTF8.mli
-lib/ocaml/site-lib/extlib/unzip.cmi
-lib/ocaml/site-lib/extlib/unzip.mli
-lib/ocaml/site-lib/extlib/extLib.cma
-lib/ocaml/site-lib/extlib/extLib.cmxa
-lib/ocaml/site-lib/extlib/extLib.a
-lib/ocaml/site-lib/extlib/META
-@dirrm lib/ocaml/site-lib/extlib
-@dirrmtry lib/ocaml/site-lib