aboutsummaryrefslogtreecommitdiff
path: root/devel/ocaml-findlib
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2008-04-07 06:05:58 +0000
committerStanislav Sedov <stas@FreeBSD.org>2008-04-07 06:05:58 +0000
commitbaf0f911a523ca1f4d360ea86fde738207a981a0 (patch)
treec0e15c69c06374d835dd778c217aae4416c74a9f /devel/ocaml-findlib
parent3a64e6b04db66165ad5e659268327375678d7e05 (diff)
downloadports-baf0f911a523ca1f4d360ea86fde738207a981a0.tar.gz
ports-baf0f911a523ca1f4d360ea86fde738207a981a0.zip
Notes
Diffstat (limited to 'devel/ocaml-findlib')
-rw-r--r--devel/ocaml-findlib/Makefile55
-rw-r--r--devel/ocaml-findlib/distinfo6
-rw-r--r--devel/ocaml-findlib/files/patch-src_findlib_Makefile19
-rw-r--r--devel/ocaml-findlib/pkg-descr3
-rw-r--r--devel/ocaml-findlib/pkg-plist116
5 files changed, 164 insertions, 35 deletions
diff --git a/devel/ocaml-findlib/Makefile b/devel/ocaml-findlib/Makefile
index b69aadeb7de9..64e134fe6efd 100644
--- a/devel/ocaml-findlib/Makefile
+++ b/devel/ocaml-findlib/Makefile
@@ -7,10 +7,10 @@
#
PORTNAME= findlib
-PORTVERSION= 1.1.1
-PORTREVISION= 1
+PORTVERSION= 1.2.1
+PORTREVISION= 0
CATEGORIES= devel
-MASTER_SITES= http://www.ocaml-programming.de/packages/
+MASTER_SITES= http://download.camlcity.org/download/
PKGNAMEPREFIX= ocaml-
MAINTAINER= ports@FreeBSD.org
@@ -23,39 +23,32 @@ HAS_CONFIGURE= yes
USE_GMAKE= yes
ALL_TARGET= all opt
-PLIST_FILES= bin/ocamlfind etc/findlib.conf
+CONFIGURE_ARGS= -bindir "${PREFIX}/bin" -mandir "${PREFIX}/man" \
+ -sitelib "${PREFIX}/lib/ocaml/site-lib" \
+ -config "${PREFIX}/etc/findlib.conf"
+
+DOCSDIR= ${PREFIX}/share/doc/ocaml/${PORTNAME}
+
+PATTERN= [[:space:]]*(do|then)?[[:space:]]*)cp([[:space:]]
MAN1= ocamlfind.1
MAN5= META.5 findlib.conf.5 site-lib.5
-# this list comes from the findlib configure script
-OCAML_DIRS= dbm dynlink graphics num num-top str threads unix stdlib bigarray camlp4
-
-.if !defined(WITHOUT_X11)
-OCAML_DIRS+= labltk
-.endif
+post-patch:
+ @${REINPLACE_CMD} -E \
+ -e 's,(${PATTERN}+.*INSTALLDIR),\1\$${BSD_INSTALL_DATA} \3,' \
+ -e 's,(${PATTERN}+.*FIND_BIN),\1\$${BSD_INSTALL_SCRIPT} \3,' \
+ -e 's,(${PATTERN}+.*LIBBIN),\1\$${BSD_INSTALL_SCRIPT} \3,' \
+ -e 's,(${PATTERN}+.*FIND_CONF),\1\$${BSD_INSTALL_DATA} \3,' \
+ -e 's,(${PATTERN}+.*SITELIB),\1\$${BSD_INSTALL_DATA} \3,' \
+ ${WRKSRC}/Makefile ${WRKSRC}/src/findlib/Makefile \
+ ${WRKSRC}/src/findlib-toolbox/Makefile
post-install:
- @${FIND} ${PREFIX}/lib/ocaml/site-lib/findlib -type f | \
- ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
-
-.for D in ${OCAML_DIRS}
- @${FIND} ${PREFIX}/lib/ocaml/site-lib/$D -type f -name META | \
- ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
-.endfor
-
- ${ECHO_CMD} 'lib/ocaml/site-lib/num-top/num_top.cma' >> ${TMPPLIST}
- ${ECHO_CMD} 'lib/ocaml/site-lib/num-top/num_top.cmi' >> ${TMPPLIST}
- ${ECHO_CMD} 'lib/ocaml/site-lib/num-top/num_top_printers.cmi' >> ${TMPPLIST}
- ${ECHO_CMD} 'lib/ocaml/topfind' >> ${TMPPLIST}
-
- @${FIND} ${PREFIX}/lib/ocaml/site-lib/findlib -type d | ${SORT} -r | \
- ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
-
-.for D in ${OCAML_DIRS}
- ${ECHO_CMD} "@dirrm lib/ocaml/site-lib/$D" >> ${TMPPLIST}
-.endfor
-
- ${ECHO_CMD} '@dirrm lib/ocaml/site-lib' >> ${TMPPLIST}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} \* ${DOCSDIR} \
+ "! -regex .*ref-man.*")
+.endif
.include <bsd.port.mk>
diff --git a/devel/ocaml-findlib/distinfo b/devel/ocaml-findlib/distinfo
index 2dbe0003ab87..6cf595b5fd1e 100644
--- a/devel/ocaml-findlib/distinfo
+++ b/devel/ocaml-findlib/distinfo
@@ -1,3 +1,3 @@
-MD5 (findlib-1.1.1.tar.gz) = 5f5b1cea586d81d0e3d2d1eb84ebe28a
-SHA256 (findlib-1.1.1.tar.gz) = d2e0d99209c7768fe0c7dfab328cd73fb019338b50afdf62c6de6d6be7519cd9
-SIZE (findlib-1.1.1.tar.gz) = 152557
+MD5 (findlib-1.2.1.tar.gz) = fa580a4c1fc28c06fe79aa1c98b6ef2d
+SHA256 (findlib-1.2.1.tar.gz) = fe3db7c9f9707eb589e8f194ac4364f854e8a57aace826d59ee52cf9fa2a2a4e
+SIZE (findlib-1.2.1.tar.gz) = 158480
diff --git a/devel/ocaml-findlib/files/patch-src_findlib_Makefile b/devel/ocaml-findlib/files/patch-src_findlib_Makefile
new file mode 100644
index 000000000000..44f11d0657a2
--- /dev/null
+++ b/devel/ocaml-findlib/files/patch-src_findlib_Makefile
@@ -0,0 +1,19 @@
+--- src/findlib/Makefile.orig 2008-04-07 01:37:57.000000000 +0400
++++ src/findlib/Makefile 2008-04-07 01:38:45.000000000 +0400
+@@ -17,6 +17,7 @@
+ OCAMLLEX = ocamllex
+ CAMLP4O = camlp4 pa_o.cmo pa_op.cmo pr_o.cmo --
+ #CAMLP4O = camlp4 pa_o.cmo pa_op.cmo pr_dump.cmo --
++OCAML_LIBBIN=${PREFIX}/lib/ocaml
+
+
+ OBJECTS = findlib_config.cmo fl_split.cmo fl_metatoken.cmo fl_meta.cmo \
+@@ -80,7 +81,7 @@
+ install: all
+ mkdir -p $(prefix)$(OCAML_SITELIB)/$(NAME)
+ mkdir -p $(prefix)$(OCAMLFIND_BIN)
+- test $(INSTALL_TOPFIND) -eq 0 || cp topfind $(prefix)$(OCAML_CORE_STDLIB)
++ test $(INSTALL_TOPFIND) -eq 0 || cp topfind $(prefix)$(OCAML_LIBBIN)
+ files=`$(TOP)/tools/collect_files $(TOP)/Makefile.config findlib.cmi findlib.mli findlib.cma topfind.cmi topfind.mli fl_package_base.mli fl_package_base.cmi fl_metascanner.mli fl_metascanner.cmi findlib_top.cma findlib.cmxa findlib.a META` && \
+ ${BSD_INSTALL_DATA} $$files $(prefix)$(OCAML_SITELIB)/$(NAME)
+ f="ocamlfind$(EXEC_SUFFIX)"; { test -f ocamlfind_opt$(EXEC_SUFFIX) && f="ocamlfind_opt$(EXEC_SUFFIX)"; }; \
diff --git a/devel/ocaml-findlib/pkg-descr b/devel/ocaml-findlib/pkg-descr
index 97e6883ce8de..7de72a7a573a 100644
--- a/devel/ocaml-findlib/pkg-descr
+++ b/devel/ocaml-findlib/pkg-descr
@@ -10,4 +10,5 @@ the user to enter queries on the command-line. In order to simplify
compilation and linkage, there are new frontends of the various OCaml
compilers that can directly deal with packages.
-WWW: http://www.ocaml-programming.de/packages/documentation/findlib/
+Author: Gerd Stolpmann <gerd@gerd-stolpmann.de>
+WWW: http://projects.camlcity.org/projects/findlib.html
diff --git a/devel/ocaml-findlib/pkg-plist b/devel/ocaml-findlib/pkg-plist
new file mode 100644
index 000000000000..d4562f106b3c
--- /dev/null
+++ b/devel/ocaml-findlib/pkg-plist
@@ -0,0 +1,116 @@
+bin/ocamlfind
+bin/safe_camlp4
+etc/findlib.conf
+lib/ocaml/site-lib/bigarray/META
+lib/ocaml/site-lib/camlp4/META
+lib/ocaml/site-lib/dbm/META
+lib/ocaml/site-lib/dynlink/META
+lib/ocaml/site-lib/findlib/META
+lib/ocaml/site-lib/findlib/Makefile.config
+lib/ocaml/site-lib/findlib/findlib.a
+lib/ocaml/site-lib/findlib/findlib.cma
+lib/ocaml/site-lib/findlib/findlib.cmi
+lib/ocaml/site-lib/findlib/findlib.cmxa
+lib/ocaml/site-lib/findlib/findlib.mli
+lib/ocaml/site-lib/findlib/findlib_top.cma
+lib/ocaml/site-lib/findlib/fl_metascanner.cmi
+lib/ocaml/site-lib/findlib/fl_metascanner.mli
+lib/ocaml/site-lib/findlib/fl_package_base.cmi
+lib/ocaml/site-lib/findlib/fl_package_base.mli
+lib/ocaml/site-lib/findlib/topfind.cmi
+lib/ocaml/site-lib/findlib/topfind.mli
+lib/ocaml/site-lib/graphics/META
+lib/ocaml/site-lib/labltk/META
+lib/ocaml/site-lib/num-top/META
+lib/ocaml/site-lib/num-top/num_top.cma
+lib/ocaml/site-lib/num-top/num_top.cmi
+lib/ocaml/site-lib/num-top/num_top_printers.cmi
+lib/ocaml/site-lib/num/META
+lib/ocaml/site-lib/stdlib/META
+lib/ocaml/site-lib/str/META
+lib/ocaml/site-lib/threads/META
+lib/ocaml/site-lib/unix/META
+lib/ocaml/topfind
+%%PORTDOCS%%%%DOCSDIR%%/DOCINFO
+%%PORTDOCS%%%%DOCSDIR%%/QUICKSTART
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/guide-html/TIMESTAMP
+%%PORTDOCS%%%%DOCSDIR%%/guide-html/c157.html
+%%PORTDOCS%%%%DOCSDIR%%/guide-html/c188.html
+%%PORTDOCS%%%%DOCSDIR%%/guide-html/c274.html
+%%PORTDOCS%%%%DOCSDIR%%/guide-html/c348.html
+%%PORTDOCS%%%%DOCSDIR%%/guide-html/c37.html
+%%PORTDOCS%%%%DOCSDIR%%/guide-html/c380.html
+%%PORTDOCS%%%%DOCSDIR%%/guide-html/c74.html
+%%PORTDOCS%%%%DOCSDIR%%/guide-html/index.html
+%%PORTDOCS%%%%DOCSDIR%%/guide-html/p35.html
+%%PORTDOCS%%%%DOCSDIR%%/guide-html/quickstart.html
+%%PORTDOCS%%%%DOCSDIR%%/guide-html/x104.html
+%%PORTDOCS%%%%DOCSDIR%%/guide-html/x115.html
+%%PORTDOCS%%%%DOCSDIR%%/guide-html/x131.html
+%%PORTDOCS%%%%DOCSDIR%%/guide-html/x145.html
+%%PORTDOCS%%%%DOCSDIR%%/guide-html/x176.html
+%%PORTDOCS%%%%DOCSDIR%%/guide-html/x227.html
+%%PORTDOCS%%%%DOCSDIR%%/guide-html/x261.html
+%%PORTDOCS%%%%DOCSDIR%%/guide-html/x270.html
+%%PORTDOCS%%%%DOCSDIR%%/guide-html/x307.html
+%%PORTDOCS%%%%DOCSDIR%%/guide-html/x322.html
+%%PORTDOCS%%%%DOCSDIR%%/guide-html/x334.html
+%%PORTDOCS%%%%DOCSDIR%%/guide-html/x341.html
+%%PORTDOCS%%%%DOCSDIR%%/guide-html/x355.html
+%%PORTDOCS%%%%DOCSDIR%%/guide-html/x372.html
+%%PORTDOCS%%%%DOCSDIR%%/guide-html/x394.html
+%%PORTDOCS%%%%DOCSDIR%%/guide-html/x400.html
+%%PORTDOCS%%%%DOCSDIR%%/guide-html/x412.html
+%%PORTDOCS%%%%DOCSDIR%%/guide-html/x464.html
+%%PORTDOCS%%%%DOCSDIR%%/guide-html/x468.html
+%%PORTDOCS%%%%DOCSDIR%%/guide-html/x81.html
+%%PORTDOCS%%%%DOCSDIR%%/guide-html/x89.html
+%%PORTDOCS%%%%DOCSDIR%%/ref-html/TIMESTAMP
+%%PORTDOCS%%%%DOCSDIR%%/ref-html/c990.html
+%%PORTDOCS%%%%DOCSDIR%%/ref-html/index.html
+%%PORTDOCS%%%%DOCSDIR%%/ref-html/lib/Findlib.html
+%%PORTDOCS%%%%DOCSDIR%%/ref-html/lib/Fl_metascanner.html
+%%PORTDOCS%%%%DOCSDIR%%/ref-html/lib/Fl_package_base.html
+%%PORTDOCS%%%%DOCSDIR%%/ref-html/lib/Topfind.html
+%%PORTDOCS%%%%DOCSDIR%%/ref-html/lib/index.html
+%%PORTDOCS%%%%DOCSDIR%%/ref-html/lib/index_attributes.html
+%%PORTDOCS%%%%DOCSDIR%%/ref-html/lib/index_class_types.html
+%%PORTDOCS%%%%DOCSDIR%%/ref-html/lib/index_classes.html
+%%PORTDOCS%%%%DOCSDIR%%/ref-html/lib/index_exceptions.html
+%%PORTDOCS%%%%DOCSDIR%%/ref-html/lib/index_methods.html
+%%PORTDOCS%%%%DOCSDIR%%/ref-html/lib/index_module_types.html
+%%PORTDOCS%%%%DOCSDIR%%/ref-html/lib/index_modules.html
+%%PORTDOCS%%%%DOCSDIR%%/ref-html/lib/index_types.html
+%%PORTDOCS%%%%DOCSDIR%%/ref-html/lib/index_values.html
+%%PORTDOCS%%%%DOCSDIR%%/ref-html/lib/style.css
+%%PORTDOCS%%%%DOCSDIR%%/ref-html/lib/type_Findlib.html
+%%PORTDOCS%%%%DOCSDIR%%/ref-html/lib/type_Fl_metascanner.html
+%%PORTDOCS%%%%DOCSDIR%%/ref-html/lib/type_Fl_package_base.html
+%%PORTDOCS%%%%DOCSDIR%%/ref-html/lib/type_Topfind.html
+%%PORTDOCS%%%%DOCSDIR%%/ref-html/p15.html
+%%PORTDOCS%%%%DOCSDIR%%/ref-html/p645.html
+%%PORTDOCS%%%%DOCSDIR%%/ref-html/p988.html
+%%PORTDOCS%%%%DOCSDIR%%/ref-html/r17.html
+%%PORTDOCS%%%%DOCSDIR%%/ref-html/r647.html
+%%PORTDOCS%%%%DOCSDIR%%/ref-html/r741.html
+%%PORTDOCS%%%%DOCSDIR%%/ref-html/r930.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/ref-html/lib
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/ref-html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/guide-html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTDOCS%%@dirrmtry share/doc/ocaml
+@dirrm lib/ocaml/site-lib/unix
+@dirrm lib/ocaml/site-lib/threads
+@dirrm lib/ocaml/site-lib/str
+@dirrm lib/ocaml/site-lib/stdlib
+@dirrm lib/ocaml/site-lib/num-top
+@dirrm lib/ocaml/site-lib/num
+@dirrm lib/ocaml/site-lib/labltk
+@dirrm lib/ocaml/site-lib/graphics
+@dirrm lib/ocaml/site-lib/findlib
+@dirrm lib/ocaml/site-lib/dynlink
+@dirrm lib/ocaml/site-lib/dbm
+@dirrm lib/ocaml/site-lib/camlp4
+@dirrm lib/ocaml/site-lib/bigarray
+@dirrmtry lib/ocaml/site-lib