aboutsummaryrefslogtreecommitdiff
path: root/devel/ocaml-lacaml
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-08-20 06:49:11 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-08-20 06:49:11 +0000
commit5d080083375244f9031e01a0f061c720d30d42ab (patch)
tree0c1c2e099fd04107d87418b993c3a88a55381e49 /devel/ocaml-lacaml
parentc4dd701f02fc278886abd668b28b8801b482fa53 (diff)
downloadports-5d080083375244f9031e01a0f061c720d30d42ab.tar.gz
ports-5d080083375244f9031e01a0f061c720d30d42ab.zip
Notes
Diffstat (limited to 'devel/ocaml-lacaml')
-rw-r--r--devel/ocaml-lacaml/Makefile84
-rw-r--r--devel/ocaml-lacaml/distinfo3
-rw-r--r--devel/ocaml-lacaml/pkg-descr9
3 files changed, 96 insertions, 0 deletions
diff --git a/devel/ocaml-lacaml/Makefile b/devel/ocaml-lacaml/Makefile
new file mode 100644
index 000000000000..9b7457a13d4b
--- /dev/null
+++ b/devel/ocaml-lacaml/Makefile
@@ -0,0 +1,84 @@
+# New ports collection makefile for: lacaml
+# Date created: 2006-08-15
+# Whom: Stanislav Sedov <ssedov@mbsd.msk.ru>
+#
+# $MBSDlabs$
+# $FreeBSD$
+#
+
+PORTNAME= lacaml
+PORTVERSION= 3.0.18
+CATEGORIES= devel
+MASTER_SITES= http://www.ocaml.info/ocaml_sources/
+PKGNAMEPREFIX= ocaml-
+
+MAINTAINER= ssedov@mbsd.msk.ru
+COMMENT= OCaml interface to BLAS and LAPACK libraries
+
+LIB_DEPENDS= blas.1:${PORTSDIR}/math/blas \
+ lapack.3:${PORTSDIR}/math/lapack
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_OCAML= yes
+USE_OCAML_FINDLIB=yes
+USE_OCAML_LDCONFIG=yes
+USE_OCAML_WASH= yes
+
+CFLAGS+= -fPIC
+MAKE_ENV+= OCAMLMKLIB_FLAGS="-L${LOCALBASE}/lib"
+
+DOCS= README TODO
+DOCSDIR= ${TARGETDIR}/share/doc/ocaml/${PORTNAME}
+EXAMPLESDIR= ${TARGETDIR}/share/examples/ocaml/${PORTNAME}
+
+# XXX: exists untill it will be committed to bsd.port.mk
+COPYTREE_SHARE= ${SH} -c '(${FIND} -d $$0 $$2 | ${CPIO} -dumpl $$1 >/dev/null \
+ 2>&1) && \
+ ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} $$1 && \
+ ${FIND} $$1/ -type d -exec ${CHMOD} 755 {} \; && \
+ ${FIND} $$1/ -type f -exec ${CHMOD} ${SHAREMODE} {} \;' --
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/lang/ocaml/bsd.ocaml.mk"
+
+post-extract:
+#
+# CFLAGS safety
+#
+ @${REINPLACE_CMD} -E \
+ -e 's,^(CFLAGS[[:space:]]*:=[[:space:]]*).*,\1${CFLAGS},' \
+ ${WRKSRC}/lib/Makefile
+
+# For nonstandard prefixes
+.if !exists(${OCAMLFIND_DESTDIR})
+ ${MKDIR} ${OCAMLFIND_DESTDIR}
+.endif
+.if !exists(${OCAMLFIND_LDCONF})
+ ${TOUCH} ${OCAMLFIND_LDCONF}
+.endif
+
+post-install:
+ @${FIND} ${OCAMLFIND_DESTDIR}/${PORTNAME} -type f | \
+ ${SED} "s,^${TARGETDIR}/,," >> ${TMPPLIST}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${DOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
+ @${MKDIR} ${EXAMPLESDIR}
+ @(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} \* ${EXAMPLESDIR}/)
+ @${FIND} ${EXAMPLESDIR}/ ! -type d | \
+ ${SED} 's,^${TARGETDIR}/,,' >> ${TMPPLIST}
+ @${FIND} ${EXAMPLESDIR}/ -type d | ${SORT} -r | \
+ ${SED} 's,^${TARGETDIR}/,@dirrm ,' >> ${TMPPLIST}
+ @${FIND} ${DOCSDIR}/ ! -type d | \
+ ${SED} 's,^${TARGETDIR}/,,' >> ${TMPPLIST}
+ @${FIND} ${DOCSDIR}/ -type d | ${SORT} -r | \
+ ${SED} 's,^${TARGETDIR}/,@dirrm ,' >> ${TMPPLIST}
+# XXX: temporary workaround for non-standard PREFIX
+ @${ECHO_CMD} "@unexec rmdir %D/share/doc/ocaml 2>/dev/null || true" \
+ >> ${TMPPLIST}
+ @${ECHO_CMD} "@unexec rmdir %D/share/examples/ocaml 2>/dev/null||true" \
+ >> ${TMPPLIST}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/ocaml-lacaml/distinfo b/devel/ocaml-lacaml/distinfo
new file mode 100644
index 000000000000..69b2115f4d7b
--- /dev/null
+++ b/devel/ocaml-lacaml/distinfo
@@ -0,0 +1,3 @@
+MD5 (lacaml-3.0.18.tar.bz2) = 1965430e39a430b36d8beec1eb9dae93
+SHA256 (lacaml-3.0.18.tar.bz2) = 240f0025f7732c460d55274487d56c3a018589baf06bf8e9a69d4d3e3b0b4dbd
+SIZE (lacaml-3.0.18.tar.bz2) = 68886
diff --git a/devel/ocaml-lacaml/pkg-descr b/devel/ocaml-lacaml/pkg-descr
new file mode 100644
index 000000000000..a283ff1320de
--- /dev/null
+++ b/devel/ocaml-lacaml/pkg-descr
@@ -0,0 +1,9 @@
+This OCaml-library interfaces the BLAS-library (Basic Linear Algebra
+Subroutines) and LAPACK-library (Linear Algebra routines), which are
+written in FORTRAN.
+
+This allows people to write high-performance numerical code for
+applications that need linear algebra.
+
+Author: Markus Mottl <markus.mottl@gmail.com>
+WWW: http://www.ocaml.info/home/ocaml_sources.html