aboutsummaryrefslogtreecommitdiff
path: root/devel/ocaml-lacaml
diff options
context:
space:
mode:
authorMarcelo Araujo <araujo@FreeBSD.org>2012-12-20 05:46:41 +0000
committerMarcelo Araujo <araujo@FreeBSD.org>2012-12-20 05:46:41 +0000
commit793694929c5ef0ab4a7a36b7d20c36e29d4aa260 (patch)
tree5043842def0238489aad90b6a0cefd3f1f8aae99 /devel/ocaml-lacaml
parente617f7923b2e09ff050d045ba7c72d8bb700bb2f (diff)
downloadports-793694929c5ef0ab4a7a36b7d20c36e29d4aa260.tar.gz
ports-793694929c5ef0ab4a7a36b7d20c36e29d4aa260.zip
Notes
Diffstat (limited to 'devel/ocaml-lacaml')
-rw-r--r--devel/ocaml-lacaml/Makefile81
-rw-r--r--devel/ocaml-lacaml/distinfo4
-rw-r--r--devel/ocaml-lacaml/pkg-descr2
3 files changed, 36 insertions, 51 deletions
diff --git a/devel/ocaml-lacaml/Makefile b/devel/ocaml-lacaml/Makefile
index af5d9e94e3a4..7daa47ccf17a 100644
--- a/devel/ocaml-lacaml/Makefile
+++ b/devel/ocaml-lacaml/Makefile
@@ -2,77 +2,62 @@
# $FreeBSD$
PORTNAME= lacaml
-PORTVERSION= 5.4.7
-PORTREVISION= 1
+PORTVERSION= 7.0.3
CATEGORIES= devel
-MASTER_SITES= http://hg.ocaml.info/release/lacaml/archive/
-DISTNAME= release-${PORTVERSION}
+MASTER_SITES= http://cdn.bitbucket.org/mmottl/lacaml/downloads/
PKGNAMEPREFIX= ocaml-
MAINTAINER= ports@FreeBSD.org
COMMENT= OCaml interface to BLAS and LAPACK libraries
-DEPRECATED= No more public distfiles
-EXPIRATION_DATE= 2012-11-26
+LICENSE= LGPL21
-LIB_DEPENDS= blas.2:${PORTSDIR}/math/blas \
- lapack.4:${PORTSDIR}/math/lapack
+LIB_DEPENDS= blas:${PORTSDIR}/math/blas \
+ lapack:${PORTSDIR}/math/lapack
+
+OPTIONS_DEFINE= DOCS EXAMPLES
-USE_BZIP2= yes
-USE_GMAKE= yes
USE_OCAML= yes
USE_OCAML_FINDLIB=yes
+USE_OCAMLFIND_PLIST=yes
USE_OCAML_LDCONFIG=yes
USE_OCAML_WASH= yes
-WRKSRC= ${WRKDIR}/lacaml-${DISTNAME}
+
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix ${PREFIX} --disable-docs --disable-examples \
+ --override conf_ccopt "${CFLAGS}" \
+ --override conf_cclib "${LDFLAGS:S,^.*[[:space:]],,}"
+MAKE_JOBS_UNSAFE=yes
CFLAGS+= -fPIC
-MAKE_ENV+= OCAMLMKLIB_FLAGS="-L${LOCALBASE}/lib"
-MAKE_JOBS_UNSAFE= yes
+LDFLAGS+= -L${LOCALBASE}/lib -lblas -llapack
-DOCS= README.txt TODO
-DOCSDIR= ${PREFIX}/share/doc/ocaml/${PORTNAME}
-EXAMPLESDIR= ${PREFIX}/share/examples/ocaml/${PORTNAME}
+DOCSDIR= ${OCAML_DOCSDIR}/${PORTNAME}
+EXAMPLESDIR= ${OCAML_EXAMPLESDIR}/${PORTNAME}
-.include <bsd.port.pre.mk>
+PORTDOCS= *
+PORTEXAMPLES= *
-post-extract:
-#
-# CFLAGS safety
-#
- @${REINPLACE_CMD} -E \
- -e 's,^(CFLAGS[[:space:]]*:=[[:space:]]*).*,\1${CFLAGS},' \
- ${WRKSRC}/lib/Makefile
+.include <bsd.port.options.mk>
-# For nonstandard prefixes
-.if !exists(${OCAMLFIND_DESTDIR})
- ${MKDIR} ${OCAMLFIND_DESTDIR}
+.if ${PORT_OPTIONS:MDOCS}
+PLIST_DIRSTRY+= ${OCAML_DOCSDIR:S,^${PREFIX}/,,}
.endif
-.if !exists(${OCAMLFIND_LDCONF})
- ${TOUCH} ${OCAMLFIND_LDCONF}
+
+.if ${PORT_OPTIONS:MEXAMPLES}
+PLIST_DIRSTRY+= ${OCAML_EXAMPLESDIR:S,^${PREFIX}/,,}
.endif
post-install:
- @${FIND} ${OCAMLFIND_DESTDIR}/${PORTNAME} -type f | \
- ${SED} "s,^${PREFIX}/,," >> ${TMPPLIST}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${DOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
+.for i in AUTHORS.txt CHANGES.txt README.md TODO.md
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${i} ${DOCSDIR})
+.endfor
+.endif
+.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
- @(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} \* ${EXAMPLESDIR}/)
- @${FIND} ${EXAMPLESDIR}/ ! -type d | \
- ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
- @${FIND} ${EXAMPLESDIR}/ -type d | ${SORT} -r | \
- ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
- @${FIND} ${DOCSDIR}/ ! -type d | \
- ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
- @${FIND} ${DOCSDIR}/ -type d | ${SORT} -r | \
- ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
-# XXX: temporary workaround for non-standard PREFIX
- @${ECHO_CMD} "@unexec rmdir %D/share/doc/ocaml 2>/dev/null || true" \
- >> ${TMPPLIST}
- @${ECHO_CMD} "@unexec rmdir %D/share/examples/ocaml 2>/dev/null||true" \
- >> ${TMPPLIST}
+ @(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${EXAMPLESDIR})
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/ocaml-lacaml/distinfo b/devel/ocaml-lacaml/distinfo
index dd8fd1c3c5d6..ff254d76caf2 100644
--- a/devel/ocaml-lacaml/distinfo
+++ b/devel/ocaml-lacaml/distinfo
@@ -1,2 +1,2 @@
-SHA256 (release-5.4.7.tar.bz2) = 87a833aa88c22accbf340a61dcf21f542def8d401be14df67ab4390f15cf8460
-SIZE (release-5.4.7.tar.bz2) = 86427
+SHA256 (lacaml-7.0.3.tar.gz) = 3ebd0b35ae0e4fe5cc5483e61a8bf1fb46ef8fed60f5c89a09e589b91b7ec982
+SIZE (lacaml-7.0.3.tar.gz) = 151742
diff --git a/devel/ocaml-lacaml/pkg-descr b/devel/ocaml-lacaml/pkg-descr
index a283ff1320de..ce9344e5aeb0 100644
--- a/devel/ocaml-lacaml/pkg-descr
+++ b/devel/ocaml-lacaml/pkg-descr
@@ -6,4 +6,4 @@ This allows people to write high-performance numerical code for
applications that need linear algebra.
Author: Markus Mottl <markus.mottl@gmail.com>
-WWW: http://www.ocaml.info/home/ocaml_sources.html
+WWW: https://bitbucket.org/mmottl/lacaml