aboutsummaryrefslogtreecommitdiff
path: root/devel/ocaml-magic
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2014-04-04 19:57:56 +0000
committerJohan van Selst <johans@FreeBSD.org>2014-04-04 19:57:56 +0000
commit77c8bf2cc9aed059e02c30a9d062e23071f2ea59 (patch)
treea7fcccf5ea52468a5424b6f229b71fda532af338 /devel/ocaml-magic
parent2d18d289ba6422d8513a8a03dc1d0e9a3842cd8a (diff)
downloadports-77c8bf2cc9aed059e02c30a9d062e23071f2ea59.tar.gz
ports-77c8bf2cc9aed059e02c30a9d062e23071f2ea59.zip
Notes
Diffstat (limited to 'devel/ocaml-magic')
-rw-r--r--devel/ocaml-magic/Makefile34
-rw-r--r--devel/ocaml-magic/pkg-plist34
2 files changed, 43 insertions, 25 deletions
diff --git a/devel/ocaml-magic/Makefile b/devel/ocaml-magic/Makefile
index 80cdb91d2f3c..77ab78132341 100644
--- a/devel/ocaml-magic/Makefile
+++ b/devel/ocaml-magic/Makefile
@@ -3,50 +3,34 @@
PORTNAME= magic
PORTVERSION= 0.7.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= SF/ocaml-${PORTNAME}/ocaml-${PORTNAME}/0.7
PKGNAMEPREFIX= ocaml-
DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
MAINTAINER= johans@FreeBSD.org
-COMMENT= An OCaml binding for libmagic(3)
+COMMENT= OCaml binding for libmagic(3)
USE_OCAML= yes
USE_OCAML_FINDLIB= yes
USE_OCAML_LDCONFIG= yes
+USES= gmake
GNU_CONFIGURE= yes
-USE_GMAKE= yes
-.ifndef(NOPORTDOCS)
-ALL_TARGET+= doc
-PORTDOCS= *
+ALL_TARGET+= doc examples
DOCSDIR= ${OCAML_DOCSDIR}/${PORTNAME}
-.endif
-
-.ifndef(NOPORTEXAMPLES)
-ALL_TARGET+= examples
-PORTEXAMPLES= *
EXAMPLESDIR= ${OCAML_EXAMPLESDIR}/${PORTNAME}
-.endif
# This really is overzealous but I work this way
.if !exists(/usr/lib/libmagic.so)
-LIB_DEPENDS+= magic:${PORTSDIR}/sysutils/file
+LIB_DEPENDS+= libmagic.so:${PORTSDIR}/sysutils/file
.endif
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
post-install:
-.ifndef(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/html/* ${DOCSDIR}
-.endif
-.ifndef(NOPORTEXAMPLES)
- ${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
-.endif
+ ${MKDIR} ${STAGEDIR}${DOCSDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/html/* ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/ocaml-magic/pkg-plist b/devel/ocaml-magic/pkg-plist
new file mode 100644
index 000000000000..ad8d3dd38343
--- /dev/null
+++ b/devel/ocaml-magic/pkg-plist
@@ -0,0 +1,34 @@
+%%OCAML_SITELIBDIR%%/magic/META
+%%OCAML_SITELIBDIR%%/magic/dllmagic_stubs.so
+%%OCAML_SITELIBDIR%%/magic/libmagic_stubs.a
+%%OCAML_SITELIBDIR%%/magic/magic.a
+%%OCAML_SITELIBDIR%%/magic/magic.cma
+%%OCAML_SITELIBDIR%%/magic/magic.cmi
+%%OCAML_SITELIBDIR%%/magic/magic.cmx
+%%OCAML_SITELIBDIR%%/magic/magic.cmxa
+%%OCAML_SITELIBDIR%%/magic/magic.mli
+%%PORTDOCS%%%%DOCSDIR%%/Magic.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/index_attributes.html
+%%PORTDOCS%%%%DOCSDIR%%/index_class_types.html
+%%PORTDOCS%%%%DOCSDIR%%/index_classes.html
+%%PORTDOCS%%%%DOCSDIR%%/index_exceptions.html
+%%PORTDOCS%%%%DOCSDIR%%/index_methods.html
+%%PORTDOCS%%%%DOCSDIR%%/index_module_types.html
+%%PORTDOCS%%%%DOCSDIR%%/index_modules.html
+%%PORTDOCS%%%%DOCSDIR%%/index_types.html
+%%PORTDOCS%%%%DOCSDIR%%/index_values.html
+%%PORTDOCS%%%%DOCSDIR%%/style.css
+%%PORTDOCS%%%%DOCSDIR%%/type_Magic.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Makefile
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Makefile.in
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/file
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/file.cmi
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/file.cmo
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/file.cmx
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/file.ml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/file.o
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test.ml
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%
+%%PORTDOCS%%@dirrmtry %%DOCSDIR%%
+@dirrmtry %%OCAML_SITELIBDIR%%/magic