aboutsummaryrefslogtreecommitdiff
path: root/devel/ocaml-parmap
diff options
context:
space:
mode:
authorJean-Sébastien Pédron <dumbbell@FreeBSD.org>2015-06-27 13:47:04 +0000
committerJean-Sébastien Pédron <dumbbell@FreeBSD.org>2015-06-27 13:47:04 +0000
commitd416afd219350381544141e3ab2423a466ecff36 (patch)
tree1e8b3e62955d6f0a789b1fa6353b23ccb4a5bc09 /devel/ocaml-parmap
parent37bebf844533c7f8d7ef0e15cf08419f492f14af (diff)
Notes
Diffstat (limited to 'devel/ocaml-parmap')
-rw-r--r--devel/ocaml-parmap/Makefile28
-rw-r--r--devel/ocaml-parmap/distinfo2
-rw-r--r--devel/ocaml-parmap/files/patch-Makefile.in15
-rw-r--r--devel/ocaml-parmap/files/patch-configure13
-rw-r--r--devel/ocaml-parmap/pkg-descr9
-rw-r--r--devel/ocaml-parmap/pkg-plist18
6 files changed, 85 insertions, 0 deletions
diff --git a/devel/ocaml-parmap/Makefile b/devel/ocaml-parmap/Makefile
new file mode 100644
index 000000000000..b2b2a78c093b
--- /dev/null
+++ b/devel/ocaml-parmap/Makefile
@@ -0,0 +1,28 @@
+# Created by: Jean-Sébastien Pédron <dumbbell@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= parmap
+DISTVERSION= 1.0-rc6
+CATEGORIES= devel
+PKGNAMEPREFIX= ocaml-
+
+MAINTAINER= dumbbell@FreeBSD.org
+COMMENT= Minimalistic library allowing to exploit multicore architecture
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= rdicosmo
+
+USES= gmake
+GNU_CONFIGURE= yes
+USE_OCAML= yes
+USE_OCAML_FINDLIB= yes
+USE_OCAML_LDCONFIG= yes
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/ocaml/parmap/*.cmxs
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/ocaml/stublibs/*.so
+
+.include <bsd.port.mk>
diff --git a/devel/ocaml-parmap/distinfo b/devel/ocaml-parmap/distinfo
new file mode 100644
index 000000000000..22ce399718a9
--- /dev/null
+++ b/devel/ocaml-parmap/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rdicosmo-parmap-1.0-rc6_GH0.tar.gz) = 25e2eeb2ec8b1dedc8067443ddcddf4ab0ff2e3821da888338146af69e8fd9e6
+SIZE (rdicosmo-parmap-1.0-rc6_GH0.tar.gz) = 97083
diff --git a/devel/ocaml-parmap/files/patch-Makefile.in b/devel/ocaml-parmap/files/patch-Makefile.in
new file mode 100644
index 000000000000..f38746ebb422
--- /dev/null
+++ b/devel/ocaml-parmap/files/patch-Makefile.in
@@ -0,0 +1,15 @@
+--- Makefile.in.orig 2015-02-09 10:42:28 UTC
++++ Makefile.in
+@@ -20,9 +20,9 @@ INSTALL = $(OCAMLFIND) install
+ UNINSTALL = $(OCAMLFIND) remove
+ else
+ export OCAMLLIBDIR := lib/ocaml
+-LIBDIR=$(DESTDIR)/$(OCAMLLIBDIR)
+-BINDIR=$(DESTDIR)/bin
+-MANDIR=$(DESTDIR)/man/man3
++LIBDIR=$(DESTDIR)$(prefix)/$(OCAMLLIBDIR)
++BINDIR=$(DESTDIR)$(exec_prefix)/bin
++MANDIR=$(DESTDIR)$(prefix)/man/man3
+ INSTALL = $(OCAMLFIND) install -destdir $(LIBDIR)
+ UNINSTALL = $(OCAMLFIND) remove -destdir $(LIBDIR)
+ endif
diff --git a/devel/ocaml-parmap/files/patch-configure b/devel/ocaml-parmap/files/patch-configure
new file mode 100644
index 000000000000..1d65f86b1d91
--- /dev/null
+++ b/devel/ocaml-parmap/files/patch-configure
@@ -0,0 +1,13 @@
+--- configure.orig 2015-02-09 10:42:28 UTC
++++ configure
+@@ -4379,8 +4379,8 @@ _ACEOF
+ ac_config_headers="$ac_config_headers config.h"
+
+
+-t=`$OCAMLBUILD -use-ocamlfind &> /dev/null; echo $?`
+-if test $t == 0 ; then
++t=`$OCAMLBUILD -use-ocamlfind > /dev/null; echo $?`
++if test "$t" = 0 ; then
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: ocaml version $OCAMLVERSION. Use standard Makefile" >&5
+ $as_echo "ocaml version $OCAMLVERSION. Use standard Makefile" >&6; }
+ ac_config_files="$ac_config_files Makefile"
diff --git a/devel/ocaml-parmap/pkg-descr b/devel/ocaml-parmap/pkg-descr
new file mode 100644
index 000000000000..67f6dbb6cef3
--- /dev/null
+++ b/devel/ocaml-parmap/pkg-descr
@@ -0,0 +1,9 @@
+Parmap is a minimalistic library allowing to exploit multicore
+architecture for OCaml programs with minimal modifications: if you want
+to use your many cores to accelerate an operation which happens to be a
+map, fold or map/fold (map-reduce), just use Parmap's parmap, parfold
+and parmapfold primitives in place of the standard List.map and friends,
+and specify the number of subprocesses to use by the optional parameter
+~ncores.
+
+WWW: https://github.com/rdicosmo/parmap
diff --git a/devel/ocaml-parmap/pkg-plist b/devel/ocaml-parmap/pkg-plist
new file mode 100644
index 000000000000..a0452980bd3a
--- /dev/null
+++ b/devel/ocaml-parmap/pkg-plist
@@ -0,0 +1,18 @@
+lib/ocaml/parmap/META
+lib/ocaml/parmap/bytearray.cmi
+lib/ocaml/parmap/bytearray.mli
+lib/ocaml/parmap/libparmap_stubs.a
+lib/ocaml/parmap/parmap.a
+lib/ocaml/parmap/parmap.cma
+lib/ocaml/parmap/parmap.cmi
+lib/ocaml/parmap/parmap.cmxa
+lib/ocaml/parmap/parmap.cmxs
+lib/ocaml/parmap/parmap.mli
+lib/ocaml/parmap/parmap_utils.cmi
+lib/ocaml/parmap/parmap_utils.mli
+lib/ocaml/parmap/setcore.cmi
+lib/ocaml/parmap/setcore.mli
+lib/ocaml/stublibs/dllparmap_stubs.so
+lib/ocaml/stublibs/dllparmap_stubs.so.owner
+man/man3/Parmap.3o.gz
+@dir %%OCAML_SITELIBDIR%%