aboutsummaryrefslogtreecommitdiff
path: root/devel/ocaml-sexplib
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-08-04 17:01:11 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-08-04 17:01:11 +0000
commit7aa5869e6aa1b6f5be6231a27cdad3f12f4a42c6 (patch)
treefb7e27a1113910fca78e936019a678d7248fe565 /devel/ocaml-sexplib
parent7f09660d2362fd56d535f7f61dad8eb3f2aac2e1 (diff)
downloadports-7aa5869e6aa1b6f5be6231a27cdad3f12f4a42c6.tar.gz
ports-7aa5869e6aa1b6f5be6231a27cdad3f12f4a42c6.zip
Notes
Diffstat (limited to 'devel/ocaml-sexplib')
-rw-r--r--devel/ocaml-sexplib/Makefile49
-rw-r--r--devel/ocaml-sexplib/distinfo3
-rw-r--r--devel/ocaml-sexplib/pkg-descr13
3 files changed, 65 insertions, 0 deletions
diff --git a/devel/ocaml-sexplib/Makefile b/devel/ocaml-sexplib/Makefile
new file mode 100644
index 000000000000..57dbd7c2e9fc
--- /dev/null
+++ b/devel/ocaml-sexplib/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: ocaml-sexplib
+# Date created: 2006-08-01
+# Whom: Stanislav Sedov <ssedov@mbsd.msk.ru>
+#
+# $MBSDlabs$
+# $FreeBSD$
+#
+
+PORTNAME= sexplib
+PORTVERSION= 2.2.0
+CATEGORIES= devel
+MASTER_SITES= http://www.janestcapital.com/ocaml/
+PKGNAMEPREFIX= ocaml-
+
+MAINTAINER= ssedov@mbsd.msk.ru
+COMMENT= An OCaml library for working with S-expressions
+
+USE_GMAKE= yes
+USE_OCAML= yes
+USE_OCAML_FINDLIB=yes
+
+DOCSDIR= ${PREFIX}/share/doc/ocaml/${PORTNAME}
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/lang/ocaml/bsd.ocaml.mk"
+
+post-extract:
+# For nonstandard prefixes
+.if !exists(${OCAMLFIND_DESTDIR})
+ ${MKDIR} ${OCAMLFIND_DESTDIR}
+.endif
+.if !exists(${OCAMLFIND_LDCONF})
+ ${TOUCH} ${OCAMLFIND_LDCONF}
+.endif
+ @${REINPLACE_CMD} -E -e "/lib_test/d" ${WRKSRC}/Makefile
+
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.txt ${DOCSDIR}
+
+ @${FIND} ${OCAMLFIND_DESTDIR}/${PORTNAME} -type f | \
+ ${SED} "s,^${PREFIX}/,," >> ${TMPPLIST}
+ @${FIND} ${DOCSDIR} -type f | \
+ ${SED} "s,^${PREFIX}/,," >> ${TMPPLIST}
+ @${ECHO_CMD} "@dirrm share/doc/ocaml/${PORTNAME}" >> ${TMPPLIST}
+ @${ECHO_CMD} "@unexec rmdir %D/share/doc/ocaml 2>/dev/null ||true"\
+ >> ${TMPPLIST}
+
+.include <bsd.port.post.mk>
diff --git a/devel/ocaml-sexplib/distinfo b/devel/ocaml-sexplib/distinfo
new file mode 100644
index 000000000000..30837843d831
--- /dev/null
+++ b/devel/ocaml-sexplib/distinfo
@@ -0,0 +1,3 @@
+MD5 (sexplib-2.2.0.tar.gz) = 7545423823790a8611a3c85377ed5861
+SHA256 (sexplib-2.2.0.tar.gz) = 8df0bd341439afed1b6ce4ba345bb7babe8dbdcf338655e6daa10b8ee6c1a2c5
+SIZE (sexplib-2.2.0.tar.gz) = 44643
diff --git a/devel/ocaml-sexplib/pkg-descr b/devel/ocaml-sexplib/pkg-descr
new file mode 100644
index 000000000000..0809716dba50
--- /dev/null
+++ b/devel/ocaml-sexplib/pkg-descr
@@ -0,0 +1,13 @@
+This library contains functionality for parsing and pretty-printing
+S-expressions. In addition to that it contains an extremely useful
+preprocessing module for Camlp4, which can be used to automatically generate
+code from type definitions for efficiently converting OCaml-values to
+S-expressions and vice versa. In combination with the parsing and
+pretty-printing functionality this frees the user from having to write his own
+I/O-routines for datastructures he defines. Possible errors during automatic
+conversions from S-expressions to OCaml-values are reported in a very
+human-readable way. Another module in the library allows you to extract and
+replace sub-expressions in S-expressions.
+
+Author: Markus Mottl <mmottl@janestcapital.com>
+WWW: http://www.janestcapital.com/ocaml/index.html