aboutsummaryrefslogtreecommitdiff
path: root/devel/ocaml-ulex/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-03-19 01:56:37 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-03-19 01:56:37 +0000
commitf2177fd0c86ae0ba7bb72812d202e32f4f139808 (patch)
tree8ee3d26ded2c26c766e4edd4d242e3b5d6056ad2 /devel/ocaml-ulex/Makefile
parente3eda8d4d1322e5bb0e3d9f05f95798a85a2508f (diff)
downloadports-f2177fd0c86ae0ba7bb72812d202e32f4f139808.tar.gz
ports-f2177fd0c86ae0ba7bb72812d202e32f4f139808.zip
Notes
Diffstat (limited to 'devel/ocaml-ulex/Makefile')
-rw-r--r--devel/ocaml-ulex/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/devel/ocaml-ulex/Makefile b/devel/ocaml-ulex/Makefile
new file mode 100644
index 000000000000..714ef04c0847
--- /dev/null
+++ b/devel/ocaml-ulex/Makefile
@@ -0,0 +1,43 @@
+# ex:ts=8
+# Ports collection makefile for: ulex
+# Date created: Mar 17, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= ulex
+PORTVERSION= 0.4
+CATEGORIES= devel
+MASTER_SITES= http://www.cduce.org/download/
+PKGNAMEPREFIX= ocaml-
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A lexer generator for Unicode and OCaml
+
+BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml \
+ ocamlfind:${PORTSDIR}/devel/ocaml-findlib
+RUN_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml \
+ ocamlfind:${PORTSDIR}/devel/ocaml-findlib
+
+USE_GMAKE= yes
+ALL_TARGET= all all.opt
+
+.if !defined(NOPORTDOCS)
+ALL_TARGET+= doc
+PORTDOCS= *
+.endif
+
+PKGDEINSTALL= ${PKGINSTALL}
+
+post-install:
+ @${FIND} ${PREFIX}/lib/ocaml/site-lib/${PORTNAME} -type f | \
+ ${SED} "s,^${PREFIX}/,," >> ${TMPPLIST}
+ @${ECHO_CMD} "@dirrm lib/ocaml/site-lib/${PORTNAME}" >> ${TMPPLIST}
+ @${ECHO_CMD} "@unexec ocamlfind remove ${PORTNAME} 2>/dev/null || true" >> ${TMPPLIST}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.html ${WRKSRC}/*.css ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>