aboutsummaryrefslogtreecommitdiff
path: root/devel/ocaml-xstr
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-08-06 14:17:12 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-08-06 14:17:12 +0000
commit1683d870a07f802e3182d212d7045ffcc7828b76 (patch)
treea303cd6550c276502cdfe446e7535fbf3adf7da2 /devel/ocaml-xstr
parenta63cf30be2570c1bab1bf29570cc74a4ca25a1e5 (diff)
downloadports-1683d870a07f802e3182d212d7045ffcc7828b76.tar.gz
ports-1683d870a07f802e3182d212d7045ffcc7828b76.zip
Notes
Diffstat (limited to 'devel/ocaml-xstr')
-rw-r--r--devel/ocaml-xstr/Makefile25
-rw-r--r--devel/ocaml-xstr/distinfo3
-rw-r--r--devel/ocaml-xstr/pkg-descr10
-rw-r--r--devel/ocaml-xstr/pkg-plist8
4 files changed, 46 insertions, 0 deletions
diff --git a/devel/ocaml-xstr/Makefile b/devel/ocaml-xstr/Makefile
new file mode 100644
index 000000000000..6b35c17ae54a
--- /dev/null
+++ b/devel/ocaml-xstr/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: ocaml-xstr
+# Date created: 2006-07-29
+# Whom: Stanislav Sedov <ssedov@mbsd.msk.ru>
+#
+# $MBSDlabs$
+# $FreeBSD$
+#
+
+PORTNAME= xstr
+PORTVERSION= 0.2.1
+CATEGORIES= devel
+MASTER_SITES= http://www.ocaml-programming.de/packages/
+PKGNAMEPREFIX= ocaml-
+
+MAINTAINER= ssedov@mbsd.msk.ru
+COMMENT= Thread-safe implementation of string searching/matching
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_GMAKE= yes
+USE_OCAML= yes
+USE_OCAML_FINDLIB=yes
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/lang/ocaml/bsd.ocaml.mk"
+.include <bsd.port.post.mk>
diff --git a/devel/ocaml-xstr/distinfo b/devel/ocaml-xstr/distinfo
new file mode 100644
index 000000000000..c7f007f14620
--- /dev/null
+++ b/devel/ocaml-xstr/distinfo
@@ -0,0 +1,3 @@
+MD5 (xstr-0.2.1.tar.gz) = 81598c438d6ab5c5d544ea7cc6ed8a34
+SHA256 (xstr-0.2.1.tar.gz) = 796f77589af651d1bb627444fa48c76d887c97d98a58cb95913d86103fb168be
+SIZE (xstr-0.2.1.tar.gz) = 14703
diff --git a/devel/ocaml-xstr/pkg-descr b/devel/ocaml-xstr/pkg-descr
new file mode 100644
index 000000000000..aff7dbf91892
--- /dev/null
+++ b/devel/ocaml-xstr/pkg-descr
@@ -0,0 +1,10 @@
+This package implements frequent string operations: searching, replacing,
+splitting, matching. It is independent from the Str library, and can
+replace Str in many cases. Unlike Str, xstr is thread-safe. xstr does
+not implement regular expressions in general, but an important subset.
+Some operations of xstr are performed as quickly as by Str; if the string
+to be processed is small, xstr is often faster than Str; if the string is
+big, xstr is upto half as fast than Str.
+
+Author: Gerd Stolpmann <gerd@gerd-stolpmann.de>
+WWW: http://www.ocaml-programming.de/packages/
diff --git a/devel/ocaml-xstr/pkg-plist b/devel/ocaml-xstr/pkg-plist
new file mode 100644
index 000000000000..f08a5b521f81
--- /dev/null
+++ b/devel/ocaml-xstr/pkg-plist
@@ -0,0 +1,8 @@
+%%OCAML_SITELIBDIR%%/xstr/META
+%%OCAML_SITELIBDIR%%/xstr/xstr.cma
+%%OCAML_SITELIBDIR%%/xstr/xstr_match.cmi
+%%OCAML_SITELIBDIR%%/xstr/xstr_match.mli
+%%OCAML_SITELIBDIR%%/xstr/xstr_search.cmi
+%%OCAML_SITELIBDIR%%/xstr/xstr_search.mli
+%%OCAML_SITELIBDIR%%/xstr/xstr_split.cmi
+%%OCAML_SITELIBDIR%%/xstr/xstr_split.mli