aboutsummaryrefslogtreecommitdiff
path: root/devel/ode
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2009-01-16 04:14:29 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2009-01-16 04:14:29 +0000
commit2fc40b1f6553e668f5a456419c57cbf6bad7977d (patch)
tree787e1ec726700dd6b1e66e095cbac0b7453d0b47 /devel/ode
parent3a67eb1aee168d9fbff909902f5941f27c95aece (diff)
downloadports-2fc40b1f6553e668f5a456419c57cbf6bad7977d.tar.gz
ports-2fc40b1f6553e668f5a456419c57cbf6bad7977d.zip
Notes
Diffstat (limited to 'devel/ode')
-rw-r--r--devel/ode/Makefile18
-rw-r--r--devel/ode/distinfo6
-rw-r--r--devel/ode/pkg-plist3
3 files changed, 18 insertions, 9 deletions
diff --git a/devel/ode/Makefile b/devel/ode/Makefile
index 08a3921bf60b..e06aa2ab1cde 100644
--- a/devel/ode/Makefile
+++ b/devel/ode/Makefile
@@ -6,20 +6,19 @@
#
PORTNAME= ode
-PORTVERSION= 0.9
-PORTREVISION= 2
+PORTVERSION= 0.10.1
PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= SF
MASTER_SITE_SUBDIR= opende
-DISTNAME= ${PORTNAME}-src-${PORTVERSION}
+DISTNAME= ${PORTNAME}-${PORTVERSION}
MAINTAINER= acm@FreeBSD.org
COMMENT= Articulated rigid body dynamics library
CONFLICTS= ode-devel-[0-9].*
-USE_ZIP= yes
+USE_BZIP2= yes
USE_GL= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
@@ -29,7 +28,8 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
OPTIONS= GIMPACT "Enable gimpact instead of opcode support" off \
GYROSCOPIC "Configure ODE to work with gyroscopic term" on \
- DOUBLE "Enable double precision (BROKEN with GIMPACT)" off
+ DOUBLE "Enable double precision (BROKEN with GIMPACT)" off \
+ OU "Enable Thread-local storage (Experimental)" off
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
@@ -53,6 +53,12 @@ CONFIGURE_ARGS+= --disable-gyroscopic
CONFIGURE_ARGS+= --enable-double-precision
.endif
+.if defined(WITH_OU)
+CONFIGURE_ARGS+= --enable-ou
+.else
+CONFIGURE_ARGS+= --disable-ou
+.endif
+
post-patch:
@${REINPLACE_CMD} -e '/if test/ s|==|=|' -e 's|^\( *CFLAGS=\)|#\1|;' \
-e 's|^\( *CPPFLAGS=\)|#\1|' -e 's|^\( *CXXFLAGS=\)|#\1|' \
@@ -67,7 +73,7 @@ post-patch:
-i "" -e 's|malloc.h|stdlib.h|g'
post-install:
- ${SED} -e '/PACKAGE/ s|^|//|; /VERSION/ s|^|//|' ${WRKSRC}/include/ode/config.h \
+ ${SED} -e '/PACKAGE/ s|^|//|; /VERSION/ s|^|//|' ${WRKSRC}/ode/src/config.h \
> ${PREFIX}/include/ode/config.h
.include <bsd.port.post.mk>
diff --git a/devel/ode/distinfo b/devel/ode/distinfo
index e413f36fb0f3..4b00e507597f 100644
--- a/devel/ode/distinfo
+++ b/devel/ode/distinfo
@@ -1,3 +1,3 @@
-MD5 (ode-src-0.9.zip) = 4c03759b76a0649a6d5108c8e172e1e4
-SHA256 (ode-src-0.9.zip) = 460d0851b743b1f144ef2a8259004d6774504c95d08e9357a96a296111496feb
-SIZE (ode-src-0.9.zip) = 2052825
+MD5 (ode-0.10.1.tar.bz2) = 91c396b915539a760617437d56eb1681
+SHA256 (ode-0.10.1.tar.bz2) = 9636b246ec2d40411babedcb8d2cb5dbc96b4cc65fab7701992b6f7c6a9da72e
+SIZE (ode-0.10.1.tar.bz2) = 1485871
diff --git a/devel/ode/pkg-plist b/devel/ode/pkg-plist
index 29c4b154ae80..d91bf2f7354b 100644
--- a/devel/ode/pkg-plist
+++ b/devel/ode/pkg-plist
@@ -14,10 +14,13 @@ include/ode/memory.h
include/ode/misc.h
include/ode/objects.h
include/ode/ode.h
+include/ode/odeconfig.h
include/ode/odecpp.h
include/ode/odecpp_collision.h
+include/ode/odeinit.h
include/ode/odemath.h
include/ode/rotation.h
include/ode/timer.h
lib/libode.a
+lib/libode.la
@dirrm include/ode