aboutsummaryrefslogtreecommitdiff
path: root/devel/ode
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2006-09-02 14:26:29 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2006-09-02 14:26:29 +0000
commitcd85452c48d023633158e0c9dd20f4e291350c6f (patch)
treed269ff64fa1e9329bc1981246dc269a569116aa6 /devel/ode
parentfa6a9d4924949a94da903484e080a92bfe35e0bf (diff)
downloadports-cd85452c48d023633158e0c9dd20f4e291350c6f.tar.gz
ports-cd85452c48d023633158e0c9dd20f4e291350c6f.zip
Notes
Diffstat (limited to 'devel/ode')
-rw-r--r--devel/ode/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/devel/ode/Makefile b/devel/ode/Makefile
index 2ad6b50c1034..3be1175fdbd9 100644
--- a/devel/ode/Makefile
+++ b/devel/ode/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ode
PORTVERSION= 0.6
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
@@ -24,7 +25,7 @@ USE_GL= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --program-prefix=${PREFIX}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL
CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include" \
LIBS="-L${X11BASE}/lib"
@@ -54,8 +55,10 @@ post-patch:
-e 's|__isnanf||g; s|__isnan||g' -e 's|-lpthread|-pthread|g' \
${WRKSRC}/configure
@${REINPLACE_CMD} -e '/^traplib_PROGRAMS / d' ${WRKSRC}/ode/src/Makefile.in
- @${FIND} ${WRKSRC} -type f -name Makefile.in -print0 | xargs -0 ${REINPLACE_CMD} \
+ @${FIND} ${WRKSRC} -type f -name Makefile.in -print0 | ${XARGS} -0 ${REINPLACE_CMD} \
-e '/^DEFAULT_INCLUDES/ s|$$| -I$$(top_builddir)/include|' \
-e '/CFLAGS/ s|-O[12]||'
+ @${FIND} ${WRKSRC} -type f -name "*.h" -print0 | ${XARGS} -0 ${REINPLACE_CMD} \
+ -i "" -e 's|<malloc.h>|<stdlib.h>|g'
.include <bsd.port.post.mk>