aboutsummaryrefslogtreecommitdiff
path: root/devel/omake
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-09-06 07:33:20 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-09-06 07:33:20 +0000
commit53060de06869e0d27ede4a4741fe86f4c3b51d57 (patch)
tree9f67c1f87095cb9a769b701c9dd7ae2f0eebea24 /devel/omake
parentad566dadbb58d6991f45a602603b1e083ec28c94 (diff)
downloadports-53060de06869e0d27ede4a4741fe86f4c3b51d57.tar.gz
ports-53060de06869e0d27ede4a4741fe86f4c3b51d57.zip
Notes
Diffstat (limited to 'devel/omake')
-rw-r--r--devel/omake/Makefile62
-rw-r--r--devel/omake/distinfo3
-rw-r--r--devel/omake/files/patch-Makefile13
-rw-r--r--devel/omake/files/patch-OMakefile10
-rw-r--r--devel/omake/pkg-descr5
-rw-r--r--devel/omake/pkg-plist22
6 files changed, 115 insertions, 0 deletions
diff --git a/devel/omake/Makefile b/devel/omake/Makefile
new file mode 100644
index 000000000000..b075df4d7f0b
--- /dev/null
+++ b/devel/omake/Makefile
@@ -0,0 +1,62 @@
+# New ports collection makefile for: omake
+# Date created: 2006-08-06
+# Whom: Stanislav Sedov <ssedov@mbsd.msk.ru>
+#
+# $MBSDlabs$
+# $FreeBSD$
+#
+
+PORTNAME= omake
+PORTVERSION= 0.9.6.9.1
+CATEGORIES= devel
+MASTER_SITES= http://omake.metaprl.org/downloads/
+#DISTNAME= ${PORTNAME}-${PORTVERSION:C/\.[0-9]*$//}-1
+DISTNAME= omake-0.9.6.9-1
+
+MAINTAINER= ssedov@mbsd.msk.ru
+COMMENT= A flexible build system
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:C/\.[0-9]*$//}
+USE_OCAML= yes
+NO_OCAML_RUNDEPENDS=yes
+
+FETCH_CMD= /usr/bin/fetch -Rr
+
+MAN1= omake-base.1 omake-doc.1 omake-language.1 omake-options.1 \
+ omake-pervasives.1 omake-quickstart.1 omake-root.1 omake-rules.1 \
+ omake-shell.1 omake-system.1 omake.1 osh.1
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/lang/ocaml/bsd.ocaml.mk"
+
+.if ${OSVERSION} > 500000 && exists(${LOCALBASE}/lib/libreadline.so.5)
+LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+.endif
+
+post-patch:
+#
+# Dirty hack for PREFIX safety
+#
+ @${REINPLACE_CMD} -E -e "s,(getenv[[:space:]]+)LIBDIR,\1PREFLIBDIR," \
+ ${WRKSRC}/mk/defaults
+
+#
+# Permissions safety
+#
+ @${REINPLACE_CMD} -E -e "s,cp -f -m 444,\$$(BSD_INSTALL_DATA)," \
+ -e "s,cp -f -m 555,\$$(BSD_INSTALL_PROGRAM)," \
+ ${WRKSRC}/OMakefile ${WRKSRC}/src/main/OMakefile \
+ ${WRKSRC}/doc/OMakefile
+
+#
+# Readline code is deeply broken on 4
+#
+.if ${OSVERSION} < 500000
+ @${REINPLACE_CMD} -E -e \
+ "s,^(READLINE_ENABLED[[:space:]]*=[[:space:]]*).*,\1false," \
+ ${WRKSRC}/mk/make_config ${WRKSRC}/mk/defaults
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/omake/distinfo b/devel/omake/distinfo
new file mode 100644
index 000000000000..15fd44ce092a
--- /dev/null
+++ b/devel/omake/distinfo
@@ -0,0 +1,3 @@
+MD5 (omake-0.9.6.9-1.tar.gz) = 81a44fcf8192140b3147ffe849818742
+SHA256 (omake-0.9.6.9-1.tar.gz) = f9a296b06d4a68407ae499f95f601a4a7ba2ca0157b1b03808183ba26e2afc26
+SIZE (omake-0.9.6.9-1.tar.gz) = 2046152
diff --git a/devel/omake/files/patch-Makefile b/devel/omake/files/patch-Makefile
new file mode 100644
index 000000000000..7204da25f064
--- /dev/null
+++ b/devel/omake/files/patch-Makefile
@@ -0,0 +1,13 @@
+--- Makefile.orig Thu Sep 8 04:43:14 2005
++++ Makefile Mon Aug 7 13:01:39 2006
+@@ -18,8 +18,8 @@
+ @exit 1
+
+ boot: boot/Makefile
+- @touch boot/Makefile.dep
+- @cd boot; $(MAKE) Makefile.dep; $(MAKE) omake
++ @sed -i "" -e '/include Makefile.dep/d' boot/Makefile
++ @cd boot; $(MAKE) Makefile.dep; echo "include Makefile.dep" >> Makefile; $(MAKE) omake
+ @ln -sf boot/omake omake-boot
+
+ boot/Makefile: src/Makefile
diff --git a/devel/omake/files/patch-OMakefile b/devel/omake/files/patch-OMakefile
new file mode 100644
index 000000000000..dfc95043eb3a
--- /dev/null
+++ b/devel/omake/files/patch-OMakefile
@@ -0,0 +1,10 @@
+--- OMakefile.orig Wed Sep 6 00:43:31 2006
++++ OMakefile Wed Sep 6 00:43:41 2006
+@@ -31,7 +31,6 @@
+ #
+ # Extra options for the C compiler
+ #
+- CFLAGS += -g -O2 -Wall -Werror -Wno-unused
+
+ #
+ # Try to build man pages on Unix
diff --git a/devel/omake/pkg-descr b/devel/omake/pkg-descr
new file mode 100644
index 000000000000..2fdd5df5bb76
--- /dev/null
+++ b/devel/omake/pkg-descr
@@ -0,0 +1,5 @@
+OMake is a build system designed for scalability and portability. It uses a
+syntax similar to make utilities you may have used, but it features many
+additional enhancements.
+
+WWW: http://omake.metaprl.org/index.html
diff --git a/devel/omake/pkg-plist b/devel/omake/pkg-plist
new file mode 100644
index 000000000000..3c2a31b3f8e2
--- /dev/null
+++ b/devel/omake/pkg-plist
@@ -0,0 +1,22 @@
+bin/cvs_realclean
+bin/omake
+bin/osh
+lib/omake/OMakefile.default
+lib/omake/OMakeroot.default
+lib/omake/OMakeroot.om
+lib/omake/Pervasives.om
+lib/omake/build/C.om
+lib/omake/build/Common.om
+lib/omake/build/LaTeX.om
+lib/omake/build/OCaml.om
+lib/omake/configure/Configure.om
+lib/omake/configure/fam.om
+lib/omake/configure/ncurses.om
+lib/omake/configure/readline.om
+lib/omake/parse/C/Lex.om
+lib/omake/parse/C/Parse.om
+@dirrm lib/omake/parse/C
+@dirrm lib/omake/parse
+@dirrm lib/omake/configure
+@dirrm lib/omake/build
+@dirrm lib/omake