aboutsummaryrefslogtreecommitdiff
path: root/devel/omniNotify/Makefile
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2004-12-04 01:49:57 +0000
committerKris Kennaway <kris@FreeBSD.org>2004-12-04 01:49:57 +0000
commitc6349c090154978a96ec1d9073138164ad38af19 (patch)
tree77689f1215d2857345378d48c0657892161df7a0 /devel/omniNotify/Makefile
parent0a012829867d1069225755973ef4aa5e726663f0 (diff)
downloadports-c6349c090154978a96ec1d9073138164ad38af19.tar.gz
ports-c6349c090154978a96ec1d9073138164ad38af19.zip
Notes
Diffstat (limited to 'devel/omniNotify/Makefile')
-rw-r--r--devel/omniNotify/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/devel/omniNotify/Makefile b/devel/omniNotify/Makefile
index d356ab8f004f..de20d239d4cc 100644
--- a/devel/omniNotify/Makefile
+++ b/devel/omniNotify/Makefile
@@ -39,6 +39,12 @@ CONFIGURE_ENV+= CC=${CC} CFLAGS="${CFLAGS}" CXX=${CXX} CXXFLAGS="${CXXFLAGS}" \
CPP=${CPP} PYTHON=${PYTHON_CMD}
CONFIGURE_ARGS= --with-omniorb=${LOCALBASE}
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386"
+BROKEN= "Does not compile on !i386"
+.endif
+
pre-configure:
@${MKDIR} ${CONFIGURE_WRKSRC}
@cd ${OMNIORB_WRKSRC} && ${FIND} idl | ${CPIO} --quiet -pdum ${WRKSRC}
@@ -54,4 +60,4 @@ post-install:
| ${CPIO} --quiet -pdum -R ${SHAREOWN}:${SHAREGRP} ${EXAMPLESDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>