aboutsummaryrefslogtreecommitdiff
path: root/devel/omniORB
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2005-11-07 20:10:38 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2005-11-07 20:10:38 +0000
commit77f639ecfc6915a07692c22dce140f760397bc40 (patch)
tree581af6cf811945755733ce2894e17c6626ba1bc4 /devel/omniORB
parentb80fce117fe6751d6f6ca12d39726dbc4afa0ae3 (diff)
downloadports-77f639ecfc6915a07692c22dce140f760397bc40.tar.gz
ports-77f639ecfc6915a07692c22dce140f760397bc40.zip
Notes
Diffstat (limited to 'devel/omniORB')
-rw-r--r--devel/omniORB/Makefile12
-rw-r--r--devel/omniORB/files/patch-undef_minor_macro30
2 files changed, 33 insertions, 9 deletions
diff --git a/devel/omniORB/Makefile b/devel/omniORB/Makefile
index afd8e42acd39..810ba5f232f0 100644
--- a/devel/omniORB/Makefile
+++ b/devel/omniORB/Makefile
@@ -43,15 +43,9 @@ PLIST_SUB+= STATIC=""
MAN1= catior.1 genior.1 nameclt.1 omniNames.1 omniidl.1
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700000
-BROKEN= "Does not compile on FreeBSD >= 7.0"
-.endif
-
post-patch:
- @${REINPLACE_CMD} -Ee 's#-pthread|-lc_r#${PTHREAD_LIBS}#' \
- ${WRKSRC}/mk/beforeauto.mk.in
+ @${REINPLACE_CMD} -e 's#-pthread|-lc_r#${PTHREAD_LIBS}#' \
+ -e 's#-O2#${CFLAGS}#g' ${WRKSRC}/mk/beforeauto.mk.in
pre-configure:
@${MKDIR} ${CONFIGURE_WRKSRC}
@@ -69,4 +63,4 @@ post-install:
@${INSTALL_DATA} ${WRKSRC}/sample.cfg ${EXAMPLESDIR}/omniORB.cfg
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/omniORB/files/patch-undef_minor_macro b/devel/omniORB/files/patch-undef_minor_macro
new file mode 100644
index 000000000000..bf236574a953
--- /dev/null
+++ b/devel/omniORB/files/patch-undef_minor_macro
@@ -0,0 +1,30 @@
+--- src/appl/utils/catior/catior.cc.orig Mon Nov 7 22:38:04 2005
++++ src/appl/utils/catior/catior.cc Mon Nov 7 22:38:55 2005
+@@ -42,6 +42,12 @@
+ # include <unistd.h>
+ #endif
+
++#ifdef minor
++ // Digital Unix 3.2, and may be others as well, defines minor() as
++ // a macro in its sys/types.h. Get rid of it!
++#undef minor
++#endif
++
+ #ifndef Swap16
+ #define Swap16(s) ((((s) & 0xff) << 8) | (((s) >> 8) & 0xff))
+ #else
+--- src/appl/utils/convertior/convertior.cc.orig Mon Nov 7 22:39:11 2005
++++ src/appl/utils/convertior/convertior.cc Mon Nov 7 22:39:28 2005
+@@ -40,6 +40,12 @@
+ # include <unistd.h>
+ #endif
+
++#ifdef minor
++ // Digital Unix 3.2, and may be others as well, defines minor() as
++ // a macro in its sys/types.h. Get rid of it!
++#undef minor
++#endif
++
+ #ifndef Swap16
+ #define Swap16(s) ((((s) & 0xff) << 8) | (((s) >> 8) & 0xff))
+ #else