aboutsummaryrefslogtreecommitdiff
path: root/devel/open-beagle/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-06-09 06:52:06 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-06-09 06:52:06 +0000
commit86c01e98532b6e8d9f89cae3ab7b49bade5a84cd (patch)
tree4f9ac9af70b56f7ec901c6dcd9ddde424a002374 /devel/open-beagle/Makefile
parentc251d5d494250df1c44134e6159f476c1a0bb1df (diff)
downloadports-86c01e98532b6e8d9f89cae3ab7b49bade5a84cd.tar.gz
ports-86c01e98532b6e8d9f89cae3ab7b49bade5a84cd.zip
Notes
Diffstat (limited to 'devel/open-beagle/Makefile')
-rw-r--r--devel/open-beagle/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/devel/open-beagle/Makefile b/devel/open-beagle/Makefile
new file mode 100644
index 000000000000..dfeee128f189
--- /dev/null
+++ b/devel/open-beagle/Makefile
@@ -0,0 +1,29 @@
+# ex:ts=8
+# Ports collection makefile for: beagle
+# Date created: Jun 9, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= beagle
+PORTVERSION= 2.1.3
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= An Evolutionary Computation Framework
+
+USE_GCC= 3.3
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-optimization
+INSTALLS_SHLIB= yes
+
+post-install:
+ @${FIND} ${PREFIX}/include/beagle ! -type d | \
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/include/beagle -type d | ${SORT} -r | \
+ ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
+
+.include <bsd.port.mk>