aboutsummaryrefslogtreecommitdiff
path: root/devel/opencl
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2012-09-22 08:25:38 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2012-09-22 08:25:38 +0000
commit2073cceb3cfcd113b4e0033d47891a80e789bc9a (patch)
treef082e2a49611fc190ecb4e5635bc69567631c15b /devel/opencl
parent375ef54e1489f5858934bc111010208aae561398 (diff)
downloadports-2073cceb3cfcd113b4e0033d47891a80e789bc9a.tar.gz
ports-2073cceb3cfcd113b4e0033d47891a80e789bc9a.zip
Notes
Diffstat (limited to 'devel/opencl')
-rw-r--r--devel/opencl/Makefile31
-rw-r--r--devel/opencl/distinfo20
-rw-r--r--devel/opencl/pkg-descr6
-rw-r--r--devel/opencl/pkg-message5
4 files changed, 62 insertions, 0 deletions
diff --git a/devel/opencl/Makefile b/devel/opencl/Makefile
new file mode 100644
index 000000000000..db7c0aab20cc
--- /dev/null
+++ b/devel/opencl/Makefile
@@ -0,0 +1,31 @@
+# Created by: Oliver Hartmann <ohartman@zedat.fu-berlin.de>
+# $FreeBSD$
+
+PORTNAME= opencl
+PORTVERSION= 1.2
+CATEGORIES= devel
+MASTER_SITES= http://www.khronos.org/registry/cl/api/${PORTVERSION}/
+DISTFILES= opencl.h cl_platform.h cl.h cl_ext.h cl_dx9_media_sharing.h \
+ cl_d3d10.h cl_d3d11.h cl_gl.h cl_gl_ext.h cl.hpp
+DIST_SUBDIR= ${PORTNAME}
+EXTRACT_ONLY=
+
+MAINTAINER= ohartman@zedat.fu-berlin.de
+COMMENT= Open Computing Language (OpenCL) specifications
+
+CONFLICTS= opencl-1.[0-1]
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+PLIST_DIRS= include/CL
+.for f in ${DISTFILES}
+PLIST_FILES+=include/CL/$f
+.endfor
+
+do-install:
+ ${MKDIR} ${PREFIX}/include/CL
+ ${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/*.h ${PREFIX}/include/CL
+ ${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/*.hpp ${PREFIX}/include/CL
+
+.include <bsd.port.mk>
diff --git a/devel/opencl/distinfo b/devel/opencl/distinfo
new file mode 100644
index 000000000000..18b8eec3a269
--- /dev/null
+++ b/devel/opencl/distinfo
@@ -0,0 +1,20 @@
+SHA256 (opencl/opencl.h) = a69842d53ea5b505323a6bee242cca8ddba47294f69972fe61c0371636935819
+SIZE (opencl/opencl.h) = 1754
+SHA256 (opencl/cl_platform.h) = 3d217a53c9bf8e0cd3a74b9eac030e27606253368d4ac6511e95399bd14af4ad
+SIZE (opencl/cl_platform.h) = 41131
+SHA256 (opencl/cl.h) = 4df687ff7bd1c85c3f4768c45e9a0b2529705d21ab659ec06e82e876d75c6478
+SIZE (opencl/cl.h) = 63158
+SHA256 (opencl/cl_ext.h) = bda268419b454540c56ee615f6718a917d4289973545d7357509b4128933a18e
+SIZE (opencl/cl_ext.h) = 9951
+SHA256 (opencl/cl_dx9_media_sharing.h) = 7aa1cece80d7ca7bf699e248ca989dd97aa807472f7ecd7aca79cec0af56340c
+SIZE (opencl/cl_dx9_media_sharing.h) = 5157
+SHA256 (opencl/cl_d3d10.h) = 394787cf9ddfee6f24c59521b714d0974f6a7874fd8fd5aae6365028d946a8bd
+SIZE (opencl/cl_d3d10.h) = 4859
+SHA256 (opencl/cl_d3d11.h) = 20cc068d09e06498e38f449e35876ec4b5bf545807a463aca85319246717cba8
+SIZE (opencl/cl_d3d11.h) = 4853
+SHA256 (opencl/cl_gl.h) = 19e923585b36b69b5c09d566cef3b3d43fcf1143f64eece3cbf716fd0afbb6d7
+SIZE (opencl/cl_gl.h) = 7429
+SHA256 (opencl/cl_gl_ext.h) = c28c7b03aa7eb22bad5af50c9d1213e80b827e90ee04c2a6ee27561f19e93cf6
+SIZE (opencl/cl_gl_ext.h) = 2630
+SHA256 (opencl/cl.hpp) = eeacf0fefc51d618dda67d52e2bbff7dc9a67e90bc38166b3fad26d44800013a
+SIZE (opencl/cl.hpp) = 915453
diff --git a/devel/opencl/pkg-descr b/devel/opencl/pkg-descr
new file mode 100644
index 000000000000..e5d0ba469d8b
--- /dev/null
+++ b/devel/opencl/pkg-descr
@@ -0,0 +1,6 @@
+OpenCL (Open Computing Language) is an open royalty-free standard
+for general purpose parallel programming across CPUs, GPUs and
+other processors, giving software developers portable and efficient
+access to the power of these heterogeneous processing platforms.
+
+This is OpenCL 1.2
diff --git a/devel/opencl/pkg-message b/devel/opencl/pkg-message
new file mode 100644
index 000000000000..4bc9e018ee9c
--- /dev/null
+++ b/devel/opencl/pkg-message
@@ -0,0 +1,5 @@
+OpenCL is the first open, royalty-free standard for cross-platform,
+parallel programming of modern processors.
+
+Header files will reside in PREFIX/CL, with PREFIX usually
+set to /usr/local/include.