aboutsummaryrefslogtreecommitdiff
path: root/devel/openorb
diff options
context:
space:
mode:
authorHerve Quiroz <hq@FreeBSD.org>2004-11-27 23:28:52 +0000
committerHerve Quiroz <hq@FreeBSD.org>2004-11-27 23:28:52 +0000
commit39e5700a3ecde4667db0c158742a0efe6c4208d5 (patch)
tree120f24e7d3f0d6aaa292ddd3b795f4732f1183cb /devel/openorb
parent798b68483f80bb708ddc143c66ee515a8a504ebc (diff)
Notes
Diffstat (limited to 'devel/openorb')
-rw-r--r--devel/openorb/Makefile102
-rw-r--r--devel/openorb/distinfo2
-rw-r--r--devel/openorb/files/launcher.sh20
-rw-r--r--devel/openorb/pkg-descr19
4 files changed, 143 insertions, 0 deletions
diff --git a/devel/openorb/Makefile b/devel/openorb/Makefile
new file mode 100644
index 000000000000..6f071e0a41e8
--- /dev/null
+++ b/devel/openorb/Makefile
@@ -0,0 +1,102 @@
+# New ports collection makefile for: openorb
+# Date created: 2004-11-19
+# Whom: Herve Quiroz <hq@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ${APP_NAME:L}
+PORTVERSION= 1.3.1
+CATEGORIES= devel java
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${APP_NAME}-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= hq@FreeBSD.org
+COMMENT= Java implementation of the OMG CORBA 2.4.2 specification
+
+RUN_DEPENDS= ${JAVALIBDIR}/excalibur-configuration.jar:${PORTSDIR}/devel/excalibur-configuration \
+ ${JAVALIBDIR}/avalon-framework.jar:${PORTSDIR}/devel/avalon-framework \
+ ${JAVALIBDIR}/logkit.jar:${PORTSDIR}/java/avalon-logkit \
+ ${JAVALIBDIR}/xercesImpl.jar:${PORTSDIR}/textproc/xerces-j
+
+APP_NAME= OpenORB
+
+USE_JAVA= yes
+JAVA_VERSION= 1.3+
+NO_BUILD= yes
+
+DATADIR= ${JAVASHAREDIR}/${PORTNAME}
+
+SCRIPT_FILES= openorb-idl_compiler openorb-naming_service
+DATA_FILES= config idl test
+JAR_FILES= openorb-1.3.1.jar openorb_examples-1.3.1.jar openorb_test-1.3.1.jar openorb_tools-1.3.1.jar
+PLIST_FILES= ${JAR_FILES:S,-${PORTVERSION},,:S,^,%%JAVAJARDIR%%/,} ${SCRIPT_FILES:S,^,bin/,}
+.if !defined(NOPORTDOCS)
+OTHERDOCS= EXOLAB.txt LICENSE.txt README WHATSNEW
+PORTDOCS= ${OTHERDOCS} html_img javadoc orb.html orb.pdf
+.endif
+
+.include <bsd.port.pre.mk>
+
+JAR_DEPENDS= excalibur-configuration.jar avalon-framework.jar logkit.jar xercesImpl.jar xml-apis.jar
+CLASSPATH!= ${ECHO_CMD} \
+ "${JAR_FILES:S,-${PORTVERSION},,:S,^,${JAVAJARDIR}/,} ${JAR_DEPENDS:S,^,${JAVALIBDIR}/,}" \
+ | ${TR} " " ":"
+
+do-configure:
+ ${SED} \
+ -e 's,%%LOCALBASE%%,${LOCALBASE},' \
+ -e 's,%%CLASSPATH%%,${CLASSPATH},' \
+ -e 's,%%BASENAME%%,${BASENAME},' \
+ ${FILESDIR}/launcher.sh > ${WRKSRC}/launcher
+
+do-install:
+ @${ECHO_MSG} -n ">> Installing JARs in ${JAVAJARDIR}/..."
+ @${MKDIR} ${JAVAJARDIR}
+ @for jarfile in ${JAR_FILES} ; do \
+ destjarfile="`${ECHO_CMD} "$${jarfile}" | ${SED} -e 's,-${PORTVERSION},,'`" ; \
+ ${ECHO_MSG} -n " $${destjarfile}" ; \
+ ${INSTALL_DATA} ${WRKSRC}/lib/$${jarfile} ${JAVAJARDIR}/$${destjarfile} ; \
+ done
+ @${ECHO_MSG} " [ DONE ]"
+ @${ECHO_MSG} -n ">> Installing launcher scripts in ${PREFIX}/bin/..."
+.for script in ${SCRIPT_FILES}
+ @${ECHO_MSG} -n " ${script}"
+ @${INSTALL_SCRIPT} ${WRKSRC}/launcher ${PREFIX}/bin/${script}
+.endfor
+ @${ECHO_MSG} " [ DONE ]"
+ @${ECHO_MSG} -n ">> Installing data files in ${DATADIR}/..."
+ @cd ${WRKSRC} \
+ && ${FIND} ${DATA_FILES} -type d -exec ${MKDIR} ${DATADIR}/{} \; \
+ && ${FIND} ${DATA_FILES} -type f -exec ${INSTALL_DATA} {} ${DATADIR}/{} \;
+ @${ECHO_MSG} " [ DONE ]"
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} -n ">> Installing samples in ${EXAMPLESDIR}/..."
+ @cd ${WRKSRC}/examples \
+ && ${FIND} . -type d -exec ${MKDIR} ${EXAMPLESDIR}/{} \; \
+ && ${FIND} . -type f -exec ${INSTALL_DATA} {} ${EXAMPLESDIR}/{} \;
+ @${ECHO_MSG} " [ DONE ]"
+ @${ECHO_MSG} -n ">> Installing documentation in ${DOCSDIR}/..."
+ @cd ${WRKSRC}/doc \
+ && ${FIND} . -type d -exec ${MKDIR} ${DOCSDIR}/{} \; \
+ && ${FIND} . -type f -exec ${INSTALL_DATA} {} ${DOCSDIR}/{} \;
+ @${INSTALL_DATA} ${OTHERDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
+ @${ECHO_MSG} " [ DONE ]"
+.endif
+
+post-install:
+ @${FIND} -s ${DATA_FILES:S,^,${WRKSRC}/,} -not -type d \
+ | ${SED} -ne 's,^${WRKSRC},${DATADIR:S,^${PREFIX}/,,},p' >> ${TMPPLIST}
+ @${FIND} -s -d ${DATA_FILES:S,^,${WRKSRC}/,} -type d \
+ | ${SED} -ne 's,^${WRKSRC},@dirrm ${DATADIR:S,^${PREFIX}/,,},p' >> ${TMPPLIST}
+ @${ECHO_CMD} "@dirrm ${DATADIR:S,^${PREFIX}/,,}" >> ${TMPPLIST}
+.if !defined(NOPORTDOCS)
+ @${FIND} -s ${WRKSRC}/examples -not -type d \
+ | ${SED} -ne 's,^${WRKSRC}/examples,${EXAMPLESDIR:S,^${PREFIX}/,,},p' >> ${TMPPLIST}
+ @${FIND} -s -d ${WRKSRC}/examples -type d \
+ | ${SED} -ne 's,^${WRKSRC}/examples,@dirrm ${EXAMPLESDIR:S,^${PREFIX}/,,},p' >> ${TMPPLIST}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/openorb/distinfo b/devel/openorb/distinfo
new file mode 100644
index 000000000000..f0a9f4169bcb
--- /dev/null
+++ b/devel/openorb/distinfo
@@ -0,0 +1,2 @@
+MD5 (OpenORB-1.3.1.tgz) = 011921d888c790e1313a67d45d41a5a7
+SIZE (OpenORB-1.3.1.tgz) = 5133490
diff --git a/devel/openorb/files/launcher.sh b/devel/openorb/files/launcher.sh
new file mode 100644
index 000000000000..51a9e7e9168c
--- /dev/null
+++ b/devel/openorb/files/launcher.sh
@@ -0,0 +1,20 @@
+#!/bin/sh
+#
+# $FreeBSD$
+
+IAM="`%%BASENAME%% "$0"`"
+
+case "${IAM}" in
+ openorb-idl_compiler)
+ MAIN_CLASS=org.openorb.compiler.IdlCompiler
+ ;;
+ openorb-naming_service)
+ MAIN_CLASS=org.openorb.util.MapNamingContext
+ ;;
+ *)
+ echo "ERROR: command not supported" >&2
+ exit 1
+ ;;
+esac
+
+JAVA_VERSION="1.3+" "%%LOCALBASE%%/bin/java" -classpath "%%CLASSPATH%%" "${MAIN_CLASS}" "$@"
diff --git a/devel/openorb/pkg-descr b/devel/openorb/pkg-descr
new file mode 100644
index 000000000000..e6e627e31714
--- /dev/null
+++ b/devel/openorb/pkg-descr
@@ -0,0 +1,19 @@
+This is a community fork of the open source project OpenORB
+(openorb.exolab.org). The goal of this initiative is to make the evolution of
+the OpenORB project more transparent and to allow the community to take part in
+making decisions about its future.
+
+OpenORB provides a Java implementation of the OMG CORBA 2.4.2 specification.
+Along with the ORB, the following OMG Services are provided:
+
+ * Concurrency Control Service
+ * Event Service
+ * Interoperable Naming Service
+ * Notification Service
+ * Persistent State Service
+ * Property Service
+ * Time Service
+ * Trading Service
+ * Transaction Service
+
+WWW: http://openorb.sourceforge.net/