aboutsummaryrefslogtreecommitdiff
path: root/devel/opentop/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-12-05 21:13:31 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-12-05 21:13:31 +0000
commit94d0728d0346b4778dbc920bdb370ffef0cfe093 (patch)
tree63dc1d35e817539c26ffc65071bfc4e33243ba24 /devel/opentop/Makefile
parent8caf43c2d8e94a18cd72b733603426e95c4f26c7 (diff)
downloadports-94d0728d0346b4778dbc920bdb370ffef0cfe093.tar.gz
ports-94d0728d0346b4778dbc920bdb370ffef0cfe093.zip
Notes
Diffstat (limited to 'devel/opentop/Makefile')
-rw-r--r--devel/opentop/Makefile64
1 files changed, 64 insertions, 0 deletions
diff --git a/devel/opentop/Makefile b/devel/opentop/Makefile
new file mode 100644
index 000000000000..4cc55581c782
--- /dev/null
+++ b/devel/opentop/Makefile
@@ -0,0 +1,64 @@
+# New ports collection makefile for: opentop
+# Date created: 17 November 2003
+# Whom: Sergey Matveychuk <sem@ciam.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= opentop
+PORTVERSION= 1.3.0
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= open-top
+DISTNAME= ${PORTNAME}-${PORTVERSION:C|\.|-|g}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
+ ${DOCDIST}${EXTRACT_SUFX}
+
+MAINTAINER= sem@ciam.ru
+COMMENT= A cross-platform C++ framework library
+
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+INSTALLS_SHLIB= yes
+
+DOCDIST= ${PORTNAME}-api-${PORTVERSION:C|\.[0-9]$||:C|\.|-|g}
+
+WCHAR= "@comment "
+STATIC= "@comment "
+DEBUG= "@comment "
+
+ALL_TARGET= release_multi_char_shared
+
+.if defined(WITH_WCHAR)
+ALL_TARGET+= release_multi_wchar_shared
+WCHAR= ""
+.endif
+.if defined(WITH_DEBUG)
+ALL_TARGET+= debug_multi_char_shared
+.if defined(WITH_WCHAR)
+ALL_TARGET+= debug_multi_wchar_shared
+.endif
+DEBUG= ""
+.endif
+
+PLIST_SUB+= WCHAR=${WCHAR} DEBUG=${DEBUG}
+
+post-patch:
+ @${REINPLACE_CMD} "s/-O3/${CFLAGS}/" \
+ ${WRKSRC}/buildtools/cxx_compiler_options \
+ ${WRKSRC}/buildtools/gcc_compiler_options
+
+do-install:
+ ${MKDIR} ${PREFIX}/include/${PORTNAME}
+ cd ${WRKSRC}; ${FIND} ot -name *.h -print | ${TAR} cTf - - | \
+ ${TAR} xUCf ${PREFIX}/include/${PORTNAME} -
+ ${INSTALL_PROGRAM} ${WRKSRC}/lib/*.so ${PREFIX}/lib
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @cd ${WRKDIR}/${DOCDIST}/html; ${TAR} cf - . | ${TAR} xUCf ${DOCSDIR} -
+.endif
+
+.include <bsd.port.mk>