aboutsummaryrefslogtreecommitdiff
path: root/devel/opentop
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-02-10 21:54:20 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-02-10 21:54:20 +0000
commitd0eea3a359b28b5609ed5006e0b0e92909fb21ed (patch)
treecd2871a9c5a78c8ef3e0a1ef17edcfdce46e2089 /devel/opentop
parenta3e6101ad490b4b42de24e56a852665e7c187162 (diff)
downloadports-d0eea3a359b28b5609ed5006e0b0e92909fb21ed.tar.gz
ports-d0eea3a359b28b5609ed5006e0b0e92909fb21ed.zip
Notes
Diffstat (limited to 'devel/opentop')
-rw-r--r--devel/opentop/Makefile78
-rw-r--r--devel/opentop/distinfo2
-rw-r--r--devel/opentop/pkg-plist8
3 files changed, 61 insertions, 27 deletions
diff --git a/devel/opentop/Makefile b/devel/opentop/Makefile
index 464bea77125b..484d2fe828fc 100644
--- a/devel/opentop/Makefile
+++ b/devel/opentop/Makefile
@@ -7,7 +7,7 @@
PORTNAME= opentop
PORTVERSION= 1.3.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= open-top
@@ -25,25 +25,66 @@ INSTALLS_SHLIB= yes
DOCDIST= ${PORTNAME}-api-${PORTVERSION:C|\.[0-9]$||:C|\.|-|g}
-WCHAR= "@comment "
-STATIC= "@comment "
-DEBUG= "@comment "
+OPTIONS= DEBUG "Build library with debug symbols" off \
+ SINGLE_THRD "Build single-threaded library" off \
+ WCHAR "Build wchar_t support library instead of char" off \
+ STATIC "Build static library instead of dynamic" off
-ALL_TARGET= release_multi_char_shared
+.include <bsd.port.pre.mk>
+
+# Defaults: always build release, multi-threaded, char supported, shared
+TYPE= release
+THREAD= multi
+CHAR= char
+LIBS= shared
-.if defined(WITH_WCHAR)
-ALL_TARGET+= release_multi_wchar_shared
-WCHAR= ""
-.endif
.if defined(WITH_DEBUG)
-ALL_TARGET+= debug_multi_char_shared
+TYPE+= debug
+.endif
+.if defined(WITH_SINGLE_THRD)
+THREAD+= single
+.endif
.if defined(WITH_WCHAR)
-ALL_TARGET+= debug_multi_wchar_shared
+CHAR+= wchar
.endif
-DEBUG= ""
+.if defined(WITH_STATIC)
+LIBS+= static
.endif
-PLIST_SUB+= WCHAR=${WCHAR} DEBUG=${DEBUG}
+PLIST_FILES!=for r in ${TYPE}; do \
+ for t in ${THREAD}; do \
+ for c in ${CHAR}; do \
+ for l in ${LIBS}; do \
+ type=""; thread=""; \
+ char=""; ext="so"; \
+ if [ "$$r" = "debug" ]; then \
+ type="d"; \
+ fi; \
+ if [ "$$t" = "multi" ]; then \
+ thread="mt"; \
+ fi; \
+ if [ "$$c" = "wchar" ]; then \
+ char="w"; \
+ fi; \
+ if [ "$$l" = "static" ]; then \
+ ext="a"; \
+ fi; \
+ ${ECHO_CMD} "lib/libopentop-gcc$${char}$${thread}$${type}.$${ext}"; \
+ ${ECHO_CMD} "lib/libotxml-gcc$${char}$${thread}$${type}.$${ext}"; \
+ done; \
+ done;\
+ done; \
+ done
+
+.for r in ${TYPE}
+.for t in ${THREAD}
+.for c in ${CHAR}
+.for l in ${LIBS}
+ALL_TARGET+= $r_$t_$c_$l
+.endfor
+.endfor
+.endfor
+.endfor
post-patch:
@${REINPLACE_CMD} "s/-O3/${CFLAGS}/" \
@@ -51,15 +92,14 @@ post-patch:
${WRKSRC}/buildtools/gcc_compiler_options
do-install:
- ${MKDIR} ${PREFIX}/include/${PORTNAME}
+ @${MKDIR} ${PREFIX}/include/${PORTNAME}; \
cd ${WRKSRC}; ${FIND} ot -name *.h -print | ${TAR} cTf - - | \
- ${TAR} xUCf ${PREFIX}/include/${PORTNAME} -
- ${INSTALL_PROGRAM} ${WRKSRC}/lib/*.so ${PREFIX}/lib
-
-post-install:
+ ${TAR} xUCf ${PREFIX}/include/${PORTNAME} - ; \
+ ${FIND} lib \( -name "*.so" -o -name "*.a" \) -exec \
+ ${INSTALL_PROGRAM} \{\} ${PREFIX}/lib \;
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@cd ${WRKDIR}/${DOCDIST}/html; ${TAR} cf - . | ${TAR} xUCf ${DOCSDIR} -
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/opentop/distinfo b/devel/opentop/distinfo
index 66830add6eb2..7fa682428e33 100644
--- a/devel/opentop/distinfo
+++ b/devel/opentop/distinfo
@@ -1,2 +1,4 @@
MD5 (opentop-1-3-0.tar.gz) = b1aa1e140f5eb912e832ac453e6acc21
+SIZE (opentop-1-3-0.tar.gz) = 873032
MD5 (opentop-api-1-3.tar.gz) = 059b4300f193ac6d4e21f74cc9d894d2
+SIZE (opentop-api-1-3.tar.gz) = 445165
diff --git a/devel/opentop/pkg-plist b/devel/opentop/pkg-plist
index 915c698bb64c..33ba8178295a 100644
--- a/devel/opentop/pkg-plist
+++ b/devel/opentop/pkg-plist
@@ -251,14 +251,6 @@ include/opentop/ot/xmlcat/CatalogResolver.h
include/opentop/ot/xmlcat/CatalogSerialisationContext.h
include/opentop/ot/xmlcat/CatalogSet.h
include/opentop/ot/xmlcat/defs.h
-lib/libopentop-gccmt.so
-lib/libotxml-gccmt.so
-%%WCHAR%%lib/libopentop-gccwmt.so
-%%WCHAR%%lib/libotxml-gccwmt.so
-%%DEBUG%%lib/libopentop-gccmtd.so
-%%DEBUG%%lib/libotxml-gccmtd.so
-%%DEBUG%%%%WCHAR%%lib/libopentop-gccwmtd.so
-%%DEBUG%%%%WCHAR%%lib/libotxml-gccwmtd.so
%%PORTDOCS%%%%DOCSDIR%%/allclasses-frame.html
%%PORTDOCS%%%%DOCSDIR%%/glossary.html
%%PORTDOCS%%%%DOCSDIR%%/index.html