aboutsummaryrefslogtreecommitdiff
path: root/devel/opentop
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-02-19 09:11:13 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-02-19 09:11:13 +0000
commitd506c164b6cd6cf2954a53e95d59c57a85eb1eed (patch)
tree93f644d1c0ba2f4430c64938c17de81db7c3cc70 /devel/opentop
parent9321a1b4891f20a9cc605a1584ab40c38a2ded60 (diff)
downloadports-d506c164b6cd6cf2954a53e95d59c57a85eb1eed.tar.gz
ports-d506c164b6cd6cf2954a53e95d59c57a85eb1eed.zip
Notes
Diffstat (limited to 'devel/opentop')
-rw-r--r--devel/opentop/Makefile5
-rw-r--r--devel/opentop/pkg-plist15
2 files changed, 18 insertions, 2 deletions
diff --git a/devel/opentop/Makefile b/devel/opentop/Makefile
index 484d2fe828fc..752ee3f464b4 100644
--- a/devel/opentop/Makefile
+++ b/devel/opentop/Makefile
@@ -7,7 +7,7 @@
PORTNAME= opentop
PORTVERSION= 1.3.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= open-top
@@ -93,7 +93,8 @@ post-patch:
do-install:
@${MKDIR} ${PREFIX}/include/${PORTNAME}; \
- cd ${WRKSRC}; ${FIND} ot -name *.h -print | ${TAR} cTf - - | \
+ cd ${WRKSRC}; ${FIND} ot \( -name "*.h" -o -name "*.inl" \) -print | \
+ ${TAR} cTf - - | \
${TAR} xUCf ${PREFIX}/include/${PORTNAME} - ; \
${FIND} lib \( -name "*.so" -o -name "*.a" \) -exec \
${INSTALL_PROGRAM} \{\} ${PREFIX}/lib \;
diff --git a/devel/opentop/pkg-plist b/devel/opentop/pkg-plist
index 33ba8178295a..e47c48a45ebc 100644
--- a/devel/opentop/pkg-plist
+++ b/devel/opentop/pkg-plist
@@ -12,11 +12,16 @@ include/opentop/ot/auxil/TraceHelper.h
include/opentop/ot/auxil/defs.h
include/opentop/ot/auxil/messages.h
include/opentop/ot/base/ArrayAutoPtr.h
+include/opentop/ot/base/ArrayAutoPtr.inl
include/opentop/ot/base/AtomicCounter.h
include/opentop/ot/base/AutoBuffer.h
+include/opentop/ot/base/AutoBuffer.inl
include/opentop/ot/base/AutoLock.h
+include/opentop/ot/base/AutoLock.inl
include/opentop/ot/base/AutoUnlock.h
+include/opentop/ot/base/AutoUnlock.inl
include/opentop/ot/base/Character.h
+include/opentop/ot/base/Character.inl
include/opentop/ot/base/CodeConverterBase.h
include/opentop/ot/base/ConditionVariable.h
include/opentop/ot/base/Exception.h
@@ -28,6 +33,7 @@ include/opentop/ot/base/IllegalStateException.h
include/opentop/ot/base/IllegalThreadStateException.h
include/opentop/ot/base/InterruptedException.h
include/opentop/ot/base/ManagedObject.h
+include/opentop/ot/base/ManagedObject.inl
include/opentop/ot/base/MessageFactory.h
include/opentop/ot/base/Monitor.h
include/opentop/ot/base/Mutex.h
@@ -37,22 +43,28 @@ include/opentop/ot/base/OSException.h
include/opentop/ot/base/ObjectManager.h
include/opentop/ot/base/RecursiveMutex.h
include/opentop/ot/base/RefPtr.h
+include/opentop/ot/base/RefPtr.inl
include/opentop/ot/base/RefPtrMember.h
+include/opentop/ot/base/RefPtrMember.inl
include/opentop/ot/base/Runnable.h
include/opentop/ot/base/RuntimeException.h
include/opentop/ot/base/String.h
include/opentop/ot/base/StringIterator.h
+include/opentop/ot/base/StringIterator.inl
include/opentop/ot/base/StringUtils.h
include/opentop/ot/base/SynchronizedObject.h
include/opentop/ot/base/System.h
include/opentop/ot/base/SystemCodeConverter.h
+include/opentop/ot/base/SystemCodeConverter.inl
include/opentop/ot/base/SystemMonitor.h
include/opentop/ot/base/SystemUtils.h
include/opentop/ot/base/Thread.h
include/opentop/ot/base/ThreadId.h
include/opentop/ot/base/ThreadLocal.h
include/opentop/ot/base/Tracer.h
+include/opentop/ot/base/Tracer.inl
include/opentop/ot/base/UnicodeCharacterType.h
+include/opentop/ot/base/UnicodeCharacterType.inl
include/opentop/ot/base/UnsupportedOperationException.h
include/opentop/ot/base/Win32Exception.h
include/opentop/ot/base/compdefs.h
@@ -62,6 +74,7 @@ include/opentop/ot/base/defs.h
include/opentop/ot/base/gendefs.h
include/opentop/ot/base/libname.h
include/opentop/ot/base/stringfunc.h
+include/opentop/ot/base/stringfunc.inl
include/opentop/ot/base/threaddefs.h
include/opentop/ot/base/version.h
include/opentop/ot/base/winconfig.h
@@ -85,6 +98,7 @@ include/opentop/ot/io/ByteArrayInputStream.h
include/opentop/ot/io/ByteArrayOutputStream.h
include/opentop/ot/io/CharacterCodingException.h
include/opentop/ot/io/Console.h
+include/opentop/ot/io/Console.inl
include/opentop/ot/io/ExistingFileException.h
include/opentop/ot/io/File.h
include/opentop/ot/io/FileDescriptor.h
@@ -232,6 +246,7 @@ include/opentop/ot/xml/QName.h
include/opentop/ot/xml/Scanner.h
include/opentop/ot/xml/ScannerPosition.h
include/opentop/ot/xml/StreamPosition.h
+include/opentop/ot/xml/StreamPosition.inl
include/opentop/ot/xml/UnsupportedFeatureException.h
include/opentop/ot/xml/XMLFeatures.h
include/opentop/ot/xml/XMLFilterReader.h