aboutsummaryrefslogtreecommitdiff
path: root/devel/orbitcpp
diff options
context:
space:
mode:
authorAlexander Nedotsukov <bland@FreeBSD.org>2004-05-19 06:13:51 +0000
committerAlexander Nedotsukov <bland@FreeBSD.org>2004-05-19 06:13:51 +0000
commit1d7cd048165d02734922dc3f6642530647117934 (patch)
tree301c67d11798600a92159f1fd71ad3e562dc5813 /devel/orbitcpp
parentf7cd6cbea092793892ef15dde23149af411f8bfb (diff)
downloadports-1d7cd048165d02734922dc3f6642530647117934.tar.gz
ports-1d7cd048165d02734922dc3f6642530647117934.zip
Notes
Diffstat (limited to 'devel/orbitcpp')
-rw-r--r--devel/orbitcpp/Makefile9
-rw-r--r--devel/orbitcpp/distinfo4
-rw-r--r--devel/orbitcpp/files/patch-configure10
-rw-r--r--devel/orbitcpp/files/patch-orbitcpp::idl-compiller::pass_xlate.cc11
-rw-r--r--devel/orbitcpp/files/patch-orbitcpp::idl-compiller::types::IDLTypeCode.cpp17
-rw-r--r--devel/orbitcpp/files/patch-orbitcpp::idl-compiller::types::IDLTypeCode.h15
-rw-r--r--devel/orbitcpp/files/patch-orbitcpp::orb-cpp::orbitcpp_typecode.h27
-rw-r--r--devel/orbitcpp/pkg-plist14
8 files changed, 20 insertions, 87 deletions
diff --git a/devel/orbitcpp/Makefile b/devel/orbitcpp/Makefile
index 068b6d517c75..5e64091102ec 100644
--- a/devel/orbitcpp/Makefile
+++ b/devel/orbitcpp/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= orbitcpp
-PORTVERSION= 1.3.8
-PORTREVISION= 3
+PORTVERSION= 1.3.9
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:R}
@@ -16,8 +15,12 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= C++ bindings for ORBit, a CORBA 2.2-compliant ORB
USE_BZIP2= yes
-USE_GNOME= gnomehack orbit2
+USE_REINPLACE= yes
+USE_GNOME= gnomehack lthack orbit2
USE_LIBTOOL_VER= 13
INSTALLS_SHLIB= yes
+post-patch:
+ @${REINPLACE_CMD} -e 's|^\(SUBDIRS =.*\)test\(.*\)|\1\2|' ${WRKSRC}/Makefile.in
+
.include <bsd.port.mk>
diff --git a/devel/orbitcpp/distinfo b/devel/orbitcpp/distinfo
index 1f2dcdd3f99f..c9e9a85b197e 100644
--- a/devel/orbitcpp/distinfo
+++ b/devel/orbitcpp/distinfo
@@ -1,2 +1,2 @@
-MD5 (orbitcpp-1.3.8.tar.bz2) = 76cf5eccc039501dc854614c349e9c57
-SIZE (orbitcpp-1.3.8.tar.bz2) = 239878
+MD5 (orbitcpp-1.3.9.tar.bz2) = ef1594819cf62fc2dad6e0a1cc4cb578
+SIZE (orbitcpp-1.3.9.tar.bz2) = 297985
diff --git a/devel/orbitcpp/files/patch-configure b/devel/orbitcpp/files/patch-configure
deleted file mode 100644
index 45b708aeaa6c..000000000000
--- a/devel/orbitcpp/files/patch-configure
+++ /dev/null
@@ -1,10 +0,0 @@
---- configure.orig Wed Jan 8 01:14:54 2003
-+++ configure Sun Jan 19 02:10:46 2003
-@@ -7511,6 +7511,7 @@
-
- # This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
-
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/devel/orbitcpp/files/patch-orbitcpp::idl-compiller::pass_xlate.cc b/devel/orbitcpp/files/patch-orbitcpp::idl-compiller::pass_xlate.cc
deleted file mode 100644
index a409dd6acfcd..000000000000
--- a/devel/orbitcpp/files/patch-orbitcpp::idl-compiller::pass_xlate.cc
+++ /dev/null
@@ -1,11 +0,0 @@
---- orbitcpp/idl-compiler/pass_xlate.cc.orig Tue Nov 18 12:35:41 2003
-+++ orbitcpp/idl-compiler/pass_xlate.cc Tue Nov 18 12:36:16 2003
-@@ -1328,7 +1328,7 @@
- {
- string array_id = m_dest.get_cpp_typename ();
- string slice_id = array_id + "_slice";
-- string props_id = m_dest.get_cpp_typename () + "Props";
-+ string props_id = m_dest.get_cpp_identifier () + "Props";
-
- int length = 1;
- for (IDLArray::const_iterator i = m_array.begin ();
diff --git a/devel/orbitcpp/files/patch-orbitcpp::idl-compiller::types::IDLTypeCode.cpp b/devel/orbitcpp/files/patch-orbitcpp::idl-compiller::types::IDLTypeCode.cpp
deleted file mode 100644
index 8921bfffd103..000000000000
--- a/devel/orbitcpp/files/patch-orbitcpp::idl-compiller::types::IDLTypeCode.cpp
+++ /dev/null
@@ -1,17 +0,0 @@
---- orbitcpp/idl-compiler/types/IDLTypeCode.cc 14 Sep 2002 13:13:10 -0000 1.1
-+++ orbitcpp/idl-compiler/types/IDLTypeCode.cc 15 Mar 2004 01:01:28 -0000 1.2
-@@ -54,3 +54,14 @@
- {
- return get_cpp_typename ();
- }
-+
-+void
-+IDLTypeCode::member_pack_to_c (ostream &ostr,
-+ Indent &indent,
-+ const string &cpp_id,
-+ const string &c_id,
-+ const IDLTypedef *active_typedef) const
-+{
-+ ostr << indent << c_id << " = ((" << cpp_id << ".in() != 0) ? ::_orbitcpp::duplicate_guarded("
-+ << cpp_id << ".in()->_orbitcpp_cobj ()) : CORBA_OBJECT_NIL)" << ';' << endl;
-+}
diff --git a/devel/orbitcpp/files/patch-orbitcpp::idl-compiller::types::IDLTypeCode.h b/devel/orbitcpp/files/patch-orbitcpp::idl-compiller::types::IDLTypeCode.h
deleted file mode 100644
index 9a9ccaa26fa4..000000000000
--- a/devel/orbitcpp/files/patch-orbitcpp::idl-compiller::types::IDLTypeCode.h
+++ /dev/null
@@ -1,15 +0,0 @@
---- orbitcpp/idl-compiler/types/IDLTypeCode.h 14 Sep 2002 13:13:10 -0000 1.1
-+++ orbitcpp/idl-compiler/types/IDLTypeCode.h 15 Mar 2004 01:01:28 -0000 1.2
-@@ -40,6 +40,12 @@
- string get_cpp_typename () const;
-
- string get_cpp_stub_typename () const;
-+
-+ void member_pack_to_c (ostream &ostr,
-+ Indent &indent,
-+ const string &cpp_id,
-+ const string &c_id,
-+ const IDLTypedef *active_typedef = 0) const;
- };
-
- #endif //ORBITCPP_TYPES_IDLTYPECODE
diff --git a/devel/orbitcpp/files/patch-orbitcpp::orb-cpp::orbitcpp_typecode.h b/devel/orbitcpp/files/patch-orbitcpp::orb-cpp::orbitcpp_typecode.h
deleted file mode 100644
index 8465fe4dd7ea..000000000000
--- a/devel/orbitcpp/files/patch-orbitcpp::orb-cpp::orbitcpp_typecode.h
+++ /dev/null
@@ -1,27 +0,0 @@
---- orbitcpp/orb-cpp/orbitcpp_typecode.h 2 Jul 2003 23:47:23 -0000 1.7
-+++ orbitcpp/orb-cpp/orbitcpp_typecode.h 15 Mar 2004 00:58:59 -0000 1.9
-@@ -137,6 +137,7 @@
- typedef TypeCode *TypeCode_ptr;
- typedef ::_orbitcpp::ObjectPtr_var<TypeCode>
- TypeCode_var;
-+ typedef TypeCode_var TypeCode_mgr;
-
- class TypeCode
- {
-@@ -207,6 +208,16 @@
- }
-
- static TypeCode_ptr _orbitcpp_wrap (CORBA_TypeCode tc, bool take_copy = false);
-+ static void unpack_elem(TypeCode_mgr& cpp_elem, CORBA_TypeCode c_elem)
-+ {
-+ cpp_elem = _orbitcpp_wrap(c_elem, true);
-+ }
-+
-+ static void pack_elem(TypeCode_mgr const& cpp_elem, CORBA_TypeCode& c_elem)
-+ {
-+ c_elem = _orbitcpp::duplicate_guarded(cpp_elem->_orbitcpp_cobj ());
-+
-+ }
- };
-
- inline void release(TypeCode_ptr o) {
diff --git a/devel/orbitcpp/pkg-plist b/devel/orbitcpp/pkg-plist
index d491e99df37d..b06146174885 100644
--- a/devel/orbitcpp/pkg-plist
+++ b/devel/orbitcpp/pkg-plist
@@ -14,6 +14,7 @@ include/orbitcpp-2.0/orbitcpp/orb-cpp/orbitcpp_simple_seq.h
include/orbitcpp-2.0/orbitcpp/orb-cpp/orbitcpp_smartptr.h
include/orbitcpp-2.0/orbitcpp/orb-cpp/orbitcpp_string_seq.h
include/orbitcpp-2.0/orbitcpp/orb-cpp/orbitcpp_tools.h
+include/orbitcpp-2.0/orbitcpp/orb-cpp/orbitcpp_traits.h
include/orbitcpp-2.0/orbitcpp/orb-cpp/orbitcpp_typecode.h
include/orbitcpp-2.0/orbitcpp/orb-cpp/orbitcpp_types.h
include/orbitcpp-2.0/orbitcpp/orb-cpp/orbitcpp_var_smartptr.h
@@ -32,13 +33,22 @@ include/orbitcpp-2.0/orbitcpp/orb-cpp/smartpointers/sequence_out.h
include/orbitcpp-2.0/orbitcpp/orb-cpp/smartpointers/sequence_var.h
include/orbitcpp-2.0/orbitcpp/orb-cpp/smartpointers/string_out.h
include/orbitcpp-2.0/orbitcpp/orb-cpp/smartpointers/string_var.h
+include/orbitcpp-2.0/services/name/CosNaming-cpp-common.h
+include/orbitcpp-2.0/services/name/CosNaming-cpp-stubs.h
+include/orbitcpp-2.0/services/name/CosNaming.h
lib/libORBit-2-cpp.a
lib/libORBit-2-cpp.so
-lib/libORBit-2-cpp.so.8
+lib/libORBit-2-cpp.so.9
+lib/libORBitCosNaming-2-cpp.a
+lib/libORBitCosNaming-2-cpp.so
+lib/libORBitCosNaming-2-cpp.so.9
lib/orbit-2.0/idl-backends/libORBit-idl-backend-cpp.a
lib/orbit-2.0/idl-backends/libORBit-idl-backend-cpp.so
-lib/orbit-2.0/idl-backends/libORBit-idl-backend-cpp.so.8
+lib/orbit-2.0/idl-backends/libORBit-idl-backend-cpp.so.9
libdata/pkgconfig/ORBit-2.0-cpp.pc
+libdata/pkgconfig/ORBit-CosNaming-2.0-cpp.pc
+@dirrm include/orbitcpp-2.0/services/name
+@dirrm include/orbitcpp-2.0/services
@dirrm include/orbitcpp-2.0/orbitcpp/orb-cpp/smartpointers
@dirrm include/orbitcpp-2.0/orbitcpp/orb-cpp
@dirrm include/orbitcpp-2.0/orbitcpp