aboutsummaryrefslogtreecommitdiff
path: root/devel/orbitcpp
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-06-20 15:48:49 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-06-20 15:48:49 +0000
commitf40bc8475216f3521dd900c21970cc19fe46b7dc (patch)
tree7c59fe1efae7430a9e48e96ff4f507d96d892834 /devel/orbitcpp
parent5cbe4654700cc6e51efc4713ff759ef54b4c000c (diff)
downloadports-f40bc8475216f3521dd900c21970cc19fe46b7dc.tar.gz
ports-f40bc8475216f3521dd900c21970cc19fe46b7dc.zip
Notes
Diffstat (limited to 'devel/orbitcpp')
-rw-r--r--devel/orbitcpp/Makefile2
-rw-r--r--devel/orbitcpp/files/patch-orbitcpp::idl-compiller::types:IDLStruct.h11
-rw-r--r--devel/orbitcpp/files/patch-orbitcpp::idl-compiller::types:IDLUnion.h11
3 files changed, 23 insertions, 1 deletions
diff --git a/devel/orbitcpp/Makefile b/devel/orbitcpp/Makefile
index 1736494ac114..62a76eefee7a 100644
--- a/devel/orbitcpp/Makefile
+++ b/devel/orbitcpp/Makefile
@@ -7,7 +7,7 @@
PORTNAME= orbitcpp
PORTVERSION= 1.3.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:R}
diff --git a/devel/orbitcpp/files/patch-orbitcpp::idl-compiller::types:IDLStruct.h b/devel/orbitcpp/files/patch-orbitcpp::idl-compiller::types:IDLStruct.h
new file mode 100644
index 000000000000..d0579b763c48
--- /dev/null
+++ b/devel/orbitcpp/files/patch-orbitcpp::idl-compiller::types:IDLStruct.h
@@ -0,0 +1,11 @@
+--- orbitcpp/idl-compiler/types/IDLStruct.h.orig Fri Jun 20 14:36:07 2003
++++ orbitcpp/idl-compiler/types/IDLStruct.h Fri Jun 20 14:36:26 2003
+@@ -33,7 +33,7 @@
+ #include "IDLCompound.h"
+ #include "IDLCompoundSeqElem.h"
+
+-class IDLStruct: public IDLCompound, public virtual IDLType, public IDLCompoundSeqElem
++class IDLStruct: public IDLCompound, public IDLCompoundSeqElem
+ {
+ public:
+ IDLStruct(const string &id,
diff --git a/devel/orbitcpp/files/patch-orbitcpp::idl-compiller::types:IDLUnion.h b/devel/orbitcpp/files/patch-orbitcpp::idl-compiller::types:IDLUnion.h
new file mode 100644
index 000000000000..5de45d00b4ca
--- /dev/null
+++ b/devel/orbitcpp/files/patch-orbitcpp::idl-compiller::types:IDLUnion.h
@@ -0,0 +1,11 @@
+--- orbitcpp/idl-compiler/types/IDLUnion.h.orig Fri Jun 20 15:05:07 2003
++++ orbitcpp/idl-compiler/types/IDLUnion.h Fri Jun 20 15:05:33 2003
+@@ -34,7 +34,7 @@
+ #include "IDLCompoundSeqElem.h"
+ //#include "language.h"
+
+-class IDLUnion: public virtual IDLType, public IDLScope, public IDLCompoundSeqElem
++class IDLUnion: public IDLScope, public IDLCompoundSeqElem
+ {
+ const IDLUnionDiscriminator &m_discriminator;
+