aboutsummaryrefslogtreecommitdiff
path: root/devel/oskit
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-02-28 16:49:20 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-02-28 16:49:20 +0000
commit22cb27d26cf43beaae0520efbccb44924c75900a (patch)
treeda3c932a0211c3bdd4af47007b49aa7ed672b2c3 /devel/oskit
parentcdbbc4b9b5dd23f4ee4967e9b1ba7609cc1c4f57 (diff)
downloadports-22cb27d26cf43beaae0520efbccb44924c75900a.tar.gz
ports-22cb27d26cf43beaae0520efbccb44924c75900a.zip
Notes
Diffstat (limited to 'devel/oskit')
-rw-r--r--devel/oskit/Makefile28
-rw-r--r--devel/oskit/distinfo1
-rw-r--r--devel/oskit/pkg-descr15
-rw-r--r--devel/oskit/pkg-plist838
4 files changed, 882 insertions, 0 deletions
diff --git a/devel/oskit/Makefile b/devel/oskit/Makefile
new file mode 100644
index 000000000000..564b4d6e1293
--- /dev/null
+++ b/devel/oskit/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: oskit
+# Date created: 25 Nov 2003
+# Whom: jerry
+#
+# $FreeBSD$
+#
+
+PORTNAME= oskit
+PORTVERSION= 20020317
+CATEGORIES= devel
+MASTER_SITES= ftp://flux.cs.utah.edu/flux/oskit/
+
+MAINTAINER= unidevel@yahoo.com.cn
+COMMENT= Framework and a set of libraries for developing operating systems
+
+BUILD_DEPENDS= gcc295:${PORTSDIR}/lang/gcc295
+RUN_DEPENDS= gcc295:${PORTSDIR}/lang/gcc295
+
+OSKITDIR= ${PORTNAME}
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CFLAGS=-O2 LIBS=-lposix
+USE_GMAKE= yes
+USE_GCC= 2.95
+MAKEFILE= GNUmakefile
+STRIP=
+
+.include <bsd.port.mk>
diff --git a/devel/oskit/distinfo b/devel/oskit/distinfo
new file mode 100644
index 000000000000..373c89a75376
--- /dev/null
+++ b/devel/oskit/distinfo
@@ -0,0 +1 @@
+MD5 (oskit-20020317.tar.gz) = 258f256a87c19bf1a49090c46ea0e51b
diff --git a/devel/oskit/pkg-descr b/devel/oskit/pkg-descr
new file mode 100644
index 000000000000..c528e5d73ad1
--- /dev/null
+++ b/devel/oskit/pkg-descr
@@ -0,0 +1,15 @@
+The OSKit is a framework and a set of component libraries oriented to operating
+systems, together with extensive documentation. By providing in a modular way
+not only most of the infrastructure "grunge" needed by an OS, but also many
+higher-level components, the OSKit's goal is to lower the barrier to entry to
+OS R&D and to lower its costs. The OSKit makes it vastly easier to create a new
+OS, port an existing OS to the x86 (or in the future, to other architectures
+supported by the OSkit), or enhance an OS to support a wider range of devices,
+file system formats, executable formats, or network services. The OSKit also
+works well for constructing OS-related programs, such as boot loaders or
+OS-level servers atop a microkernel.
+
+WWW: http://www.cs.utah.edu/flux/oskit/index.html
+
+- jerry
+unidevel@yahoo.com.cn
diff --git a/devel/oskit/pkg-plist b/devel/oskit/pkg-plist
new file mode 100644
index 000000000000..e5f11ce329e5
--- /dev/null
+++ b/devel/oskit/pkg-plist
@@ -0,0 +1,838 @@
+bin/mkmb2
+bin/mkmbimage
+bin/sym-trace
+bin/x86-oskit-gcc
+include/crt/x86/crti.h
+include/flask/access_vectors
+include/flask/av_inherit.h
+include/flask/av_perm_to_string.h
+include/flask/av_permissions.h
+include/flask/class_to_string.h
+include/flask/common_perm_to_string.h
+include/flask/flask.h
+include/flask/initial_sid_to_string.h
+include/flask/initial_sids
+include/flask/security_classes
+include/oskit/amm.h
+include/oskit/anno.h
+include/oskit/arm32/asm.h
+include/oskit/arm32/atomic.h
+include/oskit/arm32/base_cpu.h
+include/oskit/arm32/base_irq.h
+include/oskit/arm32/base_multiboot.h
+include/oskit/arm32/base_paging.h
+include/oskit/arm32/base_stack.h
+include/oskit/arm32/base_trap.h
+include/oskit/arm32/base_vm.h
+include/oskit/arm32/byteorder.h
+include/oskit/arm32/c/float.h
+include/oskit/arm32/c/limits.h
+include/oskit/arm32/c/setjmp.h
+include/oskit/arm32/c/signal.h
+include/oskit/arm32/c/stdarg.h
+include/oskit/arm32/debug.h
+include/oskit/arm32/dev.h
+include/oskit/arm32/endian.h
+include/oskit/arm32/exec/elf.h
+include/oskit/arm32/gdb.h
+include/oskit/arm32/multiboot.h
+include/oskit/arm32/ofw/ofw.h
+include/oskit/arm32/ofw/ofw_cons.h
+include/oskit/arm32/ofw/ofw_console.h
+include/oskit/arm32/page.h
+include/oskit/arm32/paging.h
+include/oskit/arm32/param.h
+include/oskit/arm32/phys_lmm.h
+include/oskit/arm32/physmem.h
+include/oskit/arm32/pio.h
+include/oskit/arm32/proc_reg.h
+include/oskit/arm32/reset.h
+include/oskit/arm32/shark/base_console.h
+include/oskit/arm32/shark/base_irq.h
+include/oskit/arm32/shark/base_multiboot.h
+include/oskit/arm32/shark/base_vm.h
+include/oskit/arm32/shark/com_cons.h
+include/oskit/arm32/shark/com_console.h
+include/oskit/arm32/shark/direct_cons.h
+include/oskit/arm32/shark/direct_console.h
+include/oskit/arm32/shark/gdb_console.h
+include/oskit/arm32/shark/irq_list.h
+include/oskit/arm32/shark/isa.h
+include/oskit/arm32/shark/keyboard.h
+include/oskit/arm32/shark/phys_lmm.h
+include/oskit/arm32/shark/pic.h
+include/oskit/arm32/shark/pit.h
+include/oskit/arm32/shark/rtc.h
+include/oskit/arm32/softfloat.h
+include/oskit/arm32/spin_lock.h
+include/oskit/arm32/trap.h
+include/oskit/arm32/types.h
+include/oskit/arm32/uvm.h
+include/oskit/base_critical.h
+include/oskit/boolean.h
+include/oskit/boot/bootwhat.h
+include/oskit/c/a.out.h
+include/oskit/c/alloca.h
+include/oskit/c/arpa/inet.h
+include/oskit/c/arpa/nameser.h
+include/oskit/c/assert.h
+include/oskit/c/ctype.h
+include/oskit/c/dirent.h
+include/oskit/c/environment.h
+include/oskit/c/errno.h
+include/oskit/c/fcntl.h
+include/oskit/c/fd.h
+include/oskit/c/float.h
+include/oskit/c/fs.h
+include/oskit/c/limits.h
+include/oskit/c/malloc.h
+include/oskit/c/math.h
+include/oskit/c/mqueue.h
+include/oskit/c/netdb.h
+include/oskit/c/netinet/in.h
+include/oskit/c/netinet/ip.h
+include/oskit/c/netinet/tcp.h
+include/oskit/c/netinet/udp.h
+include/oskit/c/resolv.h
+include/oskit/c/semaphore.h
+include/oskit/c/setjmp.h
+include/oskit/c/signal.h
+include/oskit/c/stdarg.h
+include/oskit/c/stddef.h
+include/oskit/c/stdio.h
+include/oskit/c/stdlib.h
+include/oskit/c/string.h
+include/oskit/c/strings.h
+include/oskit/c/sys/filio.h
+include/oskit/c/sys/gmon.h
+include/oskit/c/sys/ioccom.h
+include/oskit/c/sys/ioctl.h
+include/oskit/c/sys/mman.h
+include/oskit/c/sys/mount.h
+include/oskit/c/sys/param.h
+include/oskit/c/sys/profile.h
+include/oskit/c/sys/signal.h
+include/oskit/c/sys/socket.h
+include/oskit/c/sys/stat.h
+include/oskit/c/sys/time.h
+include/oskit/c/sys/ttycom.h
+include/oskit/c/sys/types.h
+include/oskit/c/sys/uio.h
+include/oskit/c/sys/utsname.h
+include/oskit/c/sys/wait.h
+include/oskit/c/syslog.h
+include/oskit/c/termios.h
+include/oskit/c/time.h
+include/oskit/c/unistd.h
+include/oskit/c/utime.h
+include/oskit/c/wchar.h
+include/oskit/clientos.h
+include/oskit/com.h
+include/oskit/com/aggregate.h
+include/oskit/com/charqueue.h
+include/oskit/com/condvar.h
+include/oskit/com/libcenv.h
+include/oskit/com/listener.h
+include/oskit/com/listener_fanout.h
+include/oskit/com/listener_mgr.h
+include/oskit/com/lock.h
+include/oskit/com/lock_mgr.h
+include/oskit/com/mem.h
+include/oskit/com/pipe.h
+include/oskit/com/pqueue.h
+include/oskit/com/queue.h
+include/oskit/com/random.h
+include/oskit/com/services.h
+include/oskit/com/sfs.h
+include/oskit/com/storage.h
+include/oskit/com/stream.h
+include/oskit/com/trivial_stream.h
+include/oskit/com/wrapper.h
+include/oskit/compiler.h
+include/oskit/comsid.h
+include/oskit/config.h
+include/oskit/console.h
+include/oskit/debug.h
+include/oskit/dev/blk.h
+include/oskit/dev/bus.h
+include/oskit/dev/clock.h
+include/oskit/dev/dev.h
+include/oskit/dev/device.h
+include/oskit/dev/driver.h
+include/oskit/dev/error.h
+include/oskit/dev/ethernet.h
+include/oskit/dev/freebsd.h
+include/oskit/dev/freebsd_isa.h
+include/oskit/dev/ide.h
+include/oskit/dev/isa.h
+include/oskit/dev/linux.h
+include/oskit/dev/linux_ethernet.h
+include/oskit/dev/linux_scsi.h
+include/oskit/dev/membus.h
+include/oskit/dev/native.h
+include/oskit/dev/net.h
+include/oskit/dev/osenv.h
+include/oskit/dev/osenv_device.h
+include/oskit/dev/osenv_driver.h
+include/oskit/dev/osenv_intr.h
+include/oskit/dev/osenv_ioport.h
+include/oskit/dev/osenv_irq.h
+include/oskit/dev/osenv_isa.h
+include/oskit/dev/osenv_log.h
+include/oskit/dev/osenv_mem.h
+include/oskit/dev/osenv_pci_config.h
+include/oskit/dev/osenv_rtc.h
+include/oskit/dev/osenv_safe.h
+include/oskit/dev/osenv_sleep.h
+include/oskit/dev/osenv_timer.h
+include/oskit/dev/scsi.h
+include/oskit/dev/serial.h
+include/oskit/dev/soa.h
+include/oskit/dev/softirq.h
+include/oskit/dev/timer.h
+include/oskit/dev/tty.h
+include/oskit/diskpart/dec.h
+include/oskit/diskpart/disklabel.h
+include/oskit/diskpart/diskpart.h
+include/oskit/diskpart/omron.h
+include/oskit/diskpart/pcbios.h
+include/oskit/diskpart/vtoc.h
+include/oskit/dpf.h
+include/oskit/error.h
+include/oskit/exec/a.out.h
+include/oskit/exec/elf.h
+include/oskit/exec/exec.h
+include/oskit/flask/avc.h
+include/oskit/flask/avc_callback.h
+include/oskit/flask/avc_ss.h
+include/oskit/flask/flask_types.h
+include/oskit/flask/security.h
+include/oskit/freebsd/a.out.h
+include/oskit/freebsd/ar.h
+include/oskit/freebsd/arm32/ansi.h
+include/oskit/freebsd/arm32/endian.h
+include/oskit/freebsd/arm32/float.h
+include/oskit/freebsd/arm32/ieee.h
+include/oskit/freebsd/arm32/ieeefp.h
+include/oskit/freebsd/arm32/limits.h
+include/oskit/freebsd/arm32/lock.h
+include/oskit/freebsd/arm32/param.h
+include/oskit/freebsd/arm32/trap.h
+include/oskit/freebsd/arm32/types.h
+include/oskit/freebsd/arpa/ftp.h
+include/oskit/freebsd/arpa/inet.h
+include/oskit/freebsd/arpa/nameser.h
+include/oskit/freebsd/arpa/nameser_compat.h
+include/oskit/freebsd/arpa/telnet.h
+include/oskit/freebsd/arpa/tftp.h
+include/oskit/freebsd/assert.h
+include/oskit/freebsd/bitstring.h
+include/oskit/freebsd/ctype.h
+include/oskit/freebsd/db.h
+include/oskit/freebsd/dirent.h
+include/oskit/freebsd/disktab.h
+include/oskit/freebsd/dlfcn.h
+include/oskit/freebsd/elf.h
+include/oskit/freebsd/err.h
+include/oskit/freebsd/errno.h
+include/oskit/freebsd/fcntl.h
+include/oskit/freebsd/float.h
+include/oskit/freebsd/fnmatch.h
+include/oskit/freebsd/fstab.h
+include/oskit/freebsd/fts.h
+include/oskit/freebsd/glob.h
+include/oskit/freebsd/grp.h
+include/oskit/freebsd/histedit.h
+include/oskit/freebsd/i386/ansi.h
+include/oskit/freebsd/i386/asm.h
+include/oskit/freebsd/i386/asmacros.h
+include/oskit/freebsd/i386/elf.h
+include/oskit/freebsd/i386/endian.h
+include/oskit/freebsd/i386/float.h
+include/oskit/freebsd/i386/limits.h
+include/oskit/freebsd/i386/lock.h
+include/oskit/freebsd/i386/param.h
+include/oskit/freebsd/i386/signal.h
+include/oskit/freebsd/i386/trap.h
+include/oskit/freebsd/i386/types.h
+include/oskit/freebsd/ieeefp.h
+include/oskit/freebsd/iso646.h
+include/oskit/freebsd/kvm.h
+include/oskit/freebsd/limits.h
+include/oskit/freebsd/link.h
+include/oskit/freebsd/locale.h
+include/oskit/freebsd/machine
+include/oskit/freebsd/malloc.h
+include/oskit/freebsd/math.h
+include/oskit/freebsd/md5.h
+include/oskit/freebsd/memory.h
+include/oskit/freebsd/mpool.h
+include/oskit/freebsd/ndbm.h
+include/oskit/freebsd/net/bpf.h
+include/oskit/freebsd/net/bpf_compat.h
+include/oskit/freebsd/net/bpfdesc.h
+include/oskit/freebsd/net/ethernet.h
+include/oskit/freebsd/net/if.h
+include/oskit/freebsd/net/if_arp.h
+include/oskit/freebsd/net/if_dl.h
+include/oskit/freebsd/net/if_llc.h
+include/oskit/freebsd/net/if_media.h
+include/oskit/freebsd/net/if_mib.h
+include/oskit/freebsd/net/if_ppp.h
+include/oskit/freebsd/net/if_slvar.h
+include/oskit/freebsd/net/if_sppp.h
+include/oskit/freebsd/net/if_tun.h
+include/oskit/freebsd/net/if_types.h
+include/oskit/freebsd/net/if_var.h
+include/oskit/freebsd/net/netisr.h
+include/oskit/freebsd/net/radix.h
+include/oskit/freebsd/net/raw_cb.h
+include/oskit/freebsd/net/route.h
+include/oskit/freebsd/net/slcompress.h
+include/oskit/freebsd/net/slip.h
+include/oskit/freebsd/netdb.h
+include/oskit/freebsd/netinet/icmp_var.h
+include/oskit/freebsd/netinet/if_ether.h
+include/oskit/freebsd/netinet/if_fddi.h
+include/oskit/freebsd/netinet/igmp.h
+include/oskit/freebsd/netinet/igmp_var.h
+include/oskit/freebsd/netinet/in.h
+include/oskit/freebsd/netinet/in_pcb.h
+include/oskit/freebsd/netinet/in_systm.h
+include/oskit/freebsd/netinet/in_var.h
+include/oskit/freebsd/netinet/ip.h
+include/oskit/freebsd/netinet/ip_flow.h
+include/oskit/freebsd/netinet/ip_fw.h
+include/oskit/freebsd/netinet/ip_icmp.h
+include/oskit/freebsd/netinet/ip_mroute.h
+include/oskit/freebsd/netinet/ip_var.h
+include/oskit/freebsd/netinet/tcp.h
+include/oskit/freebsd/netinet/tcp_debug.h
+include/oskit/freebsd/netinet/tcp_fsm.h
+include/oskit/freebsd/netinet/tcp_seq.h
+include/oskit/freebsd/netinet/tcp_timer.h
+include/oskit/freebsd/netinet/tcp_var.h
+include/oskit/freebsd/netinet/tcpip.h
+include/oskit/freebsd/netinet/udp.h
+include/oskit/freebsd/netinet/udp_var.h
+include/oskit/freebsd/nl_types.h
+include/oskit/freebsd/nlist.h
+include/oskit/freebsd/objformat.h
+include/oskit/freebsd/paths.h
+include/oskit/freebsd/poll.h
+include/oskit/freebsd/protocols/dumprestore.h
+include/oskit/freebsd/protocols/routed.h
+include/oskit/freebsd/protocols/rwhod.h
+include/oskit/freebsd/protocols/talkd.h
+include/oskit/freebsd/protocols/timed.h
+include/oskit/freebsd/pthread.h
+include/oskit/freebsd/pthread_np.h
+include/oskit/freebsd/pwd.h
+include/oskit/freebsd/ranlib.h
+include/oskit/freebsd/regex.h
+include/oskit/freebsd/regexp.h
+include/oskit/freebsd/resolv.h
+include/oskit/freebsd/rpc/auth.h
+include/oskit/freebsd/rpc/auth_des.h
+include/oskit/freebsd/rpc/auth_unix.h
+include/oskit/freebsd/rpc/clnt.h
+include/oskit/freebsd/rpc/des.h
+include/oskit/freebsd/rpc/des_crypt.h
+include/oskit/freebsd/rpc/pmap_clnt.h
+include/oskit/freebsd/rpc/pmap_prot.h
+include/oskit/freebsd/rpc/pmap_rmt.h
+include/oskit/freebsd/rpc/rpc.h
+include/oskit/freebsd/rpc/rpc_com.h
+include/oskit/freebsd/rpc/rpc_msg.h
+include/oskit/freebsd/rpc/svc.h
+include/oskit/freebsd/rpc/svc_auth.h
+include/oskit/freebsd/rpc/types.h
+include/oskit/freebsd/rpc/xdr.h
+include/oskit/freebsd/rpcsvc/nis_db.h
+include/oskit/freebsd/rpcsvc/nis_tags.h
+include/oskit/freebsd/rpcsvc/nislib.h
+include/oskit/freebsd/rpcsvc/yp_prot.h
+include/oskit/freebsd/rpcsvc/ypclnt.h
+include/oskit/freebsd/rune.h
+include/oskit/freebsd/runetype.h
+include/oskit/freebsd/setjmp.h
+include/oskit/freebsd/sgtty.h
+include/oskit/freebsd/signal.h
+include/oskit/freebsd/stab.h
+include/oskit/freebsd/stdarg.h
+include/oskit/freebsd/stddef.h
+include/oskit/freebsd/stdio.h
+include/oskit/freebsd/stdlib.h
+include/oskit/freebsd/strhash.h
+include/oskit/freebsd/string.h
+include/oskit/freebsd/stringlist.h
+include/oskit/freebsd/strings.h
+include/oskit/freebsd/struct.h
+include/oskit/freebsd/sys/_posix.h
+include/oskit/freebsd/sys/acct.h
+include/oskit/freebsd/sys/buf.h
+include/oskit/freebsd/sys/bus.h
+include/oskit/freebsd/sys/callout.h
+include/oskit/freebsd/sys/ccdvar.h
+include/oskit/freebsd/sys/cdefs.h
+include/oskit/freebsd/sys/cdio.h
+include/oskit/freebsd/sys/chio.h
+include/oskit/freebsd/sys/clist.h
+include/oskit/freebsd/sys/conf.h
+include/oskit/freebsd/sys/dataacq.h
+include/oskit/freebsd/sys/device.h
+include/oskit/freebsd/sys/devicestat.h
+include/oskit/freebsd/sys/dir.h
+include/oskit/freebsd/sys/dirent.h
+include/oskit/freebsd/sys/disk.h
+include/oskit/freebsd/sys/disklabel.h
+include/oskit/freebsd/sys/diskslice.h
+include/oskit/freebsd/sys/dkbad.h
+include/oskit/freebsd/sys/dkstat.h
+include/oskit/freebsd/sys/dmap.h
+include/oskit/freebsd/sys/domain.h
+include/oskit/freebsd/sys/elf32.h
+include/oskit/freebsd/sys/elf_common.h
+include/oskit/freebsd/sys/elf_generic.h
+include/oskit/freebsd/sys/errno.h
+include/oskit/freebsd/sys/exec.h
+include/oskit/freebsd/sys/fbio.h
+include/oskit/freebsd/sys/fcntl.h
+include/oskit/freebsd/sys/file.h
+include/oskit/freebsd/sys/filedesc.h
+include/oskit/freebsd/sys/filio.h
+include/oskit/freebsd/sys/ftape.h
+include/oskit/freebsd/sys/gmon.h
+include/oskit/freebsd/sys/imgact.h
+include/oskit/freebsd/sys/imgact_aout.h
+include/oskit/freebsd/sys/inflate.h
+include/oskit/freebsd/sys/interrupt.h
+include/oskit/freebsd/sys/inttypes.h
+include/oskit/freebsd/sys/ioccom.h
+include/oskit/freebsd/sys/ioctl.h
+include/oskit/freebsd/sys/ioctl_compat.h
+include/oskit/freebsd/sys/ipc.h
+include/oskit/freebsd/sys/kernel.h
+include/oskit/freebsd/sys/ktrace.h
+include/oskit/freebsd/sys/libkern.h
+include/oskit/freebsd/sys/linker.h
+include/oskit/freebsd/sys/linker_set.h
+include/oskit/freebsd/sys/lkm.h
+include/oskit/freebsd/sys/lock.h
+include/oskit/freebsd/sys/lockf.h
+include/oskit/freebsd/sys/malloc.h
+include/oskit/freebsd/sys/mbuf.h
+include/oskit/freebsd/sys/md5.h
+include/oskit/freebsd/sys/mman.h
+include/oskit/freebsd/sys/module.h
+include/oskit/freebsd/sys/mount.h
+include/oskit/freebsd/sys/msg.h
+include/oskit/freebsd/sys/msgbuf.h
+include/oskit/freebsd/sys/mtio.h
+include/oskit/freebsd/sys/namei.h
+include/oskit/freebsd/sys/param.h
+include/oskit/freebsd/sys/poll.h
+include/oskit/freebsd/sys/proc.h
+include/oskit/freebsd/sys/protosw.h
+include/oskit/freebsd/sys/ptrace.h
+include/oskit/freebsd/sys/queue.h
+include/oskit/freebsd/sys/reboot.h
+include/oskit/freebsd/sys/resource.h
+include/oskit/freebsd/sys/resourcevar.h
+include/oskit/freebsd/sys/rlist.h
+include/oskit/freebsd/sys/rtprio.h
+include/oskit/freebsd/sys/scsiio.h
+include/oskit/freebsd/sys/select.h
+include/oskit/freebsd/sys/sem.h
+include/oskit/freebsd/sys/shm.h
+include/oskit/freebsd/sys/signal.h
+include/oskit/freebsd/sys/signalvar.h
+include/oskit/freebsd/sys/snoop.h
+include/oskit/freebsd/sys/socket.h
+include/oskit/freebsd/sys/socketvar.h
+include/oskit/freebsd/sys/sockio.h
+include/oskit/freebsd/sys/stat.h
+include/oskit/freebsd/sys/syscall-hide.h
+include/oskit/freebsd/sys/syscall.h
+include/oskit/freebsd/sys/sysctl.h
+include/oskit/freebsd/sys/sysent.h
+include/oskit/freebsd/sys/syslimits.h
+include/oskit/freebsd/sys/syslog.h
+include/oskit/freebsd/sys/sysproto.h
+include/oskit/freebsd/sys/systm.h
+include/oskit/freebsd/sys/tablet.h
+include/oskit/freebsd/sys/termios.h
+include/oskit/freebsd/sys/time.h
+include/oskit/freebsd/sys/timeb.h
+include/oskit/freebsd/sys/timepps.h
+include/oskit/freebsd/sys/times.h
+include/oskit/freebsd/sys/timex.h
+include/oskit/freebsd/sys/tprintf.h
+include/oskit/freebsd/sys/tty.h
+include/oskit/freebsd/sys/ttychars.h
+include/oskit/freebsd/sys/ttycom.h
+include/oskit/freebsd/sys/ttydefaults.h
+include/oskit/freebsd/sys/ttydev.h
+include/oskit/freebsd/sys/types.h
+include/oskit/freebsd/sys/ucred.h
+include/oskit/freebsd/sys/uio.h
+include/oskit/freebsd/sys/un.h
+include/oskit/freebsd/sys/unistd.h
+include/oskit/freebsd/sys/unpcb.h
+include/oskit/freebsd/sys/user.h
+include/oskit/freebsd/sys/utsname.h
+include/oskit/freebsd/sys/vadvise.h
+include/oskit/freebsd/sys/vcmd.h
+include/oskit/freebsd/sys/vlimit.h
+include/oskit/freebsd/sys/vmmeter.h
+include/oskit/freebsd/sys/vnioctl.h
+include/oskit/freebsd/sys/vnode.h
+include/oskit/freebsd/sys/wait.h
+include/oskit/freebsd/sys/wormio.h
+include/oskit/freebsd/sys/xrpuio.h
+include/oskit/freebsd/sysexits.h
+include/oskit/freebsd/syslog.h
+include/oskit/freebsd/tar.h
+include/oskit/freebsd/termios.h
+include/oskit/freebsd/time.h
+include/oskit/freebsd/timers.h
+include/oskit/freebsd/ttyent.h
+include/oskit/freebsd/unistd.h
+include/oskit/freebsd/utime.h
+include/oskit/freebsd/utmp.h
+include/oskit/freebsd/vis.h
+include/oskit/fs/dir.h
+include/oskit/fs/dir_secure.h
+include/oskit/fs/dirents.h
+include/oskit/fs/file.h
+include/oskit/fs/file_secure.h
+include/oskit/fs/filepsid.h
+include/oskit/fs/filesystem.h
+include/oskit/fs/filesystem_secure.h
+include/oskit/fs/fs.h
+include/oskit/fs/fsnamespace.h
+include/oskit/fs/linux.h
+include/oskit/fs/linux_filesystems.h
+include/oskit/fs/memfs.h
+include/oskit/fs/netbsd.h
+include/oskit/fs/openfile.h
+include/oskit/fs/read.h
+include/oskit/fs/soa.h
+include/oskit/fudp.h
+include/oskit/gdb.h
+include/oskit/gdb_serial.h
+include/oskit/hpfq.h
+include/oskit/io/absio.h
+include/oskit/io/asyncio.h
+include/oskit/io/blkio.h
+include/oskit/io/bufio.h
+include/oskit/io/bufio_stream.h
+include/oskit/io/bufiovec.h
+include/oskit/io/cacheio.h
+include/oskit/io/chario.h
+include/oskit/io/dpf.h
+include/oskit/io/iovec.h
+include/oskit/io/mouse.h
+include/oskit/io/netio.h
+include/oskit/io/netio_fanout.h
+include/oskit/io/posixio.h
+include/oskit/io/skbufio.h
+include/oskit/io/spf.h
+include/oskit/io/ttystream.h
+include/oskit/io/uspf.h
+include/oskit/lmm.h
+include/oskit/machine/anno.h
+include/oskit/machine/asm.h
+include/oskit/machine/atomic.h
+include/oskit/machine/base_cpu.h
+include/oskit/machine/base_gdt.h
+include/oskit/machine/base_idt.h
+include/oskit/machine/base_irq.h
+include/oskit/machine/base_multiboot.h
+include/oskit/machine/base_paging.h
+include/oskit/machine/base_stack.h
+include/oskit/machine/base_trap.h
+include/oskit/machine/base_tss.h
+include/oskit/machine/base_vm.h
+include/oskit/machine/byteorder.h
+include/oskit/machine/c/float.h
+include/oskit/machine/c/limits.h
+include/oskit/machine/c/setjmp.h
+include/oskit/machine/c/signal.h
+include/oskit/machine/c/stdarg.h
+include/oskit/machine/cpuid.h
+include/oskit/machine/debug.h
+include/oskit/machine/debug_reg.h
+include/oskit/machine/dev.h
+include/oskit/machine/dos/dpmi.h
+include/oskit/machine/dos/vcpi.h
+include/oskit/machine/eflags.h
+include/oskit/machine/endian.h
+include/oskit/machine/exec/elf.h
+include/oskit/machine/far_ptr.h
+include/oskit/machine/fp_reg.h
+include/oskit/machine/gate_init.h
+include/oskit/machine/gdb.h
+include/oskit/machine/i16.h
+include/oskit/machine/multiboot.h
+include/oskit/machine/page.h
+include/oskit/machine/paging.h
+include/oskit/machine/param.h
+include/oskit/machine/pc/a20.h
+include/oskit/machine/pc/base_console.h
+include/oskit/machine/pc/base_i16.h
+include/oskit/machine/pc/base_irq.h
+include/oskit/machine/pc/base_multiboot.h
+include/oskit/machine/pc/base_real.h
+include/oskit/machine/pc/bios32.h
+include/oskit/machine/pc/com_cons.h
+include/oskit/machine/pc/com_console.h
+include/oskit/machine/pc/debug.h
+include/oskit/machine/pc/dev.h
+include/oskit/machine/pc/direct_cons.h
+include/oskit/machine/pc/direct_console.h
+include/oskit/machine/pc/dos_io.h
+include/oskit/machine/pc/gdb_console.h
+include/oskit/machine/pc/i16_bios.h
+include/oskit/machine/pc/i16_dos.h
+include/oskit/machine/pc/intr_cons.h
+include/oskit/machine/pc/intr_console.h
+include/oskit/machine/pc/irq_list.h
+include/oskit/machine/pc/isa.h
+include/oskit/machine/pc/keyboard.h
+include/oskit/machine/pc/phys_lmm.h
+include/oskit/machine/pc/pic.h
+include/oskit/machine/pc/pit.h
+include/oskit/machine/pc/reset.h
+include/oskit/machine/pc/rtc.h
+include/oskit/machine/pc/serial_gdb.h
+include/oskit/machine/pc/speaker.h
+include/oskit/machine/perfmon.h
+include/oskit/machine/phys_lmm.h
+include/oskit/machine/physmem.h
+include/oskit/machine/pio.h
+include/oskit/machine/pmode.h
+include/oskit/machine/proc_reg.h
+include/oskit/machine/seg.h
+include/oskit/machine/smp.h
+include/oskit/machine/spin_lock.h
+include/oskit/machine/sproc.h
+include/oskit/machine/trap.h
+include/oskit/machine/tss.h
+include/oskit/machine/types.h
+include/oskit/machine/uvm.h
+include/oskit/memdebug.h
+include/oskit/mib.h
+include/oskit/mib/icmp.h
+include/oskit/mib/interfaces.h
+include/oskit/mib/ip.h
+include/oskit/mib/snmp.h
+include/oskit/mib/system.h
+include/oskit/mib/tcp.h
+include/oskit/mib/udp.h
+include/oskit/misc/sysconf.h
+include/oskit/net/arp.h
+include/oskit/net/bootp.h
+include/oskit/net/ether.h
+include/oskit/net/freebsd.h
+include/oskit/net/socket.h
+include/oskit/net/socket_secure.h
+include/oskit/page.h
+include/oskit/pd.h
+include/oskit/principal.h
+include/oskit/queue.h
+include/oskit/smp.h
+include/oskit/sproc.h
+include/oskit/startup.h
+include/oskit/svgalib/vga.h
+include/oskit/svm.h
+include/oskit/threads/cpuinherit.h
+include/oskit/threads/ipc.h
+include/oskit/threads/pthread.h
+include/oskit/threads/sched.h
+include/oskit/threads/sched_edf.h
+include/oskit/threads/sched_stride.h
+include/oskit/time.h
+include/oskit/tmcp.h
+include/oskit/tty.h
+include/oskit/types.h
+include/oskit/udplib.h
+include/oskit/unsupp/bus_walk.h
+include/oskit/unsupp/nullpointer.h
+include/oskit/uvm.h
+include/oskit/version.h
+include/oskit/video/fb.h
+include/oskit/video/s3.h
+include/oskit/x86/anno.h
+include/oskit/x86/asm.h
+include/oskit/x86/atomic.h
+include/oskit/x86/base_cpu.h
+include/oskit/x86/base_gdt.h
+include/oskit/x86/base_idt.h
+include/oskit/x86/base_irq.h
+include/oskit/x86/base_multiboot.h
+include/oskit/x86/base_paging.h
+include/oskit/x86/base_stack.h
+include/oskit/x86/base_trap.h
+include/oskit/x86/base_tss.h
+include/oskit/x86/base_vm.h
+include/oskit/x86/byteorder.h
+include/oskit/x86/c/float.h
+include/oskit/x86/c/limits.h
+include/oskit/x86/c/setjmp.h
+include/oskit/x86/c/signal.h
+include/oskit/x86/c/stdarg.h
+include/oskit/x86/cpuid.h
+include/oskit/x86/debug.h
+include/oskit/x86/debug_reg.h
+include/oskit/x86/dev.h
+include/oskit/x86/dos/dpmi.h
+include/oskit/x86/dos/vcpi.h
+include/oskit/x86/eflags.h
+include/oskit/x86/endian.h
+include/oskit/x86/exec/elf.h
+include/oskit/x86/far_ptr.h
+include/oskit/x86/fp_reg.h
+include/oskit/x86/gate_init.h
+include/oskit/x86/gdb.h
+include/oskit/x86/i16.h
+include/oskit/x86/multiboot.h
+include/oskit/x86/page.h
+include/oskit/x86/paging.h
+include/oskit/x86/param.h
+include/oskit/x86/pc/a20.h
+include/oskit/x86/pc/base_console.h
+include/oskit/x86/pc/base_i16.h
+include/oskit/x86/pc/base_irq.h
+include/oskit/x86/pc/base_multiboot.h
+include/oskit/x86/pc/base_real.h
+include/oskit/x86/pc/bios32.h
+include/oskit/x86/pc/com_cons.h
+include/oskit/x86/pc/com_console.h
+include/oskit/x86/pc/debug.h
+include/oskit/x86/pc/dev.h
+include/oskit/x86/pc/direct_cons.h
+include/oskit/x86/pc/direct_console.h
+include/oskit/x86/pc/dos_io.h
+include/oskit/x86/pc/gdb_console.h
+include/oskit/x86/pc/i16_bios.h
+include/oskit/x86/pc/i16_dos.h
+include/oskit/x86/pc/intr_cons.h
+include/oskit/x86/pc/intr_console.h
+include/oskit/x86/pc/irq_list.h
+include/oskit/x86/pc/isa.h
+include/oskit/x86/pc/keyboard.h
+include/oskit/x86/pc/phys_lmm.h
+include/oskit/x86/pc/pic.h
+include/oskit/x86/pc/pit.h
+include/oskit/x86/pc/reset.h
+include/oskit/x86/pc/rtc.h
+include/oskit/x86/pc/serial_gdb.h
+include/oskit/x86/pc/speaker.h
+include/oskit/x86/perfmon.h
+include/oskit/x86/phys_lmm.h
+include/oskit/x86/physmem.h
+include/oskit/x86/pio.h
+include/oskit/x86/pmode.h
+include/oskit/x86/proc_reg.h
+include/oskit/x86/seg.h
+include/oskit/x86/smp.h
+include/oskit/x86/spin_lock.h
+include/oskit/x86/sproc.h
+include/oskit/x86/trap.h
+include/oskit/x86/tss.h
+include/oskit/x86/types.h
+include/oskit/x86/uvm.h
+lib/boot/mbboot.o
+lib/boot/netboot.mb
+lib/boot/netboot.mb.debug
+lib/liboskit_amm.a
+lib/liboskit_bootp.a
+lib/liboskit_c.a
+lib/liboskit_clientos.a
+lib/liboskit_com.a
+lib/liboskit_dev.a
+lib/liboskit_diskpart.a
+lib/liboskit_exec.a
+lib/liboskit_freebsd_c.a
+lib/liboskit_freebsd_c_r.a
+lib/liboskit_freebsd_dev.a
+lib/liboskit_freebsd_m.a
+lib/liboskit_freebsd_net.a
+lib/liboskit_fsnamespace.a
+lib/liboskit_fsnamespace_r.a
+lib/liboskit_fsread.a
+lib/liboskit_fudp.a
+lib/liboskit_kern.a
+lib/liboskit_linux_dev.a
+lib/liboskit_linux_fs.a
+lib/liboskit_lmm.a
+lib/liboskit_memdebug.a
+lib/liboskit_memfs.a
+lib/liboskit_netbsd_fs.a
+lib/liboskit_netbsd_uvm.a
+lib/liboskit_posix.a
+lib/liboskit_posix_r.a
+lib/liboskit_realtime.a
+lib/liboskit_security.a
+lib/liboskit_sproc.a
+lib/liboskit_startup.a
+lib/liboskit_svm.a
+lib/liboskit_threads.a
+lib/liboskit_udp.a
+lib/liboskit_unsupp.a
+lib/oskit/crtn.o
+lib/oskit/dos.o
+lib/oskit/multiboot.o
+lib/oskit/multiboot_dyn.o
+lib/oskit/specs
+@dirrm lib/oskit
+@dirrm lib/boot
+@dirrm include/oskit/x86/pc
+@dirrm include/oskit/x86/exec
+@dirrm include/oskit/x86/dos
+@dirrm include/oskit/x86/c
+@dirrm include/oskit/x86
+@dirrm include/oskit/video
+@dirrm include/oskit/unsupp
+@dirrm include/oskit/threads
+@dirrm include/oskit/svgalib
+@dirrm include/oskit/net
+@dirrm include/oskit/misc
+@dirrm include/oskit/mib
+@dirrm include/oskit/machine/pc
+@dirrm include/oskit/machine/exec
+@dirrm include/oskit/machine/dos
+@dirrm include/oskit/machine/c
+@dirrm include/oskit/machine
+@dirrm include/oskit/io
+@dirrm include/oskit/fs
+@dirrm include/oskit/freebsd/sys
+@dirrm include/oskit/freebsd/rpcsvc
+@dirrm include/oskit/freebsd/rpc
+@dirrm include/oskit/freebsd/protocols
+@dirrm include/oskit/freebsd/netinet
+@dirrm include/oskit/freebsd/net
+@dirrm include/oskit/freebsd/i386
+@dirrm include/oskit/freebsd/arpa
+@dirrm include/oskit/freebsd/arm32
+@dirrm include/oskit/freebsd
+@dirrm include/oskit/flask
+@dirrm include/oskit/exec
+@dirrm include/oskit/diskpart
+@dirrm include/oskit/dev
+@dirrm include/oskit/com
+@dirrm include/oskit/c/sys
+@dirrm include/oskit/c/netinet
+@dirrm include/oskit/c/arpa
+@dirrm include/oskit/c
+@dirrm include/oskit/boot
+@dirrm include/oskit/arm32/shark
+@dirrm include/oskit/arm32/ofw
+@dirrm include/oskit/arm32/exec
+@dirrm include/oskit/arm32/c
+@dirrm include/oskit/arm32
+@dirrm include/oskit
+@dirrm include/flask
+@dirrm include/crt/x86
+@dirrm include/crt