aboutsummaryrefslogtreecommitdiff
path: root/devel/ossp-al/Makefile
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2005-10-03 14:28:25 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2005-10-03 14:28:25 +0000
commit3c27bbbdf1e33750e944bc8acb10dc6eaf18dfd3 (patch)
tree536df7e0a40f53ed8e03035d9b3d3dcecaac9fed /devel/ossp-al/Makefile
parentfd8337b738d295ff0b1eaeac76744999341fc0b8 (diff)
downloadports-3c27bbbdf1e33750e944bc8acb10dc6eaf18dfd3.tar.gz
ports-3c27bbbdf1e33750e944bc8acb10dc6eaf18dfd3.zip
Notes
Diffstat (limited to 'devel/ossp-al/Makefile')
-rw-r--r--devel/ossp-al/Makefile18
1 files changed, 10 insertions, 8 deletions
diff --git a/devel/ossp-al/Makefile b/devel/ossp-al/Makefile
index ed57e13de078..8097606bece6 100644
--- a/devel/ossp-al/Makefile
+++ b/devel/ossp-al/Makefile
@@ -1,33 +1,35 @@
-# ex:ts=8 -*-mode: makefile-*-
-#
# New ports collection makefile for: ossp-al
-# Date created: 2003-01-31
-# Whom: Alan Eldridge <alane@geeksrus.net>
+# Date created: 2003-01-31
+# Whom: Alan Eldridge <alane@geeksrus.net>
#
# $FreeBSD$
#
PORTNAME= al
-PORTVERSION= 0.9.1
-PORTREVISION= 2
-PORTEPOCH= 0
+PORTVERSION= 0.9.3
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_OSSP}
MASTER_SITE_SUBDIR= lib/${PORTNAME}
PKGNAMEPREFIX= ossp-
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= vd@datamax.bg
COMMENT= Defines an abstract type of buffer that can move data without copying
LIB_DEPENDS= ex.10:${PORTSDIR}/devel/ossp-ex
USE_GMAKE= yes
GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-ex=${LOCALBASE}
USE_LIBTOOL_VER=15
INSTALLS_SHLIB= yes
+check:
+ build
+ @(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check)
+
.include <bsd.port.pre.mk>
.include "${FILESDIR}/manpages.mk"
+
.include <bsd.port.post.mk>