aboutsummaryrefslogtreecommitdiff
path: root/devel/ossp-ex
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-03-24 22:47:20 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-03-24 22:47:20 +0000
commit60ea56ae4bbef79fe2006986420798560803c92d (patch)
tree1f084597b6c9855c23b3992fcb4736bc5e2dff40 /devel/ossp-ex
parent7309106d1e97bea87988fbe0a95e40d098b05e15 (diff)
downloadports-60ea56ae4bbef79fe2006986420798560803c92d.tar.gz
ports-60ea56ae4bbef79fe2006986420798560803c92d.zip
Notes
Diffstat (limited to 'devel/ossp-ex')
-rw-r--r--devel/ossp-ex/Makefile13
-rw-r--r--devel/ossp-ex/files/patch-ts.c11
2 files changed, 17 insertions, 7 deletions
diff --git a/devel/ossp-ex/Makefile b/devel/ossp-ex/Makefile
index 313d1cea3e49..85d037f348f1 100644
--- a/devel/ossp-ex/Makefile
+++ b/devel/ossp-ex/Makefile
@@ -9,24 +9,23 @@
PORTNAME= ex
PORTVERSION= 1.0.2
-PORTREVISION= 1
-PORTEPOCH= 0
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= ftp://ftp.ossp.org/pkg/lib/ex/
PKGNAMEPREFIX= ossp-
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= me@davidyu.org
COMMENT= OSSP ex is a small exception handling library for use in C
USE_GMAKE= yes
-GNU_CONFIGURE= yes
+GNU_CONFIGURE= yes
USE_LIBTOOL_VER= 13
-INSTALLS_SHLIB= yes
+INSTALLS_SHLIB= yes
.include <bsd.port.pre.mk>
-.if ${ARCH} == "alpha" || ${ARCH} == "amd64"
-BROKEN= "Does not compile on alpha or amd64"
+.if ${ARCH} == "alpha"
+BROKEN= "Does not compile on alpha"
.endif
.include "${FILESDIR}/manpages.mk"
diff --git a/devel/ossp-ex/files/patch-ts.c b/devel/ossp-ex/files/patch-ts.c
new file mode 100644
index 000000000000..6ef80977b360
--- /dev/null
+++ b/devel/ossp-ex/files/patch-ts.c
@@ -0,0 +1,11 @@
+--- ts.c.orig Wed Mar 24 17:36:35 2004
++++ ts.c Wed Mar 24 17:36:49 2004
+@@ -202,7 +202,7 @@
+
+ if (format == NULL || ap == NULL)
+ return NULL;
+- ap2 = ap;
++ va_copy(ap2, ap);
+ if ((n = ts_suite_mvxprintf(NULL, 0, format, ap)) == -1)
+ return NULL;
+ if ((buffer = (char *)malloc(n+1)) == NULL)