aboutsummaryrefslogtreecommitdiff
path: root/devel/ossp-ex
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-03-25 07:54:08 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-03-25 07:54:08 +0000
commit19015e7c2fe2243760770c3fd6b493697f4075a2 (patch)
treef4da730f801e112d5be2330ed26cc5a8593af6e3 /devel/ossp-ex
parent139e9aba2728c9aa9eb5bd9ef53630f0c0c3ddeb (diff)
downloadports-19015e7c2fe2243760770c3fd6b493697f4075a2.tar.gz
ports-19015e7c2fe2243760770c3fd6b493697f4075a2.zip
Notes
Diffstat (limited to 'devel/ossp-ex')
-rw-r--r--devel/ossp-ex/Makefile6
-rw-r--r--devel/ossp-ex/files/extra-patch-ts.c (renamed from devel/ossp-ex/files/patch-ts.c)0
-rw-r--r--devel/ossp-ex/files/patch-ex.h14
3 files changed, 19 insertions, 1 deletions
diff --git a/devel/ossp-ex/Makefile b/devel/ossp-ex/Makefile
index 85d037f348f1..751d188e3330 100644
--- a/devel/ossp-ex/Makefile
+++ b/devel/ossp-ex/Makefile
@@ -9,7 +9,7 @@
PORTNAME= ex
PORTVERSION= 1.0.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel
MASTER_SITES= ftp://ftp.ossp.org/pkg/lib/ex/
PKGNAMEPREFIX= ossp-
@@ -28,5 +28,9 @@ INSTALLS_SHLIB= yes
BROKEN= "Does not compile on alpha"
.endif
+.if ${OSVERSION} >= 500000
+EXTRA_PATCHES= ${PATCHDIR}/extra-patch-ts.c
+.endif
+
.include "${FILESDIR}/manpages.mk"
.include <bsd.port.post.mk>
diff --git a/devel/ossp-ex/files/patch-ts.c b/devel/ossp-ex/files/extra-patch-ts.c
index 6ef80977b360..6ef80977b360 100644
--- a/devel/ossp-ex/files/patch-ts.c
+++ b/devel/ossp-ex/files/extra-patch-ts.c
diff --git a/devel/ossp-ex/files/patch-ex.h b/devel/ossp-ex/files/patch-ex.h
new file mode 100644
index 000000000000..e0c6bf2fc7b9
--- /dev/null
+++ b/devel/ossp-ex/files/patch-ex.h
@@ -0,0 +1,14 @@
+--- ex.h.orig Wed Mar 24 18:13:57 2004
++++ ex.h Wed Mar 24 18:14:09 2004
+@@ -86,9 +86,9 @@
+ void *ex_object;
+ void *ex_value;
+ /* throw point */
+- char *ex_file;
++ const char *ex_file;
+ int ex_line;
+- char *ex_func;
++ const char *ex_func;
+ } ex_t;
+
+ /* declare the context type (private) */