aboutsummaryrefslogtreecommitdiff
path: root/devel/ossp-xds
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-02-28 11:38:36 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-02-28 11:38:36 +0000
commit85d1ba55173188e2114001149780f404098f6593 (patch)
treec219f29a461fe5fe2033f6f78be3f460c37ce9db /devel/ossp-xds
parent50d9d8d17e02d4e5c0cf41bf4d2e9029ba8f32ed (diff)
downloadports-85d1ba55173188e2114001149780f404098f6593.tar.gz
ports-85d1ba55173188e2114001149780f404098f6593.zip
Notes
Diffstat (limited to 'devel/ossp-xds')
-rw-r--r--devel/ossp-xds/Makefile26
-rw-r--r--devel/ossp-xds/distinfo2
-rw-r--r--devel/ossp-xds/pkg-descr10
-rw-r--r--devel/ossp-xds/pkg-plist6
4 files changed, 44 insertions, 0 deletions
diff --git a/devel/ossp-xds/Makefile b/devel/ossp-xds/Makefile
new file mode 100644
index 000000000000..a1b63fa3b33b
--- /dev/null
+++ b/devel/ossp-xds/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: OSSP xds
+# Date created: 22 February 2004
+# Whom: Kimura Fuyuki <fuyuki@nigredo.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xds
+PORTVERSION= 0.9.0
+CATEGORIES= devel
+MASTER_SITES= ftp://ftp.ossp.org/pkg/lib/${PORTNAME}/
+PKGNAMEPREFIX= ossp-
+
+MAINTAINER= fuyuki@nigredo.org
+COMMENT= A generic and extensible framework for serialization
+
+USE_LIBTOOL_VER= 15
+INSTALLS_SHLIB= yes
+
+MAN1= xds-config.1
+MAN3= xds.3
+
+test:
+ cd ${WRKSRC}; make check
+
+.include <bsd.port.mk>
diff --git a/devel/ossp-xds/distinfo b/devel/ossp-xds/distinfo
new file mode 100644
index 000000000000..d820273baf92
--- /dev/null
+++ b/devel/ossp-xds/distinfo
@@ -0,0 +1,2 @@
+MD5 (xds-0.9.0.tar.gz) = adc4f2173d05447b03f8d790eee2eb66
+SIZE (xds-0.9.0.tar.gz) = 240772
diff --git a/devel/ossp-xds/pkg-descr b/devel/ossp-xds/pkg-descr
new file mode 100644
index 000000000000..c2e5bb7c992b
--- /dev/null
+++ b/devel/ossp-xds/pkg-descr
@@ -0,0 +1,10 @@
+The OSSP xds library is generic and extensible encoding and decoding
+framework for the serialization of arbitrary ISO C data types. OSSP
+xds consists of three components: the generic encoding and decoding
+framework, a set of shipped engines to encode and decode values in
+certain existing formats (Sun RPC/XDR and XDS/XML are currently
+provided), and a run-time context, which is used to manage buffers,
+registered engines, etc. The library is designed to allow fully
+recursive and efficient encoding/decoding of arbitrary nested data.
+
+WWW: http://www.ossp.org/pkg/lib/xds/
diff --git a/devel/ossp-xds/pkg-plist b/devel/ossp-xds/pkg-plist
new file mode 100644
index 000000000000..ea6752de31fd
--- /dev/null
+++ b/devel/ossp-xds/pkg-plist
@@ -0,0 +1,6 @@
+bin/xds-config
+include/xds.h
+lib/libxds.a
+lib/libxds.la
+lib/libxds.so
+lib/libxds.so.9