aboutsummaryrefslogtreecommitdiff
path: root/devel/otrs
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2011-02-26 16:44:32 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2011-02-26 16:44:32 +0000
commitee1d1e47840b009f961a6b011de167af93351754 (patch)
treef950df16ec66fba844a03f10c8cd22d1874a0534 /devel/otrs
parent89411aa472d411f55d1ea3b2b0a2ac2ad9361e05 (diff)
downloadports-ee1d1e47840b009f961a6b011de167af93351754.tar.gz
ports-ee1d1e47840b009f961a6b011de167af93351754.zip
Notes
Diffstat (limited to 'devel/otrs')
-rw-r--r--devel/otrs/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/devel/otrs/Makefile b/devel/otrs/Makefile
index 59486c711fab..fe533fef4f9a 100644
--- a/devel/otrs/Makefile
+++ b/devel/otrs/Makefile
@@ -7,6 +7,7 @@
PORTNAME= otrs
PORTVERSION= 3.0.5
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://ftp.otrs.org/pub/otrs/ \
ftp://ftp.samurai.com/pub/otrs/ \
@@ -41,6 +42,7 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
OPTIONS= MYSQL "MySQL database support" on \
PGSQL "PostgreSQL database support" off \
+ MODPERL2 "ModPerl2 support" on \
REPORTS_MODULES "Reports support" on \
SMTP "Send email via SMTP" on \
POP3 "Fetch email via POP3" on \
@@ -73,7 +75,6 @@ CLEAN_FILES= scripts/suse* scripts/redhat* \
var/httpd/htdocs/js/thirdparty/ckeditor-3.4.2/_source \
var/httpd/htdocs/skins/Agent/*/img/source
-USE_APACHE= 1.3+
USE_PERL5= yes
.include <bsd.port.pre.mk>
@@ -88,6 +89,13 @@ RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-P
USE_PGSQL= yes
.endif
+.ifdef WITH_MODPERL2
+USE_APACHE= 2.2+
+RUN_DEPENDS+= mod_perl>=2.0:${PORTSDIR}/www/mod_perl2
+.else
+USE_APACHE= 1.3+
+.endif
+
.ifdef WITH_REPORTS_MODULES
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/GD.pm:${PORTSDIR}/graphics/p5-GD \
${SITE_PERL}/GD/Graph.pm:${PORTSDIR}/graphics/p5-GD-Graph \