aboutsummaryrefslogtreecommitdiff
path: root/devel/otrs
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2011-07-10 17:40:59 +0000
committerChris Rees <crees@FreeBSD.org>2011-07-10 17:40:59 +0000
commitacd4a94f863fdb61a59cbac2ffefd9570c8cbf4f (patch)
treee5b19cfc7001025fe4efa8e12181f4730a07d81d /devel/otrs
parent6d7c5bdddb8b7c4f7f98b59001c4ab77f45b92c4 (diff)
downloadports-acd4a94f863fdb61a59cbac2ffefd9570c8cbf4f.tar.gz
ports-acd4a94f863fdb61a59cbac2ffefd9570c8cbf4f.zip
Notes
Diffstat (limited to 'devel/otrs')
-rw-r--r--devel/otrs/Makefile3
-rw-r--r--devel/otrs/files/pkg-install.in25
2 files changed, 2 insertions, 26 deletions
diff --git a/devel/otrs/Makefile b/devel/otrs/Makefile
index 04aa377f3490..98d3488dbd62 100644
--- a/devel/otrs/Makefile
+++ b/devel/otrs/Makefile
@@ -53,6 +53,8 @@ OPTIONS= MYSQL "MySQL database support" on \
USE_BZIP2= yes
OTRSDIR= ${PREFIX}/otrs
+USERS= ${PORTNAME}
+GROUPS= ${USERS}
SUB_FILES= pkg-install pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
@@ -165,7 +167,6 @@ do-build:
.endif
do-install:
- @PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
@${MKDIR} ${ROOT_DIRS_LIST:S!^!${OTRSDIR}/!} ${BIN_DIRS_LIST:S!^!${OTRSDIR}/bin/!} \
${SCRIPTS_DIRS_LIST:S!^!${OTRSDIR}/scripts/!}
@${INSTALL_DATA} ${WRKSRC}/.*.dist ${OTRSDIR}/
diff --git a/devel/otrs/files/pkg-install.in b/devel/otrs/files/pkg-install.in
index efdf6090d8bc..296381b4fb62 100644
--- a/devel/otrs/files/pkg-install.in
+++ b/devel/otrs/files/pkg-install.in
@@ -7,33 +7,8 @@ WWWOWN="www"
WWWGRP="www"
OTRS_USER="otrs"
OTRS_GROUP="otrs"
-OTRS_UID=121
-OTRS_GID=121
case $2 in
-PRE-INSTALL)
-
- if ! pw groupshow -n ${OTRS_GROUP} >/dev/null 2>&1; then
- if pw groupadd -n ${OTRS_GROUP} -g ${OTRS_GID}; then
- echo "Added group \"${OTRS_GROUP}\"."
- else
- echo "Adding group \"${OTRS_GROUP}\" failed..."
- exit 1
- fi
- fi
-
- if ! id -u ${OTRS_USER} >/dev/null 2>&1; then
- if pw useradd -n ${OTRS_USER} -g ${OTRS_GROUP} \
- -u ${OTRS_UID} -G ${WWWGRP} -h - -s /bin/csh \
- -d ${PKG_PREFIX}/otrs -c "OTRS Administrator" ; then
- echo "Added user \"${OTRS_USER}\"."
- else
- echo "Adding user \"${OTRS_USER}\" failed..."
- exit 1
- fi
- fi
-;;
-
POST-INSTALL)
${PKG_PREFIX}/otrs/bin/otrs.SetPermissions.pl \
--web-user=${WWWOWN} --web-group=${WWWGRP} \