aboutsummaryrefslogtreecommitdiff
path: root/devel/p4p/Makefile
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-06-10 06:22:55 +0000
committerWill Andrews <will@FreeBSD.org>2000-06-10 06:22:55 +0000
commitba9f68c58c1f6ca5a861f032277c07bc4e4845b7 (patch)
tree86a89290021e327b66ebf0b878720ee19c6ebc4c /devel/p4p/Makefile
parenta01d4b6f71708d9f894a7cb174cfd864e51bebf2 (diff)
downloadports-ba9f68c58c1f6ca5a861f032277c07bc4e4845b7.tar.gz
ports-ba9f68c58c1f6ca5a861f032277c07bc4e4845b7.zip
Notes
Diffstat (limited to 'devel/p4p/Makefile')
-rw-r--r--devel/p4p/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/devel/p4p/Makefile b/devel/p4p/Makefile
new file mode 100644
index 000000000000..3580b0038af8
--- /dev/null
+++ b/devel/p4p/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: perforce
+# Date created: 3 Mai 2000
+# Whom: sam@inf.enst.fr
+#
+# $FreeBSD$
+#
+
+PORTNAME= perforce
+PORTVERSION= 99.2
+CATEGORIES= devel
+MASTER_SITES= ftp://ftp.perforce.com/pub/perforce/r${PORTVERSION}/bin.freebsd/ \
+ http://www.dsmit.com/p4/ \
+ ftp://ftp.perforce.com/pub/perforce/r${PORTVERSION}/doc/man/
+EXTRACT_SUFX=
+DISTFILES= p4 p4d p4.1 p4d.1
+DIST_SUBDIR= perforce
+
+MAINTAINER= sam@inf.enst.fr
+
+NO_PACKAGE= Restricted distribution
+NO_CDROM= Restricted distribution
+NO_BUILD= yes
+MAN1= p4.1 p4d.1
+
+do-extract:
+ @${MKDIR} ${WRKSRC}
+
+do-install:
+ ${INSTALL_PROGRAM} ${DISTDIR}/${DIST_SUBDIR}/p4 ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${DISTDIR}/${DIST_SUBDIR}/p4d ${PREFIX}/sbin
+.for PERFMAN in p4 p4d
+ ${INSTALL_MAN} ${DISTDIR}/${DIST_SUBDIR}/${PERFMAN}.1 ${PREFIX}/man/man1
+.endfor
+
+.include <bsd.port.mk>