aboutsummaryrefslogtreecommitdiff
path: root/devel/p4v
diff options
context:
space:
mode:
authorBruce M Simpson <bms@FreeBSD.org>2007-07-17 21:08:38 +0000
committerBruce M Simpson <bms@FreeBSD.org>2007-07-17 21:08:38 +0000
commita543bd7ef1c913f17d6ededa177c67ba4598c118 (patch)
tree45f4cc4612dbb5fc894c6bcce6a2473e8ccbb48f /devel/p4v
parent2cd8ba91905e164a53ef54850d231c0819bf450a (diff)
downloadports-a543bd7ef1c913f17d6ededa177c67ba4598c118.tar.gz
ports-a543bd7ef1c913f17d6ededa177c67ba4598c118.zip
Notes
Diffstat (limited to 'devel/p4v')
-rw-r--r--devel/p4v/Makefile72
-rw-r--r--devel/p4v/distinfo.i3866
-rw-r--r--devel/p4v/pkg-message2
-rw-r--r--devel/p4v/pkg-plist.i38681
4 files changed, 64 insertions, 97 deletions
diff --git a/devel/p4v/Makefile b/devel/p4v/Makefile
index 5be1532efa7e..656f39194bc0 100644
--- a/devel/p4v/Makefile
+++ b/devel/p4v/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= p4v
-PORTVERSION= 2007.1.116736
+PORTVERSION= 2007.2.128166
CATEGORIES= devel
-MASTER_SITES= ftp://ftp.perforce.com/pub/perforce/r07.1/bin.freebsd54x86/
+MASTER_SITES= http://filehost.perforce.com/perforce/r07.2/bin.freebsd60x86/
DISTNAME= ${PORTNAME}
EXTRACT_SUFX= .tgz
DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
@@ -23,18 +23,24 @@ ONLY_FOR_ARCHS= i386
NO_BUILD= yes
NO_WRKSUBDIR= yes
-PLIST= ${MASTERDIR}/pkg-plist.${MACHINE_ARCH}
MD5_FILE= ${MASTERDIR}/distinfo.${MACHINE_ARCH}
P4V_ICONS_DIR= P4VResources/icons
P4V_ICONS= p4v_16_low.png p4v_32_high.png p4v_32_low.png p4v_48_high.png
P4V_DOCS_DIR= P4VResources/p4vhelp
-P4V_DOCS= About_Perforce_products.html \
+P4V_DOCS= \
+ About_Perforce_products.html \
About_file_icons.html \
Adding_files_to_the_depot.html \
+ Admin_creating_groups.html \
+ Admin_creating_users.html \
+ Admin_homepage.html \
+ Admin_managing_permissions.html \
+ Admin_managing_users_and_groups.html \
Changing_a_file_s_type.html \
Configuring_display_preferences.html \
+ Configuring_unicode.html \
Connecting_to_the_Perforce_server.html \
Defining_a_client_view.html \
Deleting_files.html \
@@ -44,10 +50,12 @@ P4V_DOCS= About_Perforce_products.html \
Getting_more_information.html \
Getting_started_with_Perforce.html \
Integrating_files_into_codelines.html \
+ Managing_bookmarks.html \
Managing_branch_specifications.html \
Managing_jobs.html \
Managing_labels.html \
Managing_users.html \
+ Offline.html \
P4V_shortcuts.html \
Renaming_files.html \
Resolving_files.html \
@@ -57,16 +65,25 @@ P4V_DOCS= About_Perforce_products.html \
ancillary_p4v_files.html \
custom_tools.html \
diffing_folders.html \
+ folder_diff_cheatsheet.html \
p4v-gs.pdf \
p4vindex.html \
revision_graph.html \
time_lapse.html
P4V_IMGS_DIR= P4VResources/p4vhelp/p4images
-P4V_IMGS= p4v_bookmark.png p4v_file_add.png p4v_file_add_other.png \
+P4V_IMGS= \
+ commandkey.jpg \
+ p4v_admin_table_icon.png \
+ p4v_bookmark.png \
+ p4v_connection_dialog.png \
+ p4v_file_add.png p4v_file_add_other.png \
+ p4v_file_add_other_ws.png \
p4v_file_delete.png p4v_file_delete_notsync.png \
p4v_file_delete_other.png p4v_file_delete_resolve.png \
- p4v_file_deleted.png p4v_file_edit_head.png \
+ p4v_file_deleted.png \
+ p4v_file_differs.png \
+ p4v_file_edit_head.png \
p4v_file_edit_notsync.png p4v_file_edit_other.png \
p4v_file_edit_other_notsyn.png p4v_file_edit_other_notsync.png \
p4v_file_edit_resolve.png \
@@ -79,18 +96,49 @@ P4V_IMGS= p4v_bookmark.png p4v_file_add.png p4v_file_add_other.png \
p4v_file_rev_have_branch.png p4v_file_rev_have_edit.png \
p4v_file_revision_integrated.png p4v_file_revsynced.png \
p4v_file_sync.png p4v_file_txt.png p4v_file_ws.png \
- p4v_filter.png p4v_filters.png p4v_folder_diff_screenshot.png \
- p4v_pin.png p4v_revision_graph_screenshot.png p4v_sort.png \
+ p4v_filter.png \
+ p4v_filter_button.png \
+ p4v_filter_content.png \
+ p4v_filter_identical.png \
+ p4v_filter_list.png \
+ p4v_filter_unique.png \
+ p4v_filters.png p4v_folder_diff_screenshot.png \
+ p4v_folderdiff.png \
+ p4v_integration_dialog.png \
+ p4v_main_window.png \
+ p4v_offline.png \
+ p4v_offline_deleted.png \
+ p4v_pin.png \
+ p4v_revgraph_bracket.png \
+ p4v_revgraph_branch.png \
+ p4v_revgraph_diff.png \
+ p4v_revgraph_highlighter.png \
+ p4v_revgraph_options.png \
+ p4v_revision_graph_screenshot.png p4v_sort.png \
p4v_tearoff.png p4v_time_lapse_screenshot.png p4v_views.png
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-IGNORE= please upgrade to FreeBSD 5.x or newer
+.if ${OSVERSION} < 600000
+IGNORE= please upgrade to FreeBSD 6.x or newer
.endif
-.if ${OSVERSION} >= 500000
-LIB_DEPENDS+= c_r.5:${PORTSDIR}/misc/compat5x
+
+PLIST_FILES= bin/p4v
+
+.if !defined(NOPORTDOCS)
+.for _IMGFILE in ${P4V_IMGS}
+PLIST_FILES+= share/${P4V_IMGS_DIR}/${_IMGFILE}
+.endfor
+PLIST_DIRS+= share/${P4V_IMGS_DIR}
+.for _DOCFILE in ${P4V_DOCS}
+PLIST_FILES+= share/${P4V_DOCS_DIR}/${_DOCFILE}
+.endfor
+PLIST_DIRS+= share/${P4V_DOCS_DIR}
.endif
+.for _ICONFILE in ${P4V_ICONS}
+PLIST_FILES+= share/${P4V_ICONS_DIR}/${_ICONFILE}
+.endfor
+PLIST_DIRS+= share/${P4V_ICONS_DIR} share/P4VResources
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/p4v ${PREFIX}/bin
diff --git a/devel/p4v/distinfo.i386 b/devel/p4v/distinfo.i386
index 0d7f72e49752..61697be81fe3 100644
--- a/devel/p4v/distinfo.i386
+++ b/devel/p4v/distinfo.i386
@@ -1,3 +1,3 @@
-MD5 (p4v-2007.1.116736/p4v.tgz) = 97b381f7fe54ea9fe529a30e51847cf1
-SHA256 (p4v-2007.1.116736/p4v.tgz) = 7492e4df0f9acf864f0068f0f31b5eeb6b64228ddfab69ef0979aafefc0f7cca
-SIZE (p4v-2007.1.116736/p4v.tgz) = 8281525
+MD5 (p4v-2007.2.128166/p4v.tgz) = 1c3caec51057afae3cd8bb659ff93bd0
+SHA256 (p4v-2007.2.128166/p4v.tgz) = 4888df0656fa5c18fe0dd9d6c1e165c1d8322997ee6afbb1a377121ad0f50284
+SIZE (p4v-2007.2.128166/p4v.tgz) = 8338152
diff --git a/devel/p4v/pkg-message b/devel/p4v/pkg-message
index efd34fb72020..0996597f260b 100644
--- a/devel/p4v/pkg-message
+++ b/devel/p4v/pkg-message
@@ -4,6 +4,6 @@ location of the p4v resources directory. For example:
% setenv P4VRES %%PREFIX%%/share/P4VResources
-The application is compiled for FreeBSD 5.4, so be sure to have appropriate
+The application is compiled for FreeBSD 6.0, so be sure to have appropriate
compatibility libraries (and kernel support, if applicable) installed on
your system.
diff --git a/devel/p4v/pkg-plist.i386 b/devel/p4v/pkg-plist.i386
deleted file mode 100644
index 0be05d0935d4..000000000000
--- a/devel/p4v/pkg-plist.i386
+++ /dev/null
@@ -1,81 +0,0 @@
-bin/p4v
-share/P4VResources/icons/p4v_16_low.png
-share/P4VResources/icons/p4v_32_high.png
-share/P4VResources/icons/p4v_32_low.png
-share/P4VResources/icons/p4v_48_high.png
-%%PORTDOCS%%share/P4VResources/p4vhelp/About_Perforce_products.html
-%%PORTDOCS%%share/P4VResources/p4vhelp/About_file_icons.html
-%%PORTDOCS%%share/P4VResources/p4vhelp/Adding_files_to_the_depot.html
-%%PORTDOCS%%share/P4VResources/p4vhelp/Changing_a_file_s_type.html
-%%PORTDOCS%%share/P4VResources/p4vhelp/Configuring_display_preferences.html
-%%PORTDOCS%%share/P4VResources/p4vhelp/Connecting_to_the_Perforce_server.html
-%%PORTDOCS%%share/P4VResources/p4vhelp/Defining_a_client_view.html
-%%PORTDOCS%%share/P4VResources/p4vhelp/Deleting_files.html
-%%PORTDOCS%%share/P4VResources/p4vhelp/Displaying_a_file_s_revision_history.html
-%%PORTDOCS%%share/P4VResources/p4vhelp/Displaying_client_specifications.html
-%%PORTDOCS%%share/P4VResources/p4vhelp/Editing_files.html
-%%PORTDOCS%%share/P4VResources/p4vhelp/Getting_more_information.html
-%%PORTDOCS%%share/P4VResources/p4vhelp/Getting_started_with_Perforce.html
-%%PORTDOCS%%share/P4VResources/p4vhelp/Integrating_files_into_codelines.html
-%%PORTDOCS%%share/P4VResources/p4vhelp/Managing_branch_specifications.html
-%%PORTDOCS%%share/P4VResources/p4vhelp/Managing_jobs.html
-%%PORTDOCS%%share/P4VResources/p4vhelp/Managing_labels.html
-%%PORTDOCS%%share/P4VResources/p4vhelp/Managing_users.html
-%%PORTDOCS%%share/P4VResources/p4vhelp/P4V_shortcuts.html
-%%PORTDOCS%%share/P4VResources/p4vhelp/Renaming_files.html
-%%PORTDOCS%%share/P4VResources/p4vhelp/Resolving_files.html
-%%PORTDOCS%%share/P4VResources/p4vhelp/Retrieving_files_from_the_depot.html
-%%PORTDOCS%%share/P4VResources/p4vhelp/The_P4V_windows.html
-%%PORTDOCS%%share/P4VResources/p4vhelp/Working_with_changelists.html
-%%PORTDOCS%%share/P4VResources/p4vhelp/ancillary_p4v_files.html
-%%PORTDOCS%%share/P4VResources/p4vhelp/custom_tools.html
-%%PORTDOCS%%share/P4VResources/p4vhelp/diffing_folders.html
-%%PORTDOCS%%share/P4VResources/p4vhelp/p4v-gs.pdf
-%%PORTDOCS%%share/P4VResources/p4vhelp/p4vindex.html
-%%PORTDOCS%%share/P4VResources/p4vhelp/revision_graph.html
-%%PORTDOCS%%share/P4VResources/p4vhelp/time_lapse.html
-%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_bookmark.png
-%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_add.png
-%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_add_other.png
-%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_delete.png
-%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_delete_notsync.png
-%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_delete_other.png
-%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_delete_resolve.png
-%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_deleted.png
-%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_edit_head.png
-%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_edit_notsync.png
-%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_edit_other.png
-%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_edit_other_notsyn.png
-%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_edit_other_notsync.png
-%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_edit_resolve.png
-%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_edit_resolve_other_delete.png
-%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_lock.png
-%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_lock_other.png
-%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_needs_resolve.png
-%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_notmapped.png
-%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_notsync.png
-%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_rev_add.png
-%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_rev_branch.png
-%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_rev_delete.png
-%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_rev_edit.png
-%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_rev_have_add.png
-%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_rev_have_branch.png
-%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_rev_have_edit.png
-%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_revision_integrated.png
-%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_revsynced.png
-%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_sync.png
-%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_txt.png
-%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_file_ws.png
-%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_filter.png
-%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_filters.png
-%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_folder_diff_screenshot.png
-%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_pin.png
-%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_revision_graph_screenshot.png
-%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_sort.png
-%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_tearoff.png
-%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_time_lapse_screenshot.png
-%%PORTDOCS%%share/P4VResources/p4vhelp/p4images/p4v_views.png
-%%PORTDOCS%%@dirrm share/P4VResources/p4vhelp/p4images
-%%PORTDOCS%%@dirrm share/P4VResources/p4vhelp
-@dirrm share/P4VResources/icons
-@dirrm share/P4VResources