aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-AI-Pathfinding-AStar/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2004-08-27 09:32:45 +0000
committerMathieu Arnold <mat@FreeBSD.org>2004-08-27 09:32:45 +0000
commit705fc971df2baa4dd9a5440eed0ece2ca1f08d11 (patch)
tree2fc7cb8f9738af1d5d261f1ef2cc6fb482372f42 /devel/p5-AI-Pathfinding-AStar/Makefile
parenteb7041b464a03a555265a0e38b2a1cf58ead259a (diff)
downloadports-705fc971df2baa4dd9a5440eed0ece2ca1f08d11.tar.gz
ports-705fc971df2baa4dd9a5440eed0ece2ca1f08d11.zip
Notes
Diffstat (limited to 'devel/p5-AI-Pathfinding-AStar/Makefile')
-rw-r--r--devel/p5-AI-Pathfinding-AStar/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/devel/p5-AI-Pathfinding-AStar/Makefile b/devel/p5-AI-Pathfinding-AStar/Makefile
new file mode 100644
index 000000000000..6de7ddec0b89
--- /dev/null
+++ b/devel/p5-AI-Pathfinding-AStar/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: AI::Pathfinding::AStar
+# Date created: 26 August 2004
+# Whom: Aaron Dalton <aaron@daltons.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= AI-Pathfinding-AStar
+PORTVERSION= 0.02
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= AI
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@daltons.ca
+COMMENT= Perl implementation of the A* pathfinding algorithm
+
+BUILD_DEPENDS= ${SITE_PERL}/Heap/Simple.pm:${PORTSDIR}/devel/p5-Heap-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= AI::Pathfinding::AStar.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= Uses devel/p5-Heap-Simple, which requires perl5.6, install lang/perl5 or lang/perl5.8
+.endif
+
+.include <bsd.port.post.mk>