aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-AI-Pathfinding-AStar
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2004-08-27 09:32:45 +0000
committerMathieu Arnold <mat@FreeBSD.org>2004-08-27 09:32:45 +0000
commit705fc971df2baa4dd9a5440eed0ece2ca1f08d11 (patch)
tree2fc7cb8f9738af1d5d261f1ef2cc6fb482372f42 /devel/p5-AI-Pathfinding-AStar
parenteb7041b464a03a555265a0e38b2a1cf58ead259a (diff)
downloadports-705fc971df2baa4dd9a5440eed0ece2ca1f08d11.tar.gz
ports-705fc971df2baa4dd9a5440eed0ece2ca1f08d11.zip
Notes
Diffstat (limited to 'devel/p5-AI-Pathfinding-AStar')
-rw-r--r--devel/p5-AI-Pathfinding-AStar/Makefile31
-rw-r--r--devel/p5-AI-Pathfinding-AStar/distinfo2
-rw-r--r--devel/p5-AI-Pathfinding-AStar/pkg-descr10
-rw-r--r--devel/p5-AI-Pathfinding-AStar/pkg-plist7
4 files changed, 50 insertions, 0 deletions
diff --git a/devel/p5-AI-Pathfinding-AStar/Makefile b/devel/p5-AI-Pathfinding-AStar/Makefile
new file mode 100644
index 000000000000..6de7ddec0b89
--- /dev/null
+++ b/devel/p5-AI-Pathfinding-AStar/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: AI::Pathfinding::AStar
+# Date created: 26 August 2004
+# Whom: Aaron Dalton <aaron@daltons.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= AI-Pathfinding-AStar
+PORTVERSION= 0.02
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= AI
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@daltons.ca
+COMMENT= Perl implementation of the A* pathfinding algorithm
+
+BUILD_DEPENDS= ${SITE_PERL}/Heap/Simple.pm:${PORTSDIR}/devel/p5-Heap-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= AI::Pathfinding::AStar.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= Uses devel/p5-Heap-Simple, which requires perl5.6, install lang/perl5 or lang/perl5.8
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-AI-Pathfinding-AStar/distinfo b/devel/p5-AI-Pathfinding-AStar/distinfo
new file mode 100644
index 000000000000..0bf9901d7bf4
--- /dev/null
+++ b/devel/p5-AI-Pathfinding-AStar/distinfo
@@ -0,0 +1,2 @@
+MD5 (AI-Pathfinding-AStar-0.02.tar.gz) = 679867a36718f5c9a6bb7bd2d6a28994
+SIZE (AI-Pathfinding-AStar-0.02.tar.gz) = 4697
diff --git a/devel/p5-AI-Pathfinding-AStar/pkg-descr b/devel/p5-AI-Pathfinding-AStar/pkg-descr
new file mode 100644
index 000000000000..1d651280f34a
--- /dev/null
+++ b/devel/p5-AI-Pathfinding-AStar/pkg-descr
@@ -0,0 +1,10 @@
+This module implements the A* pathfinding algorithm. It acts as a base class
+from which a custom map object can be derived. It requires from the map object
+a subroutine named "getSurrounding" and provides to the object a routine called
+"findPath" which calculates the shortest (ie. least-expensive) path between two
+nodes.
+
+WWW: http://search.cpan.org/dist/AI-Pathfinding-AStar/
+
+- Aaron Dalton
+aaron@daltons.ca
diff --git a/devel/p5-AI-Pathfinding-AStar/pkg-plist b/devel/p5-AI-Pathfinding-AStar/pkg-plist
new file mode 100644
index 000000000000..6691273a0070
--- /dev/null
+++ b/devel/p5-AI-Pathfinding-AStar/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/AI/Pathfinding/AStar.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/AI/Pathfinding/AStar/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/AI/Pathfinding/AStar
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/AI/Pathfinding 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/AI 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/AI/Pathfinding 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/AI 2>/dev/null || true