aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Algorithm-Evolutionary
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2008-07-03 17:09:58 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2008-07-03 17:09:58 +0000
commite5f1ca1e393b17cc08ae1b71c0fc14640edf1b03 (patch)
treeb9db6465acf9b43d5e6bbd6005ed437cbc73bbd4 /devel/p5-Algorithm-Evolutionary
parentfb738210d07c6f516ee24700b728bb01959b1d52 (diff)
downloadports-e5f1ca1e393b17cc08ae1b71c0fc14640edf1b03.tar.gz
ports-e5f1ca1e393b17cc08ae1b71c0fc14640edf1b03.zip
Notes
Diffstat (limited to 'devel/p5-Algorithm-Evolutionary')
-rw-r--r--devel/p5-Algorithm-Evolutionary/Makefile30
-rw-r--r--devel/p5-Algorithm-Evolutionary/distinfo6
-rw-r--r--devel/p5-Algorithm-Evolutionary/pkg-descr2
-rw-r--r--devel/p5-Algorithm-Evolutionary/pkg-plist21
4 files changed, 46 insertions, 13 deletions
diff --git a/devel/p5-Algorithm-Evolutionary/Makefile b/devel/p5-Algorithm-Evolutionary/Makefile
index 81cb7f729138..89acd88798a2 100644
--- a/devel/p5-Algorithm-Evolutionary/Makefile
+++ b/devel/p5-Algorithm-Evolutionary/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= Algorithm-Evolutionary
-PORTVERSION= 0.54
-PORTREVISION= 1
+PORTVERSION= 0.60
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -18,15 +17,26 @@ COMMENT= A library for doing evolutionary computation in Perl
BUILD_DEPENDS= p5-XML-LibXML>=1.5:${PORTSDIR}/textproc/p5-XML-LibXML
RUN_DEPENDS= p5-Algorithm-Permute>=0.01:${PORTSDIR}/devel/p5-Algorithm-Permute \
+ p5-Clone-Fast>=0:${PORTSDIR}/devel/p5-Clone-Fast \
p5-Math-Random>=0.63:${PORTSDIR}/math/p5-Math-Random \
+ p5-String-Random>=0:${PORTSDIR}/devel/p5-String-Random \
p5-Tree-DAG_Node>=1.04:${PORTSDIR}/devel/p5-Tree-DAG_Node \
p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser \
- p5-XML-Parser-EasyTree>=0.01:${PORTSDIR}/textproc/p5-XML-Parser-EasyTree
+ p5-XML-Parser-EasyTree>=0.01:${PORTSDIR}/textproc/p5-XML-Parser-EasyTree \
+ p5-YAML>=0:${PORTSDIR}/textproc/p5-YAML
PERL_CONFIGURE= yes
MAN3= Algorithm::Evolutionary.3 \
Algorithm::Evolutionary::Experiment.3 \
+ Algorithm::Evolutionary::Fitness::Base.3 \
+ Algorithm::Evolutionary::Fitness::Knapsack.3 \
+ Algorithm::Evolutionary::Fitness::MMDP.3 \
+ Algorithm::Evolutionary::Fitness::ONEMAX.3 \
+ Algorithm::Evolutionary::Fitness::P_Peaks.3 \
+ Algorithm::Evolutionary::Fitness::Royal_Road.3 \
+ Algorithm::Evolutionary::Fitness::String.3 \
+ Algorithm::Evolutionary::Fitness::wP_Peaks.3 \
Algorithm::Evolutionary::Individual::Base.3 \
Algorithm::Evolutionary::Individual::BitString.3 \
Algorithm::Evolutionary::Individual::String.3 \
@@ -58,7 +68,19 @@ MAN3= Algorithm::Evolutionary.3 \
Algorithm::Evolutionary::Op::TournamentSelect.3 \
Algorithm::Evolutionary::Op::TreeMutation.3 \
Algorithm::Evolutionary::Op::VectorCrossover.3 \
+ Algorithm::Evolutionary::Run.3 \
+ Algorithm::Evolutionary::Utils.3 \
Algorithm::Evolutionary::Wheel.3 \
Algorithm::Evolutionary::XML.3
-.include <bsd.port.mk>
+post-patch:
+ ${PERL} -pi -e 's/(.*?(\S+::Wheel).*)/use \2;\1/' ${WRKSRC}/lib/Algorithm/Evolutionary/Op/GeneralGeneration.pm
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500703
+RUN_DEPENDS+= p5-Memoize>=0:${PORTSDIR}/devel/p5-Memoize \
+ p5-Time-HiRes>=0:${PORTSDIR}/devel/p5-Time-HiRes
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Algorithm-Evolutionary/distinfo b/devel/p5-Algorithm-Evolutionary/distinfo
index 30656c5861c5..91997cc358aa 100644
--- a/devel/p5-Algorithm-Evolutionary/distinfo
+++ b/devel/p5-Algorithm-Evolutionary/distinfo
@@ -1,3 +1,3 @@
-MD5 (Algorithm-Evolutionary-0.54.tar.gz) = 5af257efc7c296a1f6271bd92bdb5ad6
-SHA256 (Algorithm-Evolutionary-0.54.tar.gz) = 6379fe4218305c98c9caf207fa31d19a679015ce11c4971fc0a982b9e946c1a0
-SIZE (Algorithm-Evolutionary-0.54.tar.gz) = 51316
+MD5 (Algorithm-Evolutionary-0.60.tar.gz) = f4e19feb347cc0e2ab0728f767acf0df
+SHA256 (Algorithm-Evolutionary-0.60.tar.gz) = 58dd4702c1660c36de1ef894b65cad54f437436cef555be1a7c975a5dee15971
+SIZE (Algorithm-Evolutionary-0.60.tar.gz) = 63719
diff --git a/devel/p5-Algorithm-Evolutionary/pkg-descr b/devel/p5-Algorithm-Evolutionary/pkg-descr
index 988355f8a45b..89a450dda6b1 100644
--- a/devel/p5-Algorithm-Evolutionary/pkg-descr
+++ b/devel/p5-Algorithm-Evolutionary/pkg-descr
@@ -11,5 +11,5 @@ The design principles of Algorithm::Evolutionary are:
could make Algorithm::Evolutionary interoperable with other EA libraries,
such as EO or JEO.
-WWW: http://opeal.sourceforge.net/
WWW: http://search.cpan.org/dist/Algorithm-Evolutionary/
+WWW: http://opeal.sourceforge.net/
diff --git a/devel/p5-Algorithm-Evolutionary/pkg-plist b/devel/p5-Algorithm-Evolutionary/pkg-plist
index 44d5fd1b890d..a6f003795327 100644
--- a/devel/p5-Algorithm-Evolutionary/pkg-plist
+++ b/devel/p5-Algorithm-Evolutionary/pkg-plist
@@ -1,8 +1,14 @@
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/Evolutionary/.packlist
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/Evolutionary
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm
%%SITE_PERL%%/Algorithm/Evolutionary.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Experiment.pm
+%%SITE_PERL%%/Algorithm/Evolutionary/Fitness/Base.pm
+%%SITE_PERL%%/Algorithm/Evolutionary/Fitness/Knapsack.pm
+%%SITE_PERL%%/Algorithm/Evolutionary/Fitness/MMDP.pm
+%%SITE_PERL%%/Algorithm/Evolutionary/Fitness/ONEMAX.pm
+%%SITE_PERL%%/Algorithm/Evolutionary/Fitness/P_Peaks.pm
+%%SITE_PERL%%/Algorithm/Evolutionary/Fitness/Royal_Road.pm
+%%SITE_PERL%%/Algorithm/Evolutionary/Fitness/String.pm
+%%SITE_PERL%%/Algorithm/Evolutionary/Fitness/wP_Peaks.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Individual/Base.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Individual/BitString.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Individual/String.pm
@@ -34,9 +40,14 @@
%%SITE_PERL%%/Algorithm/Evolutionary/Op/TournamentSelect.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Op/TreeMutation.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Op/VectorCrossover.pm
+%%SITE_PERL%%/Algorithm/Evolutionary/Run.pm
+%%SITE_PERL%%/Algorithm/Evolutionary/Utils.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Wheel.pm
%%SITE_PERL%%/Algorithm/Evolutionary/XML.pod
-@dirrm %%SITE_PERL%%/Algorithm/Evolutionary/Individual
-@dirrm %%SITE_PERL%%/Algorithm/Evolutionary/Op
-@dirrm %%SITE_PERL%%/Algorithm/Evolutionary
+@dirrmtry %%SITE_PERL%%/Algorithm/Evolutionary/Op
+@dirrmtry %%SITE_PERL%%/Algorithm/Evolutionary/Individual
+@dirrmtry %%SITE_PERL%%/Algorithm/Evolutionary/Fitness
+@dirrmtry %%SITE_PERL%%/Algorithm/Evolutionary
@dirrmtry %%SITE_PERL%%/Algorithm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/Evolutionary
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm