aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Algorithm-Evolutionary
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-03-20 19:07:42 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-03-20 19:07:42 +0000
commitf15ec26975baa5594877276ee7b07de0336aca03 (patch)
treeec1ff6822ec8bbf285a6b97a69270625f302a7b2 /devel/p5-Algorithm-Evolutionary
parentffb4b5fc29132416a602609f56952ffab5b48989 (diff)
downloadports-f15ec26975baa5594877276ee7b07de0336aca03.tar.gz
ports-f15ec26975baa5594877276ee7b07de0336aca03.zip
Notes
Diffstat (limited to 'devel/p5-Algorithm-Evolutionary')
-rw-r--r--devel/p5-Algorithm-Evolutionary/Makefile6
-rw-r--r--devel/p5-Algorithm-Evolutionary/distinfo6
-rw-r--r--devel/p5-Algorithm-Evolutionary/pkg-plist10
3 files changed, 13 insertions, 9 deletions
diff --git a/devel/p5-Algorithm-Evolutionary/Makefile b/devel/p5-Algorithm-Evolutionary/Makefile
index 884d268ddbaf..759cfb5a94fa 100644
--- a/devel/p5-Algorithm-Evolutionary/Makefile
+++ b/devel/p5-Algorithm-Evolutionary/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= Algorithm-Evolutionary
-PORTVERSION= 0.64
+PORTVERSION= 0.65
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -27,7 +27,8 @@ RUN_DEPENDS= p5-Algorithm-Permute>=0.01:${PORTSDIR}/devel/p5-Algorithm-Permute \
PERL_CONFIGURE= yes
-MAN1= tide_bitstring.pl.1 tide_float.pl.1
+MAN1= tide_bitstring.pl.1 tide_float.pl.1 \
+ canonical-genetic-algorithm.pl.1
MAN3= Algorithm::Evolutionary.3 \
Algorithm::Evolutionary::Experiment.3 \
Algorithm::Evolutionary::Fitness::Base.3 \
@@ -76,6 +77,7 @@ MAN3= Algorithm::Evolutionary.3 \
Algorithm::Evolutionary::Op::Storing.3 \
Algorithm::Evolutionary::Op::TournamentSelect.3 \
Algorithm::Evolutionary::Op::TreeMutation.3 \
+ Algorithm::Evolutionary::Op::Uniform_Crossover.3 \
Algorithm::Evolutionary::Op::VectorCrossover.3 \
Algorithm::Evolutionary::Run.3 \
Algorithm::Evolutionary::Utils.3 \
diff --git a/devel/p5-Algorithm-Evolutionary/distinfo b/devel/p5-Algorithm-Evolutionary/distinfo
index 02a1fb74475d..68d97dfddd3c 100644
--- a/devel/p5-Algorithm-Evolutionary/distinfo
+++ b/devel/p5-Algorithm-Evolutionary/distinfo
@@ -1,3 +1,3 @@
-MD5 (Algorithm-Evolutionary-0.64.tar.gz) = a4d77cfd4b6883cb6cef0f032efb21be
-SHA256 (Algorithm-Evolutionary-0.64.tar.gz) = 7231da45e95a15017eaacad89842cb15dc1347a6f96cd230918b63c2ddebc0fc
-SIZE (Algorithm-Evolutionary-0.64.tar.gz) = 76231
+MD5 (Algorithm-Evolutionary-0.65.tar.gz) = c5c26f12f6ee0163a5550799820acd44
+SHA256 (Algorithm-Evolutionary-0.65.tar.gz) = 5d3bafd42103912b6d6394db5e3bce3e78bcb5f6b2e19abf6b2d439596b3821a
+SIZE (Algorithm-Evolutionary-0.65.tar.gz) = 78737
diff --git a/devel/p5-Algorithm-Evolutionary/pkg-plist b/devel/p5-Algorithm-Evolutionary/pkg-plist
index db586a2b2268..0c81aeb93863 100644
--- a/devel/p5-Algorithm-Evolutionary/pkg-plist
+++ b/devel/p5-Algorithm-Evolutionary/pkg-plist
@@ -1,6 +1,6 @@
+bin/canonical-genetic-algorithm.pl
bin/tide_bitstring.pl
bin/tide_float.pl
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/Evolutionary/.packlist
%%SITE_PERL%%/Algorithm/Evolutionary.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Experiment.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Fitness/Base.pm
@@ -12,7 +12,6 @@ bin/tide_float.pl
%%SITE_PERL%%/Algorithm/Evolutionary/Fitness/Royal_Road.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Fitness/String.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Fitness/wP_Peaks.pm
-%%SITE_PERL%%/Algorithm/Evolutionary/Individual
%%SITE_PERL%%/Algorithm/Evolutionary/Individual/Base.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Individual/BitString.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Individual/Bit_Vector.pm
@@ -50,15 +49,18 @@ bin/tide_float.pl
%%SITE_PERL%%/Algorithm/Evolutionary/Op/Storing.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Op/TournamentSelect.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Op/TreeMutation.pm
+%%SITE_PERL%%/Algorithm/Evolutionary/Op/Uniform_Crossover.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Op/VectorCrossover.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Run.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Utils.pm
%%SITE_PERL%%/Algorithm/Evolutionary/Wheel.pm
%%SITE_PERL%%/Algorithm/Evolutionary/XML.pod
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/Evolutionary/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/Evolutionary
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto
@dirrmtry %%SITE_PERL%%/Algorithm/Evolutionary/Op
@dirrmtry %%SITE_PERL%%/Algorithm/Evolutionary/Individual
@dirrmtry %%SITE_PERL%%/Algorithm/Evolutionary/Fitness
@dirrmtry %%SITE_PERL%%/Algorithm/Evolutionary
@dirrmtry %%SITE_PERL%%/Algorithm
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/Evolutionary
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm