aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Algorithm-LCS
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2005-09-14 20:14:43 +0000
committerLars Thegler <lth@FreeBSD.org>2005-09-14 20:14:43 +0000
commit3d639f4dfb42bd13cf66b935af3d6db0e0cdfc8f (patch)
tree9566ed7d432388decb550f81d2497d6290ad99ad /devel/p5-Algorithm-LCS
parent42097b596c1e944804f9a7610505649fa137bf2b (diff)
downloadports-3d639f4dfb42bd13cf66b935af3d6db0e0cdfc8f.tar.gz
ports-3d639f4dfb42bd13cf66b935af3d6db0e0cdfc8f.zip
Notes
Diffstat (limited to 'devel/p5-Algorithm-LCS')
-rw-r--r--devel/p5-Algorithm-LCS/Makefile28
-rw-r--r--devel/p5-Algorithm-LCS/distinfo2
-rw-r--r--devel/p5-Algorithm-LCS/pkg-descr4
-rw-r--r--devel/p5-Algorithm-LCS/pkg-plist7
4 files changed, 41 insertions, 0 deletions
diff --git a/devel/p5-Algorithm-LCS/Makefile b/devel/p5-Algorithm-LCS/Makefile
new file mode 100644
index 000000000000..299134196c02
--- /dev/null
+++ b/devel/p5-Algorithm-LCS/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: Algorithm::LCS
+# Date created: 26 July 2005
+# Whom: tiger@whitetigersd.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= Algorithm-LCS
+PORTVERSION= 1.04
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/J/JO/JOESUF
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tiger@whitetigersd.com
+COMMENT= Fast (XS) implementation of the Longest Common Subsequence Algorithm
+
+PERL_CONFIGURE= yes
+MAN3= Algorithm::LCS.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= Perl 5.8 or newer required. Install lang/perl5.8 and try again.
+.endif
+
+.include <bsd.port.post.mk>
+
diff --git a/devel/p5-Algorithm-LCS/distinfo b/devel/p5-Algorithm-LCS/distinfo
new file mode 100644
index 000000000000..2bfb0303f4d2
--- /dev/null
+++ b/devel/p5-Algorithm-LCS/distinfo
@@ -0,0 +1,2 @@
+MD5 (Algorithm-LCS-1.04.tar.gz) = 741a53415523eade93a006899cbe15aa
+SIZE (Algorithm-LCS-1.04.tar.gz) = 10149
diff --git a/devel/p5-Algorithm-LCS/pkg-descr b/devel/p5-Algorithm-LCS/pkg-descr
new file mode 100644
index 000000000000..6b746dcf8120
--- /dev/null
+++ b/devel/p5-Algorithm-LCS/pkg-descr
@@ -0,0 +1,4 @@
+Algorithm::LCS reimplements Algorithm::Diff's core loop in XS,
+and provides a simple OO interface to it.
+
+WWW: http://search.cpan.org/dist/Algorithm-LCS/
diff --git a/devel/p5-Algorithm-LCS/pkg-plist b/devel/p5-Algorithm-LCS/pkg-plist
new file mode 100644
index 000000000000..70cb23917c00
--- /dev/null
+++ b/devel/p5-Algorithm-LCS/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Algorithm/LCS.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/LCS/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/LCS/LCS.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/LCS/LCS.so
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/LCS 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/Algorithm 2>/dev/null || true