aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Algorithm-MinMax
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2004-10-28 09:41:18 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2004-10-28 09:41:18 +0000
commita52ebce9f284810e1de71a76ed0f44efb7890f48 (patch)
treeff80ec35b4a4f7d8d6c24759b5f7d91fc95982f2 /devel/p5-Algorithm-MinMax
parentee22df37979aea28b5cbc4db3ac78ec56a1aa11f (diff)
downloadports-a52ebce9f284810e1de71a76ed0f44efb7890f48.tar.gz
ports-a52ebce9f284810e1de71a76ed0f44efb7890f48.zip
Notes
Diffstat (limited to 'devel/p5-Algorithm-MinMax')
-rw-r--r--devel/p5-Algorithm-MinMax/Makefile22
-rw-r--r--devel/p5-Algorithm-MinMax/distinfo2
-rw-r--r--devel/p5-Algorithm-MinMax/pkg-descr7
-rw-r--r--devel/p5-Algorithm-MinMax/pkg-plist5
4 files changed, 36 insertions, 0 deletions
diff --git a/devel/p5-Algorithm-MinMax/Makefile b/devel/p5-Algorithm-MinMax/Makefile
new file mode 100644
index 000000000000..d5d929179089
--- /dev/null
+++ b/devel/p5-Algorithm-MinMax/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: Algorithm::MinMax
+# Date created: Thu Oct 28 17:18:43 CST 2004
+# Whom: clsung
+#
+# $FreeBSD$
+#
+
+PORTNAME= Algorithm-MinMax
+PORTVERSION= 0.01
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Algorithm
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= Perl modules to find the minimum and maximum of an array
+
+PERL_CONFIGURE= yes
+
+MAN3= Algorithm::MinMax.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Algorithm-MinMax/distinfo b/devel/p5-Algorithm-MinMax/distinfo
new file mode 100644
index 000000000000..0bbda950c3fb
--- /dev/null
+++ b/devel/p5-Algorithm-MinMax/distinfo
@@ -0,0 +1,2 @@
+MD5 (Algorithm-MinMax-0.01.tar.gz) = 4fbc998d532bc883503eb4db764149ba
+SIZE (Algorithm-MinMax-0.01.tar.gz) = 2144
diff --git a/devel/p5-Algorithm-MinMax/pkg-descr b/devel/p5-Algorithm-MinMax/pkg-descr
new file mode 100644
index 000000000000..ce26049bf982
--- /dev/null
+++ b/devel/p5-Algorithm-MinMax/pkg-descr
@@ -0,0 +1,7 @@
+Algorithm::MinMax finds the minimum and maximum of a given
+array with at most 3n/2 - 2 comparisons, where n is the
+number of elements of the array.
+
+WWW: http://search.cpan.org/dist/Algorithm-MinMax
+
+--clsung
diff --git a/devel/p5-Algorithm-MinMax/pkg-plist b/devel/p5-Algorithm-MinMax/pkg-plist
new file mode 100644
index 000000000000..97d7fd24de50
--- /dev/null
+++ b/devel/p5-Algorithm-MinMax/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Algorithm/MinMax.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/MinMax/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/MinMax
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Algorithm 2>/dev/null || true