aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Algorithm-NaiveBayes
diff options
context:
space:
mode:
authorFoxfair Hu <foxfair@FreeBSD.org>2003-10-28 15:26:49 +0000
committerFoxfair Hu <foxfair@FreeBSD.org>2003-10-28 15:26:49 +0000
commit69ee5c4ce8f7676a07f5083e6406cd6c15f8e435 (patch)
tree98a0255155c961773b8f2b030c394c4acd9c1c85 /devel/p5-Algorithm-NaiveBayes
parent7f69be7b9643fb6002103a9b858e62f5ba912d17 (diff)
downloadports-69ee5c4ce8f7676a07f5083e6406cd6c15f8e435.tar.gz
ports-69ee5c4ce8f7676a07f5083e6406cd6c15f8e435.zip
Notes
Diffstat (limited to 'devel/p5-Algorithm-NaiveBayes')
-rw-r--r--devel/p5-Algorithm-NaiveBayes/Makefile22
-rw-r--r--devel/p5-Algorithm-NaiveBayes/distinfo1
-rw-r--r--devel/p5-Algorithm-NaiveBayes/pkg-descr12
-rw-r--r--devel/p5-Algorithm-NaiveBayes/pkg-plist6
4 files changed, 41 insertions, 0 deletions
diff --git a/devel/p5-Algorithm-NaiveBayes/Makefile b/devel/p5-Algorithm-NaiveBayes/Makefile
new file mode 100644
index 000000000000..787ad57747e7
--- /dev/null
+++ b/devel/p5-Algorithm-NaiveBayes/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: Algorithm::NaiveBayes
+# Date created: Oct 25 2003
+# Whom: clsung@dragon2.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= Algorithm-NaiveBayes
+PORTVERSION= 0.02
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Algorithm
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@dragon2.net
+COMMENT= Perl class performing Bayesian prediction of categories
+
+PERL_CONFIGURE= yes
+
+MAN3= Algorithm::NaiveBayes.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Algorithm-NaiveBayes/distinfo b/devel/p5-Algorithm-NaiveBayes/distinfo
new file mode 100644
index 000000000000..c49c4ba8f18a
--- /dev/null
+++ b/devel/p5-Algorithm-NaiveBayes/distinfo
@@ -0,0 +1 @@
+MD5 (Algorithm-NaiveBayes-0.02.tar.gz) = 3477830a254449a26c5eb3e4c85b0054
diff --git a/devel/p5-Algorithm-NaiveBayes/pkg-descr b/devel/p5-Algorithm-NaiveBayes/pkg-descr
new file mode 100644
index 000000000000..c09f6fe38e7d
--- /dev/null
+++ b/devel/p5-Algorithm-NaiveBayes/pkg-descr
@@ -0,0 +1,12 @@
+This module implements the classic "Naive Bayes" machine learning algorithm.
+It is a well-studied probabilistic algorithm often used in automatic text
+categorization. Compared to other algorithms (kNN, SVM, Decision Trees),
+it's pretty fast and reasonably competitive in the quality of its results.
+
+A paper by Fabrizio Sebastiani provides a really good introduction to
+text categorization:
+http://faure.iei.pi.cnr.it/~fabrizio/Publications/ACMCS02.pdf
+
+WWW: http://search.cpan.org/dist/Algorithm-NaiveBayes/
+
+Author: Ken Williams <ken@mathforum.org>
diff --git a/devel/p5-Algorithm-NaiveBayes/pkg-plist b/devel/p5-Algorithm-NaiveBayes/pkg-plist
new file mode 100644
index 000000000000..51df9bb6afe8
--- /dev/null
+++ b/devel/p5-Algorithm-NaiveBayes/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/Algorithm/NaiveBayes.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/NaiveBayes/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/NaiveBayes
+@dirrm %%SITE_PERL%%/Algorithm
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Algorithm 2>/dev/null || true