aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Alias
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-01-01 05:45:34 +0000
committerWill Andrews <will@FreeBSD.org>2001-01-01 05:45:34 +0000
commit6056b08c587c78dfe5869f9551812e09eaa6a347 (patch)
tree11ff68fd7059f08b8bf238afac6852ce8bd16eb5 /devel/p5-Alias
parent81bb73551fba73c956717f95262a23442de0865a (diff)
downloadports-6056b08c587c78dfe5869f9551812e09eaa6a347.tar.gz
ports-6056b08c587c78dfe5869f9551812e09eaa6a347.zip
Notes
Diffstat (limited to 'devel/p5-Alias')
-rw-r--r--devel/p5-Alias/Makefile26
-rw-r--r--devel/p5-Alias/distinfo1
-rw-r--r--devel/p5-Alias/pkg-comment1
-rw-r--r--devel/p5-Alias/pkg-descr14
-rw-r--r--devel/p5-Alias/pkg-plist5
5 files changed, 47 insertions, 0 deletions
diff --git a/devel/p5-Alias/Makefile b/devel/p5-Alias/Makefile
new file mode 100644
index 000000000000..f68696776c27
--- /dev/null
+++ b/devel/p5-Alias/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: Alias
+# Date created: 04 Nov 2000
+# Whom: will
+#
+# $FreeBSD$
+#
+
+PORTNAME= Alias
+PORTVERSION= 2.32
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Alias
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_PERL5= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Alias.3
+
+do-configure:
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
+ CC="${CC}" CCFLAGS="${CFLAGS}"
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Alias/distinfo b/devel/p5-Alias/distinfo
new file mode 100644
index 000000000000..0e2e082d1317
--- /dev/null
+++ b/devel/p5-Alias/distinfo
@@ -0,0 +1 @@
+MD5 (Alias-2.32.tar.gz) = 74aee28a4a20e643dd7656c6d8096aa8
diff --git a/devel/p5-Alias/pkg-comment b/devel/p5-Alias/pkg-comment
new file mode 100644
index 000000000000..0f18e26c0e43
--- /dev/null
+++ b/devel/p5-Alias/pkg-comment
@@ -0,0 +1 @@
+A perl module that performs aliasing services
diff --git a/devel/p5-Alias/pkg-descr b/devel/p5-Alias/pkg-descr
new file mode 100644
index 000000000000..6575ad7a8cc2
--- /dev/null
+++ b/devel/p5-Alias/pkg-descr
@@ -0,0 +1,14 @@
+Alias is a perl module that performs aliasing services. It is useful for
+those of you that are tired of dereferencing hash-based object attributes,
+or wish perl could make-do with fewer $, -> and {} things, or are a little
+scared of using typeglobs, or want the freedom to put what you want, when you
+want in the symbol table without having to deal with wierd syntax, or need
+to use scalar constants in your program since you don't trust yourself from
+changing $PI (heh). Most notably, there is a C<attr> function that installs
+a whole hash on the symbol table with implicit localization. This allows
+you to access object attributes without having to deref the object every
+time, as in most other OO languages.
+
+Author: Sarathy <gsar@umich.edu>
+
+--will
diff --git a/devel/p5-Alias/pkg-plist b/devel/p5-Alias/pkg-plist
new file mode 100644
index 000000000000..6b52838759d0
--- /dev/null
+++ b/devel/p5-Alias/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Alias.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Alias/Alias.so
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Alias/Alias.bs
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Alias/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Alias