aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Alien-SDL/Makefile
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-11-07 16:35:50 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-11-07 16:35:50 +0000
commit8928eb6dc4a7a5aa423c306a93225ae767726736 (patch)
tree5ae34269b964f4df900c811c4843c49ea3e3b6ca /devel/p5-Alien-SDL/Makefile
parent4debbc7ab535d4680210b33683c13b00ddbdcc7c (diff)
Add new port devel/p5-Alien-SDL:
Alien::SDL can be used to detect and get configuration settings from an installed SDL and related libraries. WWW: http://search.cpan.org/dist/Alien-SDL/
Notes
Notes: svn path=/head/; revision=333134
Diffstat (limited to 'devel/p5-Alien-SDL/Makefile')
-rw-r--r--devel/p5-Alien-SDL/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/devel/p5-Alien-SDL/Makefile b/devel/p5-Alien-SDL/Makefile
new file mode 100644
index 000000000000..9ee3b5803d33
--- /dev/null
+++ b/devel/p5-Alien-SDL/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= Alien-SDL
+PORTVERSION= 1.440
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= makc@FreeBSD.org
+COMMENT= Detect and get configuration setting for SDL
+
+LICENSE= GPLv2
+
+BUILD_DEPENDS:= ${RUN_DEPENDS} \
+ p5-Text-Patch>=1.4:${PORTSDIR}/textproc/p5-Text-Patch
+RUN_DEPENDS= p5-File-Which>=0:${PORTSDIR}/sysutils/p5-File-Which \
+ p5-File-ShareDir>=0:${PORTSDIR}/devel/p5-File-ShareDir \
+ p5-Capture-Tiny>=0:${PORTSDIR}/devel/p5-Capture-Tiny
+
+USES= perl5
+USE_PERL5= modbuild
+USE_SDL= gfx image mixer pango sdl ttf
+CONFIGURE_ARGS= --with-sdl-config=${SDL_CONFIG}
+
+.include <bsd.port.mk>